From: shuah <shuah@kernel.org>
To: Mark Brown <broonie@kernel.org>
Cc: linux-kernel@vger.kernel.org, linux-kselftest@vger.kernel.org,
shuah <shuah@kernel.org>
Subject: Re: [PATCH v3 0/3] selftests: vdso: Add a selftest for vDSO getcpu()
Date: Fri, 22 May 2020 12:13:25 -0600 [thread overview]
Message-ID: <24b15074-7135-38d7-d491-76087d949498@kernel.org> (raw)
In-Reply-To: <20200522162139.44380-1-broonie@kernel.org>
On 5/22/20 10:21 AM, Mark Brown wrote:
> This series does a bit of a cleanup of the existing tests for the vDSO
> in kselftest and then adds a new test for getcpu().
>
> v3: Remove some extern keywords.
> v2: Silence checkpatch
>
> Mark Brown (3):
> selftests: vdso: Rename vdso_test to vdso_test_gettimeofday
> selftests: vdso: Use a header file to prototype parse_vdso API
> selftests: vdso: Add a selftest for vDSO getcpu()
>
> tools/testing/selftests/vDSO/.gitignore | 2 +
> tools/testing/selftests/vDSO/Makefile | 5 +-
> tools/testing/selftests/vDSO/parse_vdso.c | 24 +--------
> tools/testing/selftests/vDSO/parse_vdso.h | 31 +++++++++++
> .../selftests/vDSO/vdso_standalone_test_x86.c | 4 +-
> .../testing/selftests/vDSO/vdso_test_getcpu.c | 54 +++++++++++++++++++
> .../{vdso_test.c => vdso_test_gettimeofday.c} | 10 ++--
> 7 files changed, 96 insertions(+), 34 deletions(-)
> create mode 100644 tools/testing/selftests/vDSO/parse_vdso.h
> create mode 100644 tools/testing/selftests/vDSO/vdso_test_getcpu.c
> rename tools/testing/selftests/vDSO/{vdso_test.c => vdso_test_gettimeofday.c} (84%)
>
Thanks for the cleaning this up and the rework.
Applied to linux-kselftest next for Linux 5.8-rc1
thanks,
-- Shuah
prev parent reply other threads:[~2020-05-22 18:13 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-22 16:21 Mark Brown
2020-05-22 16:21 ` [PATCH v3 1/3] selftests: vdso: Rename vdso_test to vdso_test_gettimeofday Mark Brown
2020-05-22 16:21 ` [PATCH v3 2/3] selftests: vdso: Use a header file to prototype parse_vdso API Mark Brown
2020-05-22 16:21 ` [PATCH v3 3/3] selftests: vdso: Add a selftest for vDSO getcpu() Mark Brown
2020-05-22 18:13 ` shuah [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=24b15074-7135-38d7-d491-76087d949498@kernel.org \
--to=shuah@kernel.org \
--cc=broonie@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®