mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: James Morse <james.morse@arm.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	shameerali.kolothum.thodi@huawei.com,
	D Scott Phillips OS <scott@os.amperecomputing.com>,
	carl@os.amperecomputing.com, lcherian@marvell.com,
	bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
	baolin.wang@linux.alibaba.com,
	Jamie Iles <quic_jiles@quicinc.com>,
	Xin Hao <xhao@linux.alibaba.com>,
	peternewman@google.com, dfustini@baylibre.com,
	amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
	Rex Nie <rex.nie@jaguarmicro.com>,
	Dave Martin <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
	Shanker Donthineni <sdonthineni@nvidia.com>,
	fenghuay@nvidia.com, Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>,
	Tony Luck <tony.luck@intel.com>
Subject: Re: [PATCH v8 12/21] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl
Date: Thu, 24 Apr 2025 10:25:49 +0100	[thread overview]
Message-ID: <250f8ff8-8576-4280-a9aa-9939090b4d31@arm.com> (raw)
In-Reply-To: <b87f4c98-ef7b-44e7-ad25-8b2003bea5c3@intel.com>

Hi Reinette,

On 17/04/2025 23:46, Reinette Chatre wrote:
>> diff --git a/arch/x86/include/asm/resctrl.h b/arch/x86/include/asm/resctrl.h
>> index 7a39728b0743..6eb7d5c94c7a 100644
>> --- a/arch/x86/include/asm/resctrl.h
>> +++ b/arch/x86/include/asm/resctrl.h
>> @@ -210,6 +210,9 @@ int resctrl_arch_measure_l2_residency(void *_plr);
>>  int resctrl_arch_measure_l3_residency(void *_plr);
>>  void resctrl_cpu_detect(struct cpuinfo_x86 *c);
>>  
>> +bool resctrl_arch_get_cdp_enabled(enum resctrl_res_level l);
>> +int resctrl_arch_set_cdp_enabled(enum resctrl_res_level l, bool enable);

> I noticed this while reading through the telemetry work ... the custom
> appears to be for all arch helpers to be declared in include/linux/resctrl.h
> making these two stand out. What motivated their inclusion into
> arch/x86/include/asm/resctrl.h?

Doing some archaeology ... it looks like this dates from the era when MPAM had stub
versions of these because it didn't support/emulate CDP. Having these in the arch code's
header meant the static-inline stubs could be inlined into resctrl. x86 has an inline
version before this patch, but I moved it out of line to avoid exposing the array of all
resources. (which in turn would suggest changing the name, which isn't worth the churn)

I was assuming only x86 would ever support CDP, but since then, emulating CDP using the
separate I/D PARTID values MPAM has proved feasible.

I'll move them.


> If they move to include/linux/resctrl.h it looks like enum resctrl_res_level is
> no longer required to be in include/linux/resctrl_types.h.

Yes. I'll add a patch move it, but it feels like churn.


> Looking further, from commit f16adbaf9272 ("x86/resctrl: Move resctrl types to a separate header")
> the motivation for including enum resctrl_event_id is to support 
> resctrl_arch_mon_ctx_alloc() and resctrl_arch_mon_ctx_free(), but looking
> at their definitions in arch/x86/include/asm/resctrl.h they are using "int evtid"
> instead of enum resctrl_event_id. Looks like their definitions need to
> change?

Bother. The MPAM definition of those has the enum type, I'd missed that the x86 stub
swallowed the type. I'll fix that.


> I assume the pseudo-locking arch helpers are placed in arch/x86/include/asm/resctrl.h
> with the implicit knowledge that only x86 will set CONFIG_RESCTRL_FS_PSEUDO_LOCK so
> avoiding that extra handling in include/linux/resctrl.h?

Given how specific that is to x86, I think it will only ever be enabled there.
For arm, things like the prefetcher can't be disabled by linux. I would assume risc-v is
structurally the same.

Those definitions went into the arch header so that some architectures could inline the
stubs to let the compiler remove code that will never run.

I guess these could be defined both ways round in linux/resctrl.h depending on the Kconfig
symbol. At this point its churn, but this saves a third architecture having to define the
same list of stubs. (I reckon that is likely for risc-v).


Thanks,

James

  reply	other threads:[~2025-04-24  9:25 UTC|newest]

Thread overview: 69+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-11 16:42 [PATCH v8 00/21] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2025-04-11 16:42 ` [PATCH v8 01/21] x86/resctrl: Fix rdtgroup_mkdir()'s unlocked use of kernfs_node::name James Morse
2025-04-12  0:10   ` Fenghua Yu
2025-04-11 16:42 ` [PATCH v8 02/21] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-04-15 21:06   ` Reinette Chatre
2025-04-24  9:12   ` James Morse
2025-04-24 15:17     ` Reinette Chatre
2025-04-25  2:56   ` Shaopeng Tan (Fujitsu)
2025-04-25 15:56     ` James Morse
2025-04-11 16:42 ` [PATCH v8 03/21] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-04-15 21:11   ` Reinette Chatre
2025-04-24  9:12     ` James Morse
2025-04-11 16:42 ` [PATCH v8 04/21] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-04-16  0:25   ` Reinette Chatre
2025-04-24  9:15     ` James Morse
2025-04-11 16:42 ` [PATCH v8 05/21] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-04-11 16:42 ` [PATCH v8 06/21] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-04-11 16:42 ` [PATCH v8 07/21] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-04-15 18:56   ` Luck, Tony
2025-04-24  9:15     ` James Morse
2025-04-11 16:42 ` [PATCH v8 08/21] x86/resctrl: Expand the width of dom_id by replacing mon_data_bits James Morse
2025-04-16  0:34   ` Reinette Chatre
2025-04-24 11:15     ` James Morse
2025-04-22 17:06   ` Moger, Babu
2025-04-22 17:14     ` Luck, Tony
2025-04-22 17:59       ` Moger, Babu
2025-04-22 18:10         ` Luck, Tony
2025-04-11 16:42 ` [PATCH v8 09/21] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2025-04-25  2:32   ` Shaopeng Tan (Fujitsu)
2025-04-25 15:59     ` James Morse
2025-04-11 16:42 ` [PATCH v8 10/21] x86/resctrl: Split trace.h James Morse
2025-04-11 16:42 ` [PATCH v8 11/21] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-04-11 16:42 ` [PATCH v8 12/21] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-04-17 22:46   ` Reinette Chatre
2025-04-24  9:25     ` James Morse [this message]
2025-04-11 16:42 ` [PATCH v8 13/21] x86/resctrl: Squelch whitespace anomalies in resctrl core code James Morse
2025-04-11 16:42 ` [PATCH v8 14/21] x86/resctrl: Prefer alloc(sizeof(*foo)) idiom in rdt_init_fs_context() James Morse
2025-04-11 16:42 ` [PATCH v8 15/21] x86/resctrl: Relax some asm #includes James Morse
2025-04-16  2:08   ` Reinette Chatre
2025-04-11 16:42 ` [PATCH v8 16/21] x86/resctrl: Always initialise rid field in rdt_resources_all[] James Morse
2025-04-15 19:08   ` Luck, Tony
2025-04-24 17:08     ` James Morse
2025-04-16  2:14   ` Reinette Chatre
2025-04-24 17:08     ` James Morse
2025-04-11 16:42 ` [PATCH v8 17/21] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl James Morse
2025-04-12  0:18   ` Fenghua Yu
2025-04-14 16:04     ` Reinette Chatre
2025-04-14 23:22       ` Fenghua Yu
2025-04-14 23:29         ` Reinette Chatre
2025-04-14 23:21     ` Fenghua Yu
2025-04-24 17:08       ` James Morse
2025-04-15  0:27   ` Fenghua Yu
2025-04-24 17:11     ` James Morse
2025-04-11 16:42 ` [PATCH v8 18/21] x86,fs/resctrl: Remove duplicated trace header files James Morse
2025-04-16  2:18   ` Reinette Chatre
2025-04-24 17:11     ` James Morse
2025-04-22 14:23   ` Fenghua Yu
2025-04-24 17:11     ` James Morse
2025-04-11 16:42 ` [PATCH v8 19/21] fs/resctrl: Remove unnecessary includes James Morse
2025-04-11 16:42 ` [PATCH v8 20/21] fs/resctrl: Change internal.h's header guard macros James Morse
2025-04-11 16:42 ` [PATCH v8 21/21] x86,fs/resctrl: Move resctrl.rst to live under Documentation/filesystems James Morse
2025-04-16  2:31   ` Reinette Chatre
2025-04-24 17:12     ` James Morse
2025-04-24 17:22       ` Reinette Chatre
2025-04-15 18:48 ` [PATCH v8 00/21] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl Luck, Tony
2025-04-24 17:12   ` James Morse
2025-04-17 12:18 ` Shaopeng Tan (Fujitsu)
2025-04-17 14:47   ` Reinette Chatre
2025-04-18  0:08     ` Moger, Babu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=250f8ff8-8576-4280-a9aa-9939090b4d31@arm.com \
    --to=james.morse@arm.com \
    --cc=Babu.Moger@amd.com \
    --cc=amitsinght@marvell.com \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=bobo.shaobowang@huawei.com \
    --cc=bp@alien8.de \
    --cc=carl@os.amperecomputing.com \
    --cc=dave.martin@arm.com \
    --cc=david@redhat.com \
    --cc=dfustini@baylibre.com \
    --cc=fenghuay@nvidia.com \
    --cc=hpa@zytor.com \
    --cc=kobak@nvidia.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peternewman@google.com \
    --cc=quic_jiles@quicinc.com \
    --cc=reinette.chatre@intel.com \
    --cc=rex.nie@jaguarmicro.com \
    --cc=scott@os.amperecomputing.com \
    --cc=sdonthineni@nvidia.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=tan.shaopeng@jp.fujitsu.com \
    --cc=tglx@linutronix.de \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    --cc=xhao@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®