From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757555AbbJVT3m (ORCPT ); Thu, 22 Oct 2015 15:29:42 -0400 Received: from [81.56.37.174] ([81.56.37.174]:53812 "EHLO zm3.1g6.biz" rhost-flags-FAIL-FAIL-OK-FAIL) by vger.kernel.org with ESMTP id S1753351AbbJVT3k convert rfc822-to-8bit (ORCPT ); Thu, 22 Oct 2015 15:29:40 -0400 DKIM-Filter: OpenDKIM Filter v2.9.2 zm3.1g6.biz B38A924A27CD Date: Thu, 22 Oct 2015 21:29:05 +0200 (CEST) From: Nicolas Parpandet To: linux-kernel@vger.kernel.org Cc: pcoustillas Message-ID: <25375254.368343.1445542145314.JavaMail.zimbra@1g6.biz> In-Reply-To: <1194508496.104744.1443945446284.JavaMail.zimbra@1g6.biz> References: <703659807.104689.1443944693452.JavaMail.zimbra@1g6.biz> <1194508496.104744.1443945446284.JavaMail.zimbra@1g6.biz> Subject: Re: nfs race condition MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8BIT X-Originating-IP: [10.1.20.141] X-Mailer: Zimbra 8.6.0_GA_1178 (ZimbraWebClient - FF37 (Linux)/8.6.0_GA_1178) Thread-Topic: aide google groupelemonde... ! Thread-Index: neddYyt9SsiGaYOnweZ3SQaxHc5dzb4JYwd0vJFyjG4= Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hello, I did some more investigations, (wireshark) The unlink of /tmp/crontab.vYPoHR/crontab is tranlated into a rename nfs call ? (.nfs file) NFS 670 V3 READDIRPLUS Reply (Call In 731) crontab .. . NFS 210 V3 LOOKUP Call (Reply In 734), DH: 0x038abb3d/.nfs000000000098008a00000019 NFS 194 V3 LOOKUP Reply (Call In 733) Error: NFS3ERR_NOENT NFS 254 V3 RENAME Call (Reply In 736), From DH: 0x038abb3d/crontab To DH: 0x038abb3d/.nfs000000000098008a00000019 NFS 338 V3 RENAME Reply (Call In 735) and after, it tries to remove the directory /tmp/crontab.0wuoNx : NFS 198 V3 RMDIR Call (Reply In 738), DH: 0x954c28ec/crontab.0wuoNx NFS 222 V3 RMDIR Reply (Call In 737) Error: NFS3ERR_NOTEMPTY but the file /tmp/crontab.0wuoNx/crontab was renamed instead of being removed (nfs network, I cannot see .nfs000 file in fact), this prevent the removing of the directory /tmp/crontab.0wuoNx (notempty) It seems a race condition, see "nfs silly rename" keyword, but I have the problem with mysql temp files, and crontab temp file (crontab -e), am I the only one doing mysql and crontabs over NFS !!!?!?, does anybody have a solution ? Regards Nicolas ----- Mail original ----- De: "npa" À: linux-kernel@vger.kernel.org Cc: "pcoustillas" Envoyé: Dimanche 4 Octobre 2015 09:57:26 Objet: nfs race condition Hello, I'm doing some " crontab -e, exit with :x" on NFS mount point, and there is a race condition whent removing temporary files : 7701 write(2, "No modification made\n", 21) = 21 7701 open("/tmp/crontab.vYPoHR", O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC) = 4 7701 getdents(4, {{d_ino=73336409, d_off=1, d_reclen=24, d_name="."} {d_ino=73335455, d_off=2, d_reclen=24, d_name=".."} {d_ino=73340547, d_off=3, d_reclen=32, d_name="crontab"}}, 32768) = 80 7701 unlink("/tmp/crontab.vYPoHR/crontab") = 0 7701 getdents(4, {}, 32768) = 0 7701 close(4) = 0 7701 rmdir("/tmp/crontab.vYPoHR") = -1 ENOTEMPTY (Directory not empty) 7701 write(2, "/tmp/crontab.vYPoHR: Directory n"..., 41) = 41 7701 socket(PF_FILE, SOCK_DGRAM|SOCK_CLOEXEC, 0) = 4 The unlink is really done after the rmdir, nfsv4 & nfsv3 over ipv6, so the rmdir fails and the directory isn't removed. I have same problem with mysql temporary files. If I mount with "nocto,noac,lookupcache=none" : same problem kernel version on server : 3.16.0-4-amd64 (debian8) kernel version on client : 2.6.32-39-pve (proxmox), same thing with 3.13.0-63-generic (ubuntu) Please answer me in CC, I'm not subscribed to the list. Regards Nicolas