From: Xiaoyao Li <xiaoyao.li@intel.com>
To: Sean Christopherson <seanjc@google.com>,
Paolo Bonzini <pbonzini@redhat.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
Yan Zhao <yan.y.zhao@intel.com>,
Rick Edgecombe <rick.p.edgecombe@intel.com>
Subject: Re: [PATCH] KVM: x86: Drop "cache" from user return MSR setter that skips WRMSR
Date: Tue, 23 Sep 2025 11:20:01 +0800 [thread overview]
Message-ID: <25a7a16f-ec73-4311-81ff-3adf62748040@intel.com> (raw)
In-Reply-To: <20250919214259.1584273-1-seanjc@google.com>
On 9/20/2025 5:42 AM, Sean Christopherson wrote:
> Rename kvm_user_return_msr_update_cache() to __kvm_set_user_return_msr()
> and use the helper kvm_set_user_return_msr() to make it obvious that the
^
the helper *in* kvm_set_user_return_msrs() ..
> double-underscores version is doing a subset of the work of the "full"
> setter.
>
> While the function does indeed update a cache, the nomenclature becomes
> slightly misleading when adding a getter[1], as the current value isn't
> _just_ the cached value, it's also the value that's currently loaded in
> hardware.
>
> Opportunistically rename "index" to "slot" in the prototypes. The user-
> return APIs deliberately use "slot" to try and make it more obvious that
> they take the slot within the array, not the index of the MSR.
>
> No functional change intended.
>
> Cc: Yan Zhao <yan.y.zhao@intel.com>
> Cc: Xiaoyao Li <xiaoyao.li@intel.com>
> Cc: Rick Edgecombe <rick.p.edgecombe@intel.com>
> Link: https://lore.kernel.org/all/aM2EvzLLmBi5-iQ5@google.com [1]
> Signed-off-by: Sean Christopherson <seanjc@google.com>
Reviewed-by: Xiaoyao Li <xiaoyao.li@intel.com>
next prev parent reply other threads:[~2025-09-23 3:20 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-19 21:42 Sean Christopherson
2025-09-23 3:20 ` Xiaoyao Li [this message]
2025-09-30 12:22 ` Yan Zhao
2025-09-30 12:58 ` Yan Zhao
2025-09-30 16:29 ` Sean Christopherson
2025-09-30 16:34 ` Sean Christopherson
2025-10-15 0:55 ` Yan Zhao
2025-10-15 16:19 ` Sean Christopherson
2025-10-16 8:58 ` Yan Zhao
2025-10-16 13:27 ` Hou Wenlong
2025-10-16 13:41 ` Sean Christopherson
2025-10-20 7:53 ` Yan Zhao
2025-10-16 13:05 ` Hou Wenlong
2025-10-03 13:53 ` Yan Zhao
2025-10-03 16:53 ` Sean Christopherson
2025-10-13 13:47 ` Yan Zhao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=25a7a16f-ec73-4311-81ff-3adf62748040@intel.com \
--to=xiaoyao.li@intel.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=rick.p.edgecombe@intel.com \
--cc=seanjc@google.com \
--cc=yan.y.zhao@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®