From: Petr Zejdl <petr.zejdl@cern.ch>
To: Jakub Kicinski <kuba@kernel.org>
Cc: petr.zejdl@cern.ch, "David S. Miller" <davem@davemloft.net>,
David Ahern <dsahern@kernel.org>,
Eric Dumazet <edumazet@google.com>,
Paolo Abeni <pabeni@redhat.com>, Simon Horman <horms@kernel.org>,
netdev@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] net: ipv4: ipconfig: Support RFC 4361/3315 DHCP client ID in hex format
Date: Sat, 14 Jun 2025 00:37:07 +0200 [thread overview]
Message-ID: <25d73457-cfb7-4e65-bb19-a3a826790f32@cern.ch> (raw)
In-Reply-To: <20250612191726.2a226cdf@kernel.org>
I'm sorry, now in the correct format.
On 13.06.2025 4:17, Jakub Kicinski wrote:
> On Tue, 10 Jun 2025 16:35:03 +0200 Petr Zejdl wrote:
>> - len = strlen(dhcp_client_identifier + 1);
> maybe keep using len here? Assign dhcp_client_identifier_len to it?
> I don't think switching to dhcp_client_identifier_len improves the
> readability and it inflates the diff.
Indeed.
>> +/*
>> + * Parses DHCP Client ID in the hex form "XX:XX ... :XX" (like MAC address).
>> + * Returns the length (min 2, max 253) or -EINVAL on parsing error.
>> + */
>> +static int __init parse_client_id(const char *s, u8 *buf)
>> ...
> Feels like this helper should live in lib/net_utils.c or lib/hexdump.c
> as a generic thing?
Sounds good, will come with a new version.
I should also update 'Documentation/admin-guide/nfs/nfsroot.rst' with
the new Client ID format.
Thank you for the review.
Best regards,
Petr
prev parent reply other threads:[~2025-06-13 22:37 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-10 14:35 Petr Zejdl
2025-06-13 2:17 ` Jakub Kicinski
2025-06-13 22:37 ` Petr Zejdl [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=25d73457-cfb7-4e65-bb19-a3a826790f32@cern.ch \
--to=petr.zejdl@cern.ch \
--cc=davem@davemloft.net \
--cc=dsahern@kernel.org \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®