From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755777AbcA1V5w (ORCPT ); Thu, 28 Jan 2016 16:57:52 -0500 Received: from mout.kundenserver.de ([212.227.126.130]:57368 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751602AbcA1V5u (ORCPT ); Thu, 28 Jan 2016 16:57:50 -0500 From: Arnd Bergmann To: linux-arm-kernel@lists.infradead.org Cc: Russell King - ARM Linux , Jouni Malinen , netdev@vger.kernel.org, linux-wireless@vger.kernel.org, linux-kernel@vger.kernel.org, Kalle Valo Subject: Re: [PATCH] hostap: avoid uninitialized variable use in hfa384x_get_rid Date: Thu, 28 Jan 2016 22:57:07 +0100 Message-ID: <2640544.07pTZp3kGe@wuerfel> User-Agent: KMail/4.11.5 (Linux/3.16.0-10-generic; KDE/4.11.5; x86_64; ; ) In-Reply-To: <20160127192612.GD10826@n2100.arm.linux.org.uk> References: <1453902342-3420391-1-git-send-email-arnd@arndb.de> <20160127192612.GD10826@n2100.arm.linux.org.uk> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" X-Provags-ID: V03:K0:CfjrMwiF3+Fw+Fg697QTQ2pMW3ta2gwQpy6cQE6NrYcR3D/t1hl NLMSVK54DBsqFOWPbyndIAwlAfTBcrury0cOl+hPEQ9q52xnsHnc20rg3A3iZkXB012Bm35 uV6XlRYblgHTvlreZcz4RPGL3bb2plfyAp6p7zqGWzLWDWlv9A4j7AqoR8jhicN0Vll37Ym azuQS+blRpsmrahpDY9hQ== X-UI-Out-Filterresults: notjunk:1;V01:K0:d5AWipOnovY=:Het6VqcmZQ/XahRM1RbpLY XbD75ABMtnz35HGKUamQNphIhkFqt8nI9nqEgfoJkgn6X6NDjKo5i5pYxNHO01VwhGpsIq52t 8bqJ+9POFMhyPrhZttn5IjCIrY9XWnKLP6GfoulRuR0nC0r+HPs0CjMFWfrb8jo35bRBv2rpr iyOSo8l8nv4GcLwVxpPp8HN6DEmUuSr9ljylMIAAzmCq/OvCXRJ8N97R/3DF/vKiRQSt3NMTh 6McOSBC1n3IknyPhF5KxQPwQ5fzZOOQgtOAkeuJ+3KdmOJicPEUm8qDEUBTM643rvgIVN8S79 UosnJK7L5o5WDOmidjSq0T2SUpmL7yAbgiZHeBbCFZH1jRaEVEi5ZqjxshVtW/8eUpfCMV6Le /TaExOLSX7KlTevenzMUXFpARP2o88SJDkICHYJ17EVtCeOHjrHnuCoh2ygxwZ+B5BDQYMn+B +toWW7futgMaYvtwyo6gihQBa/A59qKSwiK0owHj5TPvJW/3XMV/hgPAdrJYR8BefC0KipDaB ul/pqp8CEdKRRyQeaOWCr0Tl0gGjwrCWkYSU0YaTWRUtXajp4dNTO1NyYYIr/4jaU11VsDccy Tdz+5ZA/JyhspeKBEg9IkRbbPeVjjMW9zMEOtXLaD7qN+5KkCO/RuxVvWIerRpiyTTeS6RLP2 XWp98taiHsgNfMbJnTECzEXIaDMw/OdSGk4USlLWskrG/cRAOFuzUxuEgqN0Jt7cy8P6hKnD3 Z38KjGgsoTVdRhYY Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wednesday 27 January 2016 19:26:13 Russell King - ARM Linux wrote: > On Wed, Jan 27, 2016 at 02:45:26PM +0100, Arnd Bergmann wrote: > So, why give the compiler a hard time as you're doing, why make the code > harder to read. What's wrong with: > > spin_lock_bh(&local->baplock); > > res = hfa384x_setup_bap(dev, BAP0, rid, 0); > if (res) > goto unlock; > > res = hfa384x_from_bap(dev, BAP0, &rec, sizeof(rec)); > if (res) > goto unlock; > > if (le16_to_cpu(rec.len) == 0) { > /* RID not available */ > res = -ENODATA; > goto unlock; > } > > rlen = (le16_to_cpu(rec.len) - 1) * 2; > if (exact_len && rlen != len) { > printk(KERN_DEBUG "%s: hfa384x_get_rid - RID len mismatch: rid=0x%04x, len=%d (expected %d)\n", > dev->name, rid, rlen, len); > res = -ENODATA; > goto unlock; > } > > res = hfa384x_from_bap(dev, BAP0, buf, len); > unlock: > spin_unlock_bh(&local->baplock); > > ? > Good idea, I'll send a new version. Arnd