From: David Howells <dhowells@redhat.com>
To: Kees Cook <keescook@chromium.org>
Cc: dhowells@redhat.com, Jeff Layton <jlayton@kernel.org>,
linux-kernel@vger.kernel.org, linux-hardening@vger.kernel.org
Subject: Re: [PATCH] netfs: Use container_of() for offset casting
Date: Wed, 18 May 2022 09:05:14 +0100 [thread overview]
Message-ID: <2692904.1652861114@warthog.procyon.org.uk> (raw)
In-Reply-To: <20220517210230.864239-1-keescook@chromium.org>
I wonder if it would be worth making this explicit in the inode wrappers of
the users of netfslib. In afs, for instance, there is:
struct afs_vnode {
struct {
/* These must be contiguous */
struct inode vfs_inode;
struct netfs_i_context netfs_ctx;
};
...
};
would it be worth making that:
struct afs_vnode {
union {
struct netfs_i_c_pair netfs_inode;
struct {
/* These must be contiguous */
struct inode vfs_inode;
struct netfs_i_context netfs_ctx;
};
};
...
};
I don't want to do the following, say:
struct afs_vnode {
struct netfs_i_c_pair ni;
...
};
as that would then require a lot of s/->vfs_inode/->ni.vfs_inode/, but maybe
it would be better to include a struct inode in struct netfs_i_context, and
then do:
struct afs_vnode {
union {
struct netfs_i_context netfs_ctx;
struct inode vfs_inode;
};
...
};
and perhaps rename netfs_i_context to netfs_inode (though that looks a bit
close to nfs_inode). It's just a shame I can't do:
struct netfs_inode : inode {
...
};
struct afs_vnode : netfs_inode {
...
};
right? ;-)
On the other hand:
warthog>git grep '[>.]vfs_inode' -- fs/{9p,afs,ceph,cifs,nfs} | wc -l
181
so maybe a mass change to, say:
struct netfs_inode {
struct inode vfs_inode;
...
};
struct afs_vnode {
struct netfs_inode ni;
...
};
wouldn't be so bad.
David
next prev parent reply other threads:[~2022-05-18 8:05 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-05-17 21:02 Kees Cook
2022-05-17 22:32 ` Jeff Layton
2022-05-18 8:05 ` David Howells [this message]
2022-05-18 10:01 ` David Laight
2022-05-18 15:21 ` David Howells
2022-05-18 20:21 ` Kees Cook
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2692904.1652861114@warthog.procyon.org.uk \
--to=dhowells@redhat.com \
--cc=jlayton@kernel.org \
--cc=keescook@chromium.org \
--cc=linux-hardening@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®