From: Abhinav Kumar <quic_abhinavk@quicinc.com>
To: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
Cc: <freedreno@lists.freedesktop.org>,
<linux-arm-msm@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<dri-devel@lists.freedesktop.org>, <quic_khsieh@quicinc.com>,
<quic_parellan@quicinc.com>, <quic_jesszhan@quicinc.com>,
Marijn Suijten <marijn.suijten@somainline.org>,
Sean Paul <sean@poorly.run>
Subject: Re: [PATCH 07/16] drm/msm/dpu: add cdm blocks to RM
Date: Wed, 6 Dec 2023 13:02:01 -0800 [thread overview]
Message-ID: <27074b58-25ed-dbcc-1048-dbd9ba3135c9@quicinc.com> (raw)
In-Reply-To: <5bcbb092-1d29-f795-3be4-5ab1c708cba0@quicinc.com>
On 11/30/2023 3:47 PM, Abhinav Kumar wrote:
>
>
> On 8/30/2023 4:48 PM, Dmitry Baryshkov wrote:
>> On Thu, 31 Aug 2023 at 01:50, Abhinav Kumar
>> <quic_abhinavk@quicinc.com> wrote:
>>>
>>> Add the RM APIs necessary to initialize and allocate CDM
>>> blocks by the rest of the DPU pipeline.
>>
>> ... to be used by the rest?
>>
>
> Yes, thanks.
>
>
>>>
>>> Signed-off-by: Abhinav Kumar <quic_abhinavk@quicinc.com>
>>> ---
>>> drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c | 17 +++++++++++++++++
>>> drivers/gpu/drm/msm/disp/dpu1/dpu_rm.h | 2 ++
>>> 2 files changed, 19 insertions(+)
>>>
>>> diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c
>>> b/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c
>>> index f9215643c71a..7b6444a3fcb1 100644
>>> --- a/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c
>>> +++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c
>>> @@ -8,6 +8,7 @@
>>> #include "dpu_kms.h"
>>> #include "dpu_hw_lm.h"
>>> #include "dpu_hw_ctl.h"
>>> +#include "dpu_hw_cdm.h"
>>> #include "dpu_hw_pingpong.h"
>>> #include "dpu_hw_sspp.h"
>>> #include "dpu_hw_intf.h"
>>> @@ -90,6 +91,9 @@ int dpu_rm_destroy(struct dpu_rm *rm)
>>> }
>>> }
>>>
>>> + if (rm->cdm_blk)
>>> + dpu_hw_cdm_destroy(to_dpu_hw_cdm(rm->cdm_blk));
>>> +
>>> for (i = 0; i < ARRAY_SIZE(rm->hw_wb); i++)
>>> dpu_hw_wb_destroy(rm->hw_wb[i]);
>>>
>>> @@ -240,6 +244,19 @@ int dpu_rm_init(struct dpu_rm *rm,
>>> rm->hw_sspp[sspp->id - SSPP_NONE] = hw;
>>> }
>>>
>>> + if (cat->cdm) {
>>> + struct dpu_hw_cdm *hw;
>>> +
>>> + hw = dpu_hw_cdm_init(cat->cdm, mmio);
>>> + /* CDM is optional so no need to bail out */
>>> + if (IS_ERR(hw)) {
>>> + rc = PTR_ERR(hw);
>>> + DPU_DEBUG("failed cdm object creation: err
>>> %d\n", rc);
>>
>> No. If it is a part of the catalog, we should fail here as we do in
>> other cases.
>>
>
> I guess, the only reason for not failing here was other hw blocks are
> needed even for basic display to come up but cdm is only for YUV formats.
>
> Thats the only reason to mark this a failure which is "OK" to ignore.
>
> But I see your point that if someone is listing this in the catalog but
> still RM fails thats an error.
>
> Hence, ack.
>
>>
>>> + } else {
>>> + rm->cdm_blk = &hw->base;
>>> + }
>>> + }
>>> +
>>> return 0;
>>>
>>> fail:
>>> diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.h
>>> b/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.h
>>> index 2b551566cbf4..29b221491926 100644
>>> --- a/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.h
>>> +++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.h
>>> @@ -22,6 +22,7 @@ struct dpu_global_state;
>>> * @hw_wb: array of wb hardware resources
>>> * @dspp_blks: array of dspp hardware resources
>>> * @hw_sspp: array of sspp hardware resources
>>> + * @cdm_blk: cdm hardware resource
>>> */
>>> struct dpu_rm {
>>> struct dpu_hw_blk *pingpong_blks[PINGPONG_MAX - PINGPONG_0];
>>> @@ -33,6 +34,7 @@ struct dpu_rm {
>>> struct dpu_hw_blk *merge_3d_blks[MERGE_3D_MAX - MERGE_3D_0];
>>> struct dpu_hw_blk *dsc_blks[DSC_MAX - DSC_0];
>>> struct dpu_hw_sspp *hw_sspp[SSPP_MAX - SSPP_NONE];
>>> + struct dpu_hw_blk *cdm_blk;
>>
>> struct dpu_hw_cdm *cdm (or cdm_blk), please.
>
> Ack.
>
I was going through this more. I think its better we leave this as a
dpu_hw_blk because if you see the other blks in struct dpu_rm, all the
blocks which are allocated dynamically / can change dynamically are of
dpu_hw_blk type. That way the dpu_rm_get_assigned_resources() remains
generic. Hence I would prefer to leave it this way.
>>
>>> };
>>>
>>> /**
>>> --
>>> 2.40.1
>>>
>>
>>
>> --
>> With best wishes
>> Dmitry
next prev parent reply other threads:[~2023-12-06 21:02 UTC|newest]
Thread overview: 52+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20230830224910.8091-1-quic_abhinavk@quicinc.com>
2023-08-30 22:48 ` [PATCH 01/16] drm/msm/dpu: fix writeback programming for YUV cases Abhinav Kumar
2023-08-30 23:38 ` Dmitry Baryshkov
2023-08-30 22:48 ` [PATCH 02/16] drm/msm/dpu: add formats check for writeback encoder Abhinav Kumar
2023-08-30 23:39 ` Dmitry Baryshkov
2023-08-30 22:48 ` [PATCH 03/16] drm/msm/dpu: rename dpu_encoder_phys_wb_setup_cdp to match its functionality Abhinav Kumar
2023-08-30 23:40 ` Dmitry Baryshkov
2023-08-30 22:48 ` [PATCH 04/16] drm/msm/dpu: add cdm blocks to sc7280 dpu_hw_catalog Abhinav Kumar
2023-08-30 22:57 ` Dmitry Baryshkov
2023-11-30 22:41 ` Abhinav Kumar
2023-08-30 22:48 ` [PATCH 05/16] drm/msm/dpu: add cdm blocks to sm8250 dpu_hw_catalog Abhinav Kumar
2023-08-30 22:48 ` [PATCH 06/16] drm/msm/dpu: add dpu_hw_cdm abstraction for CDM block Abhinav Kumar
2023-08-31 0:00 ` Dmitry Baryshkov
2023-11-30 23:36 ` Abhinav Kumar
2023-12-01 7:05 ` Dmitry Baryshkov
2023-12-01 18:19 ` Abhinav Kumar
2023-12-01 21:10 ` Dmitry Baryshkov
2023-08-30 22:49 ` [PATCH 07/16] drm/msm/dpu: add cdm blocks to RM Abhinav Kumar
2023-08-30 23:48 ` Dmitry Baryshkov
2023-11-30 23:47 ` Abhinav Kumar
2023-12-06 21:02 ` Abhinav Kumar [this message]
2023-12-06 22:23 ` Dmitry Baryshkov
2023-08-30 22:49 ` [PATCH 08/16] drm/msm/dpu: add support to allocate CDM from RM Abhinav Kumar
2023-08-31 0:06 ` Dmitry Baryshkov
2023-11-30 23:50 ` Abhinav Kumar
2023-12-01 8:39 ` Dmitry Baryshkov
2023-08-30 22:49 ` [PATCH 09/16] drm/msm/dpu: add CDM related logic to dpu_hw_ctl layer Abhinav Kumar
2023-08-31 0:12 ` Dmitry Baryshkov
2023-11-30 23:54 ` Abhinav Kumar
2023-08-30 22:49 ` [PATCH 10/16] drm/msm/dpu: add support to disable CDM block during encoder cleanup Abhinav Kumar
2023-08-31 0:14 ` Dmitry Baryshkov
2023-11-30 23:58 ` Abhinav Kumar
2023-12-01 8:36 ` Dmitry Baryshkov
2023-08-30 22:49 ` [PATCH 11/16] drm/msm/dpu: add an API to setup the CDM block for writeback Abhinav Kumar
2023-08-31 0:11 ` Dmitry Baryshkov
2023-12-01 0:41 ` Abhinav Kumar
2023-12-01 7:20 ` Dmitry Baryshkov
2023-12-01 19:04 ` Abhinav Kumar
2023-12-01 21:15 ` [Freedreno] " Dmitry Baryshkov
2023-08-30 22:49 ` [PATCH 12/16] drm/msm/dpu: plug-in the cdm related bits to writeback setup Abhinav Kumar
2023-08-31 0:15 ` Dmitry Baryshkov
2023-08-30 22:49 ` [PATCH 13/16] drm/msm/dpu: reserve cdm blocks for writeback in case of YUV output Abhinav Kumar
2023-08-31 0:23 ` Dmitry Baryshkov
2023-12-01 0:45 ` Abhinav Kumar
2023-08-30 22:49 ` [PATCH 14/16] drm/msm/dpu: do not allow YUV formats if no CDM block is present Abhinav Kumar
2023-08-31 0:24 ` Dmitry Baryshkov
2023-12-01 0:50 ` Abhinav Kumar
2023-12-01 7:14 ` Dmitry Baryshkov
2023-08-30 22:49 ` [PATCH 15/16] drm/msm/dpu: add NV12 in the list of supported WB formats Abhinav Kumar
2023-08-31 0:26 ` Dmitry Baryshkov
2023-12-07 1:09 ` Abhinav Kumar
2023-08-30 22:49 ` [PATCH 16/16] drm/msm/dpu: add cdm blocks to dpu snapshot Abhinav Kumar
2023-08-31 0:27 ` Dmitry Baryshkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=27074b58-25ed-dbcc-1048-dbd9ba3135c9@quicinc.com \
--to=quic_abhinavk@quicinc.com \
--cc=dmitry.baryshkov@linaro.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=freedreno@lists.freedesktop.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=marijn.suijten@somainline.org \
--cc=quic_jesszhan@quicinc.com \
--cc=quic_khsieh@quicinc.com \
--cc=quic_parellan@quicinc.com \
--cc=sean@poorly.run \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®