From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from canpmsgout06.his.huawei.com (canpmsgout06.his.huawei.com [113.46.200.221]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 3D14D1A9B24 for ; Wed, 5 Aug 2026 01:07:11 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=113.46.200.221 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1785892034; cv=none; b=r4D2Yz1HFk9cKTeixP8CJzxk53zdPAyUZnjrEDClgX33bssdHkZMKazzJDhVvB8yI0USf7gUBT5/88lvuPYspmn5DvKmtSaM9YVywtRSL8lLcZ/NEjkm4lWswBdLyApUbPU6a0/9IY6kXuMNPNe5o9jGwT8IEo72vo4N4OG8gpE= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1785892034; c=relaxed/simple; bh=M/h77F0V0toC/Q+3ybSePlgkfOxOcuEucJ5EYKxdVT0=; h=Message-ID:Date:MIME-Version:Subject:To:CC:References:From: In-Reply-To:Content-Type; b=LncMgIRzY9PEbO/QAjxR9rdTDlas9NnyVzeDp7hYAr+gJEkaLK77/WDFuUPuoJ6YC4YjK/L7BDbbqKUBfcqD4i0Mww2vYSGzRt43wndoupBWTDfYMOgvaDPDSNHf7RWdqYYASz50QRvFAp+N0QxF3d6QvnOjG0aMZw6fR51Zmyw= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=quarantine dis=none) header.from=huawei.com; spf=pass smtp.mailfrom=huawei.com; dkim=pass (1024-bit key) header.d=huawei.com header.i=@huawei.com header.b=3rZ5BoB7; arc=none smtp.client-ip=113.46.200.221 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=quarantine dis=none) header.from=huawei.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=huawei.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (1024-bit key) header.d=huawei.com header.i=@huawei.com header.b="3rZ5BoB7" dkim-signature: v=1; a=rsa-sha256; d=huawei.com; s=dkim; c=relaxed/relaxed; q=dns/txt; h=From; bh=EphlXXC4awDXhtZexOo6D08ZUx34ER0gqhhiggQEPtg=; b=3rZ5BoB7JqRvEDC6jFvM/LWiqPgIbGpMFvRafFEo6Lm/O1cjfiqjH5QTT1yGB9FbxNWKE/nGb YiYqeo0HlV20wCtTUozPuCZJhs52eJ2zKcdQIhFT751ePF82WR50L7fP8ulEKly6lDr7PBGbEWH 2Ub8+bQjGEgAlwDitZCZWb8= Received: from mail.maildlp.com (unknown [172.19.162.223]) by canpmsgout06.his.huawei.com (SkyGuard) with ESMTPS id 4hFBpP5YKFzRhR0; Wed, 5 Aug 2026 08:57:33 +0800 (CST) Received: from whupemo500002.china.huawei.com (unknown [7.152.185.250]) by mail.maildlp.com (Postfix) with ESMTPS id 870F740561; Wed, 5 Aug 2026 09:07:03 +0800 (CST) Received: from [10.67.120.139] (10.67.120.139) by whupemo500002.china.huawei.com (7.152.185.250) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.1544.11; Wed, 5 Aug 2026 09:07:02 +0800 Message-ID: <27c56101-07eb-46a7-83c6-34037c6b85d9@huawei.com> Date: Wed, 5 Aug 2026 09:07:01 +0800 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id To: CC: , Conor Dooley , Jonathan Cameron References: <20260804-cache-v1-1-a1491610bb01@thegoodpenguin.co.uk> Content-Language: en-US From: Yushan Wang In-Reply-To: <20260804-cache-v1-1-a1491610bb01@thegoodpenguin.co.uk> Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: 7bit X-ClientProxiedBy: kwepems100001.china.huawei.com (7.221.188.238) To whupemo500002.china.huawei.com (7.152.185.250) On 8/4/2026 7:17 PM, Pawel Zalewski via B4 Relay wrote: > From: "Pawel Zalewski (The Capable Hub)" > > Use a named initializer for the acpi_device_id fields which > makes the code more readable and consistent with how lists > are initialized in the rest of the kernel code base. > > Signed-off-by: Pawel Zalewski (The Capable Hub) Reviewed-by: Yushan Wang > --- > drivers/cache/hisi_soc_hha.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/cache/hisi_soc_hha.c b/drivers/cache/hisi_soc_hha.c > index 756c43398515..f0f6c0354108 100644 > --- a/drivers/cache/hisi_soc_hha.c > +++ b/drivers/cache/hisi_soc_hha.c > @@ -170,7 +170,7 @@ static void hisi_soc_hha_remove(struct platform_device *pdev) > } > > static const struct acpi_device_id hisi_soc_hha_ids[] = { > - { "HISI0511", }, > + { .id = "HISI0511" }, > { } > }; > MODULE_DEVICE_TABLE(acpi, hisi_soc_hha_ids); > > --- > base-commit: 075b74841bd0065a3bda3440873c747938e69b68 > change-id: 20260803-cache-55f8e58f7d94 > > Best regards, > -- > Pawel Zalewski (The Capable Hub) > >