From: Andrzej Pietrasiewicz <andrzej.p@collabora.com>
To: Sebastian Fricke <sebastian.fricke@collabora.com>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-rockchip@lists.infradead.org,
linux-staging@lists.linux.dev, Jonas Karlman <jonas@kwiboo.se>,
Alex Bee <knaerzche@gmail.com>,
Nicolas Dufresne <nicolas.dufresne@collabora.com>,
Collabora Kernel-domain <kernel@collabora.com>,
Robert Beckett <bob.beckett@collabora.com>,
Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
Benjamin Gaignard <benjamin.gaignard@collabora.com>
Subject: Re: [PATCH v2 10/12] staging: media: rkvdec: Wrapper for pixel format preparation
Date: Mon, 16 Jan 2023 11:42:15 +0100 [thread overview]
Message-ID: <2835d8cb-2652-1ac5-fff1-23928c0e569c@collabora.com> (raw)
In-Reply-To: <20230101-patch-series-v2-6-2-rc1-v2-10-fa1897efac14@collabora.com>
Hi Sebastian,
W dniu 12.01.2023 o 13:56, Sebastian Fricke pisze:
> Reduce code duplication by creating a wrapper around the preparation of
> the `v4l2_pix_format_mplane` structure and the calculation of the
> image size.
>
> Signed-off-by: Sebastian Fricke <sebastian.fricke@collabora.com>
> ---
> drivers/staging/media/rkvdec/rkvdec.c | 29 +++++++++++++++--------------
> 1 file changed, 15 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/staging/media/rkvdec/rkvdec.c b/drivers/staging/media/rkvdec/rkvdec.c
> index 8d948bcc4e46..b303c6e0286d 100644
> --- a/drivers/staging/media/rkvdec/rkvdec.c
> +++ b/drivers/staging/media/rkvdec/rkvdec.c
> @@ -27,6 +27,17 @@
> #include "rkvdec.h"
> #include "rkvdec-regs.h"
>
> +static void rkvdec_fill_decoded_pixfmt(struct rkvdec_ctx *ctx,
> + struct v4l2_pix_format_mplane *pix_mp)
> +{
> + v4l2_fill_pixfmt_mp(pix_mp, pix_mp->pixelformat,
> + pix_mp->width, pix_mp->height);
> + pix_mp->plane_fmt[0].sizeimage += 128 *
> + DIV_ROUND_UP(pix_mp->width, 16) *
> + DIV_ROUND_UP(pix_mp->height, 16);
> + pix_mp->field = V4L2_FIELD_NONE;
> +}
> +
> static int rkvdec_queue_busy(struct rkvdec_ctx *ctx, enum v4l2_buf_type buf_type)
> {
> struct vb2_queue *vq;
> @@ -248,13 +259,9 @@ static void rkvdec_reset_decoded_fmt(struct rkvdec_ctx *ctx)
>
> rkvdec_reset_fmt(ctx, f, valid_fmt);
> f->type = V4L2_BUF_TYPE_VIDEO_CAPTURE_MPLANE;
> - v4l2_fill_pixfmt_mp(&f->fmt.pix_mp,
> - ctx->coded_fmt_desc->decoded_fmts[0],
> - ctx->coded_fmt.fmt.pix_mp.width,
> - ctx->coded_fmt.fmt.pix_mp.height);
> - f->fmt.pix_mp.plane_fmt[0].sizeimage += 128 *
> - DIV_ROUND_UP(f->fmt.pix_mp.width, 16) *
> - DIV_ROUND_UP(f->fmt.pix_mp.height, 16);
> + f->fmt.pix_mp.width = ctx->coded_fmt.fmt.pix_mp.width;
> + f->fmt.pix_mp.height = ctx->coded_fmt.fmt.pix_mp.height;
> + rkvdec_fill_decoded_pixfmt(ctx, &f->fmt.pix_mp);
Strictly technically this function has _not_ been setting pix_mt->field
to V4L2_FIELD_NONE, but after this change there exists such a "side effect".
Maybe it is actually desired, or maybe it being missing in the not patched
version was a mistake in the first place. Just letting you know so that
you can make sure pix_mp->field being actually set now is ok in the context
of rkvdec_queue_busy().
Regards,
Andrzej
> }
>
> static int rkvdec_enum_framesizes(struct file *file, void *priv,
> @@ -324,13 +331,7 @@ static int rkvdec_try_capture_fmt(struct file *file, void *priv,
> &pix_mp->height,
> &coded_desc->frmsize);
>
> - v4l2_fill_pixfmt_mp(pix_mp, pix_mp->pixelformat,
> - pix_mp->width, pix_mp->height);
> - pix_mp->plane_fmt[0].sizeimage +=
> - 128 *
> - DIV_ROUND_UP(pix_mp->width, 16) *
> - DIV_ROUND_UP(pix_mp->height, 16);
> - pix_mp->field = V4L2_FIELD_NONE;
> + rkvdec_fill_decoded_pixfmt(ctx, pix_mp);
>
> return 0;
> }
>
next prev parent reply other threads:[~2023-01-16 10:44 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-01-12 12:56 [PATCH v2 00/12] RkVDEC HEVC driver Sebastian Fricke
2023-01-12 12:56 ` [PATCH v2 01/12] media: v4l2: Add NV15 pixel format Sebastian Fricke
2023-01-13 12:19 ` kernel test robot
2023-02-16 8:57 ` Hsia-Jun Li
2023-02-16 17:00 ` Nicolas Dufresne
2023-02-17 2:40 ` Hsia-Jun Li
2023-01-12 12:56 ` [PATCH v2 02/12] media: v4l2-common: Add helpers to calculate bytesperline and sizeimage Sebastian Fricke
2023-01-12 12:56 ` [PATCH v2 03/12] staging: media: rkvdec: Helper for buffer queue busy check Sebastian Fricke
2023-01-16 7:54 ` Andrzej Pietrasiewicz
2023-01-12 12:56 ` [PATCH v2 04/12] staging: media: rkvdec: Block start streaming until both queues run Sebastian Fricke
2023-01-12 14:55 ` Ezequiel Garcia
2023-01-12 15:00 ` Dan Carpenter
2023-01-16 8:23 ` Andrzej Pietrasiewicz
2023-01-12 12:56 ` [PATCH v2 05/12] staging: media: rkvdec: Add SPS structure to internal context Sebastian Fricke
2023-01-12 15:02 ` Ezequiel Garcia
2023-01-16 10:00 ` Andrzej Pietrasiewicz
2023-01-12 12:56 ` [PATCH v2 06/12] staging: media: rkvdec: Add a valid pixel format check as callback Sebastian Fricke
2023-01-12 15:30 ` Ezequiel Garcia
2023-01-12 12:56 ` [PATCH v2 07/12] staging: media: rkvdec: Add a routine to fetch SPS attributes as a callback Sebastian Fricke
2023-01-16 10:27 ` Andrzej Pietrasiewicz
2023-01-12 12:56 ` [PATCH v2 08/12] staging: media: rkvdec: Add a valid SPS check " Sebastian Fricke
2023-01-12 12:56 ` [PATCH v2 09/12] staging: media: rkvdec: h264: Add callbacks for h264 Sebastian Fricke
2023-01-12 15:21 ` Ezequiel Garcia
2023-01-12 21:58 ` Nicolas Dufresne
2023-01-12 12:56 ` [PATCH v2 10/12] staging: media: rkvdec: Wrapper for pixel format preparation Sebastian Fricke
2023-01-16 10:42 ` Andrzej Pietrasiewicz [this message]
2023-01-12 12:56 ` [PATCH v2 11/12] staging: media: rkvdec: Enable S_CTRL IOCTL Sebastian Fricke
2023-01-12 15:09 ` Ezequiel Garcia
2023-01-12 22:04 ` Nicolas Dufresne
2023-01-12 12:56 ` [PATCH v2 12/12] staging: media: rkvdec: Add HEVC backend Sebastian Fricke
2023-01-12 18:27 ` kernel test robot
2023-01-16 12:44 ` Andrzej Pietrasiewicz
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2835d8cb-2652-1ac5-fff1-23928c0e569c@collabora.com \
--to=andrzej.p@collabora.com \
--cc=benjamin.gaignard@collabora.com \
--cc=bob.beckett@collabora.com \
--cc=ezequiel@vanguardiasur.com.ar \
--cc=gregkh@linuxfoundation.org \
--cc=jonas@kwiboo.se \
--cc=kernel@collabora.com \
--cc=knaerzche@gmail.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=linux-staging@lists.linux.dev \
--cc=mchehab@kernel.org \
--cc=nicolas.dufresne@collabora.com \
--cc=sebastian.fricke@collabora.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®