From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1031659AbeEXRvM (ORCPT ); Thu, 24 May 2018 13:51:12 -0400 Received: from ale.deltatee.com ([207.54.116.67]:38148 "EHLO ale.deltatee.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1031263AbeEXRvG (ORCPT ); Thu, 24 May 2018 13:51:06 -0400 To: Randy Dunlap , linux-kernel@vger.kernel.org, linux-pci@vger.kernel.org, linux-ntb@googlegroups.com Cc: Bjorn Helgaas , Alex Williamson , Doug Meyer References: <20180524173913.4506-1-logang@deltatee.com> From: Logan Gunthorpe Message-ID: <2ab7b5f8-f068-026a-bc79-5c589dcdb07e@deltatee.com> Date: Thu, 24 May 2018 11:51:03 -0600 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.7.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8 Content-Language: en-US Content-Transfer-Encoding: 7bit X-SA-Exim-Connect-IP: 172.16.1.162 X-SA-Exim-Rcpt-To: dmeyer@gigaio.com, alex.williamson@redhat.com, bhelgaas@google.com, linux-ntb@googlegroups.com, linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org, rdunlap@infradead.org X-SA-Exim-Mail-From: logang@deltatee.com Subject: Re: [PATCH v2] PCI: Expand documentation for pci_add_dma_alias() X-SA-Exim-Version: 4.2.1 (built Tue, 02 Aug 2016 21:08:31 +0000) X-SA-Exim-Scanned: Yes (on ale.deltatee.com) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 24/05/18 11:44 AM, Randy Dunlap wrote: >> diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c >> index dbfe7c4f3776..1c0c1ea23b90 100644 >> --- a/drivers/pci/pci.c >> +++ b/drivers/pci/pci.c >> @@ -5395,8 +5395,19 @@ int pci_set_vga_state(struct pci_dev *dev, bool decode, >> * @dev: the PCI device for which alias is added >> * @devfn: alias slot and function >> * >> - * This helper encodes 8-bit devfn as bit number in dma_alias_mask. >> - * It should be called early, preferably as PCI fixup header quirk. >> + * This helper encodes an 8-bit devfn as a bit number in dma_alias_mask >> + * which is used to program permissible BDF source addresses for DMA > > It took me a few seconds to decode BDF. FWIW, I would prefer to see > bus-devfn or bus-dev-fn or bus-dev-func or bus-dev-function. Yes, there's a lot of overlapping terminology here. In circles I've discussed this stuff, BDF is a common acronym. The kernel uses Bus/Slot/Function in some places, but devfn is also common. In any case, I like bus-devfn so I'll make these changes and send a v3 shortly. Thanks, Logan