From: "Ray Lee" <ray-lk@madrabbit.org>
To: "Paul Jackson" <pj@sgi.com>
Cc: "KOSAKI Motohiro" <kosaki.motohiro@jp.fujitsu.com>,
rientjes@google.com, Lee.Schermerhorn@hp.com, mel@csn.ul.ie,
ak@suse.de, linux-kernel@vger.kernel.org,
akpm@linux-foundation.org, clameter@sgi.com
Subject: Re: [RFC] bitmap relative operator for mempolicy extensions
Date: Thu, 14 Feb 2008 12:55:49 -0800 [thread overview]
Message-ID: <2c0942db0802141255o5d18c6bfxe052ba9512a18817@mail.gmail.com> (raw)
In-Reply-To: <20080214103541.10943567.pj@sgi.com>
On Thu, Feb 14, 2008 at 8:35 AM, Paul Jackson <pj@sgi.com> wrote:
> Kosaki-san wrote:
> > i prefer another name [!relative].
>
> Any suggestions?
>
> I'll give the name some thought myself.
> I like good names, and this is the right
> time to get this one right.
'Relative map' implies a constant offset. What you have there is just
a map as relmap could be sparse (which, btw, would have been nice to
have in the example).
map_bitmap violates your naming convention, bitmap_map isn't all that
clear, bitmap_remap is taken, and while it is one-to-one and onto, I
think calling it bitmap_bijection would lose everyone except the
mathematicians. bitmap_onto? bitmap_map_onto? bitmap_map_bitmap_onto?
bitmap_read_my_kernel_doc?
Minor suggestion:
+ * and the n-th bit of @relmap is the m-th set bit of @relmap.
Perhaps s/is the/is also the/, so that the reader doesn't try to
second guess if you accidentally wrote @relmap twice instead of one of
them being @orig.
next prev parent reply other threads:[~2008-02-14 20:56 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-02-14 12:35 Paul Jackson
2008-02-14 14:11 ` KOSAKI Motohiro
2008-02-14 16:35 ` Paul Jackson
2008-02-14 20:55 ` Ray Lee [this message]
2008-02-14 21:16 ` David Rientjes
2008-02-15 10:47 ` Paul Jackson
2008-02-15 0:24 ` KOSAKI Motohiro
2008-02-15 10:25 ` Paul Jackson
2008-02-15 10:58 ` Paul Jackson
2008-02-14 19:27 ` Christoph Lameter
2008-02-14 20:02 ` Andi Kleen
2008-02-14 20:06 ` Christoph Lameter
2008-02-14 20:25 ` Mike Travis
2008-02-14 20:30 ` Andi Kleen
2008-02-15 9:54 ` Paul Jackson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2c0942db0802141255o5d18c6bfxe052ba9512a18817@mail.gmail.com \
--to=ray-lk@madrabbit.org \
--cc=Lee.Schermerhorn@hp.com \
--cc=ak@suse.de \
--cc=akpm@linux-foundation.org \
--cc=clameter@sgi.com \
--cc=kosaki.motohiro@jp.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mel@csn.ul.ie \
--cc=pj@sgi.com \
--cc=rientjes@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®