mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Robin Murphy <robin.murphy@arm.com>
To: Mark Rutland <mark.rutland@arm.com>, Xichao Zhao <zhao.xichao@vivo.com>
Cc: will@kernel.org, linux-perf-users@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH] drivers: perf: use us_to_ktime() where appropriate
Date: Wed, 27 Aug 2025 15:05:58 +0100	[thread overview]
Message-ID: <2c6d68da-fd1a-4b59-8bfc-5e1c66ceaebe@arm.com> (raw)
In-Reply-To: <aK7RkB5p6L17Ffuw@J2N7QTR9R3>

On 27/08/2025 10:36 am, Mark Rutland wrote:
> [adding Robin and LAKML]
> 
> On Wed, Aug 13, 2025 at 04:32:57PM +0800, Xichao Zhao wrote:
>> The arm_ccn_pmu_poll_period_us are more suitable for using
>> the us_to_ktime(). This can make the code more concise and
>> enhance readability.
>>
>> Signed-off-by: Xichao Zhao <zhao.xichao@vivo.com>
> 
> Superficially this looks fine to me, so:
> 
> Acked-by: Mark Rutland <mark.rutland@arm.com>
> 
> Will, I assume that (if no-one complains) you'll pick this up when
> queueing PMU patches.

Yup, the new helper looks entirely appropriate here. We could perhaps 
take this opportunity to drop the unnecessary cast as well though, since 
automatic promotion from unsigned int to u64 is perfectly well-defined 
and unsurprising.

Thanks,
Robin.

> 
> Mark.
> 
>> ---
>>   drivers/perf/arm-ccn.c | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/perf/arm-ccn.c b/drivers/perf/arm-ccn.c
>> index 1a0d0e1a2263..8af3563fdf60 100644
>> --- a/drivers/perf/arm-ccn.c
>> +++ b/drivers/perf/arm-ccn.c
>> @@ -565,7 +565,7 @@ module_param_named(pmu_poll_period_us, arm_ccn_pmu_poll_period_us, uint,
>>   
>>   static ktime_t arm_ccn_pmu_timer_period(void)
>>   {
>> -	return ns_to_ktime((u64)arm_ccn_pmu_poll_period_us * 1000);
>> +	return us_to_ktime((u64)arm_ccn_pmu_poll_period_us);
>>   }
>>   
>>   
>> -- 
>> 2.34.1
>>


  reply	other threads:[~2025-08-27 14:06 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-08-13  8:32 Xichao Zhao
2025-08-27  9:36 ` Mark Rutland
2025-08-27 14:05   ` Robin Murphy [this message]
2025-09-18 16:43 ` Will Deacon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2c6d68da-fd1a-4b59-8bfc-5e1c66ceaebe@arm.com \
    --to=robin.murphy@arm.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-perf-users@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=will@kernel.org \
    --cc=zhao.xichao@vivo.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®