From: Andrew Lunn <andrew@lunn.ch>
To: Justin Lai <justinlai0215@realtek.com>
Cc: kuba@kernel.org, davem@davemloft.net, edumazet@google.com,
pabeni@redhat.com, andrew+netdev@lunn.ch,
linux-kernel@vger.kernel.org, netdev@vger.kernel.org,
horms@kernel.org, pkshih@realtek.com, larry.chiu@realtek.com
Subject: Re: [PATCH net 1/4] rtase: Refactor the rtase_check_mac_version_valid() function
Date: Thu, 14 Nov 2024 16:38:08 +0100 [thread overview]
Message-ID: <2fac05ba-7766-4586-8676-e30f09cd2d09@lunn.ch> (raw)
In-Reply-To: <20241114111443.375649-2-justinlai0215@realtek.com>
On Thu, Nov 14, 2024 at 07:14:40PM +0800, Justin Lai wrote:
> 1. Sets tp->hw_ver.
> 2. Changes the return type from bool to int.
>
> Signed-off-by: Justin Lai <justinlai0215@realtek.com>
> ---
> drivers/net/ethernet/realtek/rtase/rtase.h | 2 ++
> .../net/ethernet/realtek/rtase/rtase_main.c | 21 +++++++++++--------
> 2 files changed, 14 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/net/ethernet/realtek/rtase/rtase.h b/drivers/net/ethernet/realtek/rtase/rtase.h
> index 583c33930f88..547c71937b01 100644
> --- a/drivers/net/ethernet/realtek/rtase/rtase.h
> +++ b/drivers/net/ethernet/realtek/rtase/rtase.h
> @@ -327,6 +327,8 @@ struct rtase_private {
> u16 int_nums;
> u16 tx_int_mit;
> u16 rx_int_mit;
> +
> + u32 hw_ver;
> };
>
> #define RTASE_LSO_64K 64000
> diff --git a/drivers/net/ethernet/realtek/rtase/rtase_main.c b/drivers/net/ethernet/realtek/rtase/rtase_main.c
> index f8777b7663d3..33808afd588d 100644
> --- a/drivers/net/ethernet/realtek/rtase/rtase_main.c
> +++ b/drivers/net/ethernet/realtek/rtase/rtase_main.c
> @@ -1972,20 +1972,21 @@ static void rtase_init_software_variable(struct pci_dev *pdev,
> tp->dev->max_mtu = RTASE_MAX_JUMBO_SIZE;
> }
>
> -static bool rtase_check_mac_version_valid(struct rtase_private *tp)
> +static int rtase_check_mac_version_valid(struct rtase_private *tp)
> {
> - u32 hw_ver = rtase_r32(tp, RTASE_TX_CONFIG_0) & RTASE_HW_VER_MASK;
> - bool known_ver = false;
> + int ret = -ENODEV;
>
> - switch (hw_ver) {
> + tp->hw_ver = rtase_r32(tp, RTASE_TX_CONFIG_0) & RTASE_HW_VER_MASK;
> +
> + switch (tp->hw_ver) {
> case 0x00800000:
> case 0x04000000:
> case 0x04800000:
Since these magic numbers are being used in more places, please add
some #define with sensible names.
> - if (!rtase_check_mac_version_valid(tp))
> - return dev_err_probe(&pdev->dev, -ENODEV,
> - "unknown chip version, contact rtase maintainers (see MAINTAINERS file)\n");
> + ret = rtase_check_mac_version_valid(tp);
> + if (ret != 0) {
> + dev_err(&pdev->dev,
> + "unknown chip version, contact rtase maintainers (see MAINTAINERS file)\n");
> + }
Since you are changing this, maybe include the hw_ver?
Andrew
next prev parent reply other threads:[~2024-11-14 15:38 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-11-14 11:14 [PATCH net 0/4] Updating and correcting switch hardware versions and reported speeds Justin Lai
2024-11-14 11:14 ` [PATCH net 1/4] rtase: Refactor the rtase_check_mac_version_valid() function Justin Lai
2024-11-14 15:38 ` Andrew Lunn [this message]
2024-11-15 5:57 ` Justin Lai
2024-11-14 15:40 ` Andrew Lunn
2024-11-15 6:32 ` Justin Lai
2024-11-14 11:14 ` [PATCH net 2/4] rtase: Correct the speed for RTL907XD-V1 Justin Lai
2024-11-14 11:14 ` [PATCH net 3/4] rtase: Add support for RTL907XD-VA PCIe port Justin Lai
2024-11-14 11:14 ` [PATCH net 4/4] rtase: Corrects error handling of the rtase_check_mac_version_valid() Justin Lai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2fac05ba-7766-4586-8676-e30f09cd2d09@lunn.ch \
--to=andrew@lunn.ch \
--cc=andrew+netdev@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=justinlai0215@realtek.com \
--cc=kuba@kernel.org \
--cc=larry.chiu@realtek.com \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=pkshih@realtek.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®