From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1031162AbcCQQPe (ORCPT ); Thu, 17 Mar 2016 12:15:34 -0400 Received: from mout.kundenserver.de ([217.72.192.74]:55101 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965634AbcCQQPb (ORCPT ); Thu, 17 Mar 2016 12:15:31 -0400 From: Arnd Bergmann To: Sinan Kaya Cc: Robin Murphy , linux-arm-kernel@lists.infradead.org, timur@codeaurora.org, cov@codeaurora.org, nwatters@codeaurora.org, Catalin Marinas , Will Deacon , Andrew Morton , Max Filippov , Joe Perches , "Suthikulpanit, Suravee" , Jisheng Zhang , Dean Nelson , "Suzuki K. Poulose" , Marek Szyprowski , linux-kernel@vger.kernel.org Subject: Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices Date: Thu, 17 Mar 2016 17:14:34 +0100 Message-ID: <3165610.Gdh8F6ejPI@wuerfel> User-Agent: KMail/4.11.5 (Linux/3.16.0-10-generic; KDE/4.11.5; x86_64; ; ) In-Reply-To: <56EAD63E.2010103@codeaurora.org> References: <1458229833-4886-1-git-send-email-okaya@codeaurora.org> <56EAD3E2.5070109@arm.com> <56EAD63E.2010103@codeaurora.org> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" X-Provags-ID: V03:K0:MThoifkXzDwlYXu05k/OLw5qJpmY4nEeNJGaE0OLi6N34W4MX1w cSqL6a6zQH3NBaZJQDtJEyWqfnj++Yi6ymYEabKzsizRzko79L7Rpfu4m5gqrxtiWpUm4oK Fku3CDUI0iDnd9SXMZADBPOzg7JLnp9OA2NT5dq9gl5hXmrdWBrynmUzfnNRdvn+4CEiUjm nO+I2ZLvxpxTNgB8AF9+A== X-UI-Out-Filterresults: notjunk:1;V01:K0:sskhRCFFG0Q=:Nromev78t30GKHIo7mXz0A 0Rz5cAJplumkbZch/uhFOe8Z13TV914MW9WH2ytgBQEh0Z60R0XE38YnZmMOEjFTzgD+puZiT 4wNmVB37UD1+q1Uv4HHa6s9Mhg2FjrdPaV3C/zBlcaP8ViHPT20j4DNQaeW2efd1nEOxrHtXl UNUi9l6NSZmLHBsSN6QcoULasfz/bA7SR8HXV4kBm1Yw6DBMi6uaDvfoJSk5jJpRgkH6Ubq/z C+M/lSnXQNf87IJ/FGDMdxIk618uZXDcIZP6nNw1ax/Rq8ppSCrY/RRImpBLkZU72uaqYcURR f3tdsnhBds1jtsON8eP5d4bLQMdJ7Mgl1QFf+5W6sOwcMYrRZIcng72YHnWbyZ/3fWKvD6Idl YWAWG5xp9NYxBZJL1MXqjVkYRNKCmabEmXaQR9aMQHK9bMzT2VW0qYZ1/al+ZqtO+EtX7nITS vBxU/5PI/chNaHNFsDQmEr+2NtXtJFWbtgy00GmxM9nQS6fFrUL/LI87vrrZcAZ6TKkvr2Zji 6kcTpm23909CoK5UADu440rwY/jDJUCW1fuwQgKgZF0KY/M1lOMSuqGBU9C+2UNyqBX2vYvGf SX6JNrZPGxdafuYsI/ZIbz/G5WGNBFqkxxYmcHTHowCMdrNLALXKf8i48lxie/9IwmSMxr4d8 xB4vePsWy3+BvlbwaHb0+HJZVhnKVxBfu6ewbliskQkzRQGYZyL6XY1qxpPDZHpXskU1PfJ3Y cfOAejlsI88vasEj Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thursday 17 March 2016 12:07:26 Sinan Kaya wrote: > On 3/17/2016 11:57 AM, Robin Murphy wrote: > > Let me know which direction I should go. > > 1. Fix phys_to_dma and keep dma_to_phys as in the patch. > 2. Remove both of the API from header file, move it to where it is needed. Rename them as swio_phys_to_dma etc. Use 2. It has been a long way to remove all virt_to_bus/bus_to_virt users from the common architectures, we are not putting them back under a different name. Drivers already know the physical address because that is what they put into dma_map_*() in the first place. Arnd