From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1759498AbcILOoR (ORCPT ); Mon, 12 Sep 2016 10:44:17 -0400 Received: from mail-yb0-f194.google.com ([209.85.213.194]:33126 "EHLO mail-yb0-f194.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1758050AbcILOoP (ORCPT ); Mon, 12 Sep 2016 10:44:15 -0400 From: Jes Sorensen X-Google-Original-From: Jes Sorensen Subject: Re: [Outreachy kernel] [PATCH] Staging: rtl8188eu: Remove ternary operator To: Bhumika Goyal , outreachy-kernel@googlegroups.com, gregkh@linuxfoundation.org, devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org References: <1473688681-14479-1-git-send-email-bhumirks@gmail.com> Message-ID: <32230433-289b-b787-9a7a-9a897bf2f93c@gmail.com> Date: Mon, 12 Sep 2016 10:44:13 -0400 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.2.0 MIME-Version: 1.0 In-Reply-To: <1473688681-14479-1-git-send-email-bhumirks@gmail.com> Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 09/12/16 09:58, Bhumika Goyal wrote: > Relational and logical operators evaluate to either true or false. > Explicit conversion is not needed so remove the ternary operator. > Done using coccinelle: > > @r@ > expression A,B; > symbol true,false; > binary operator b = {==,!=,&&,||,>=,<=,>,<}; > @@ > - (A b B) ? true : false > + A b B > > Signed-off-by: Bhumika Goyal > --- > drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 8 ++++---- > drivers/staging/rtl8188eu/hal/phy.c | 2 +- > drivers/staging/rtl8188eu/hal/rtl8188e_dm.c | 3 ++- > 3 files changed, 7 insertions(+), 6 deletions(-) > > diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c > index 9544e55..b43f57be 100644 > --- a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c > +++ b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c > @@ -705,7 +705,7 @@ static int issue_probereq_ex(struct adapter *padapter, > unsigned long start = jiffies; > > do { > - ret = issue_probereq(padapter, pssid, da, wait_ms > 0 ? true : false); > + ret = issue_probereq(padapter, pssid, da, wait_ms > 0); > > i++; > > @@ -1293,7 +1293,7 @@ int issue_nulldata(struct adapter *padapter, unsigned char *da, unsigned int pow > da = pnetwork->MacAddress; > > do { > - ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0 ? true : false); > + ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0); > > i++; > > @@ -1420,7 +1420,7 @@ int issue_qos_nulldata(struct adapter *padapter, unsigned char *da, u16 tid, int > da = pnetwork->MacAddress; > > do { > - ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0 ? true : false); > + ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0); > > i++; > > @@ -1527,7 +1527,7 @@ static int issue_deauth_ex(struct adapter *padapter, u8 *da, > unsigned long start = jiffies; > > do { > - ret = _issue_deauth(padapter, da, reason, wait_ms > 0 ? true : false); > + ret = _issue_deauth(padapter, da, reason, wait_ms > 0); > > i++; While this part of the patch is technically correct, I would argue it doesn't improve the code. It would make the code more readable to pass in the wait_ms value and then have the decision made based on that in the called function. Cheers, Jes