mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
To: Andy Lutomirski <luto@amacapital.net>
Cc: Andy Lutomirski <luto@kernel.org>, X86 ML <x86@kernel.org>,
	Borislav Petkov <bp@suse.de>,
	Peter Zijlstra <peterz@infradead.org>,
	John Stultz <john.stultz@linaro.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Len Brown <lenb@kernel.org>, Huang Rui <ray.huang@amd.com>,
	Denys Vlasenko <dvlasenk@redhat.com>,
	"linux-input@vger.kernel.org" <linux-input@vger.kernel.org>
Subject: Re: [PATCH v2 10/17] input/joystick/analog: Switch from rdtscl() to native_read_tsc()
Date: Tue, 16 Jun 2015 16:15:56 -0700	[thread overview]
Message-ID: <324F73B8-9C5B-44EC-A7D7-DC27D63FAE07@gmail.com> (raw)
In-Reply-To: <CALCETrX0_et6my95dQ8CgRPWDPPvikFVNAOCW153nAKe17SkqA@mail.gmail.com>

On June 16, 2015 4:09:06 PM PDT, Andy Lutomirski <luto@amacapital.net> wrote:
>Is it okay for -tip to take this and the other one you just acked?

Yeah, that's fine.


Thanks.

-- 
Dmitry

  reply	other threads:[~2015-06-16 23:16 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-06-12 23:44 [PATCH v2 00/17] x86/tsc: Clean up rdtsc helpers Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 01/17] x86/tsc: Inline native_read_tsc and remove __native_read_tsc Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 02/17] x86/msr/kvm: Remove vget_cycles() Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 03/17] x86/tsc/paravirt: Remove the read_tsc and read_tscp paravirt hooks Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 04/17] x86/tsc: Replace rdtscll with native_read_tsc Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 05/17] x86/tsc: Remove the rdtscp and rdtscpll macros Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 06/17] x86/tsc: Use the full 64-bit tsc in tsc_delay Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 07/17] x86/cpu/amd: Use the full 64-bit TSC to detect the 2.6.2 bug Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 08/17] baycom_epp: Replace rdtscl() with native_read_tsc() Andy Lutomirski
2015-06-13 10:45   ` walter harms
2015-06-15 23:15     ` Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 09/17] staging/lirc_serial: Remove TSC-based timing Andy Lutomirski
2015-06-19 13:02   ` Dan Carpenter
2015-06-19 16:15   ` Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 10/17] input/joystick/analog: Switch from rdtscl() to native_read_tsc() Andy Lutomirski
2015-06-16 23:03   ` Dmitry Torokhov
2015-06-16 23:09     ` Andy Lutomirski
2015-06-16 23:15       ` Dmitry Torokhov [this message]
2015-06-12 23:44 ` [PATCH v2 11/17] drivers/input/gameport: Replace rdtscl() with native_read_tsc() Andy Lutomirski
2015-06-16 23:04   ` Dmitry Torokhov
2015-06-12 23:44 ` [PATCH v2 12/17] x86/tsc: Remove rdtscl() Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 13/17] x86/tsc: Rename native_read_tsc() to rdtsc_unordered() Andy Lutomirski
2015-06-13  8:57   ` Borislav Petkov
2015-06-13 18:25     ` Andy Lutomirski
2015-06-14 11:54       ` Borislav Petkov
2015-06-12 23:44 ` [PATCH v2 14/17] x86/tsc: Move rdtsc_barrier() and rename it to barrier_before_rdtsc() Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 15/17] x86: Add rdtsc_ordered() and use it in trivial call sites Andy Lutomirski
2015-06-13  9:02   ` Borislav Petkov
2015-06-13 18:25     ` Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 16/17] x86/tsc: Use rdtsc_ordered() in check_tsc_warp() and drop extra barriers Andy Lutomirski
2015-06-12 23:44 ` [PATCH v2 17/17] x86/tsc: In read_tsc, use rdtsc_ordered() instead of get_cycles() Andy Lutomirski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=324F73B8-9C5B-44EC-A7D7-DC27D63FAE07@gmail.com \
    --to=dmitry.torokhov@gmail.com \
    --cc=bp@suse.de \
    --cc=dvlasenk@redhat.com \
    --cc=john.stultz@linaro.org \
    --cc=lenb@kernel.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@amacapital.net \
    --cc=luto@kernel.org \
    --cc=peterz@infradead.org \
    --cc=ray.huang@amd.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®