From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: Toshi Kani <toshi.kani@hp.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
ACPI Devel Maling List <linux-acpi@vger.kernel.org>,
LKML <linux-kernel@vger.kernel.org>,
isimatu.yasuaki@jp.fujitsu.com,
vasilis.liaskovitis@profitbricks.com, Len Brown <lenb@kernel.org>
Subject: Re: [PATCH 4/4] ACPI / processor: Use common hotplug infrastructure
Date: Fri, 03 May 2013 14:21:09 +0200 [thread overview]
Message-ID: <3338257.RT4RYiAzz9@vostro.rjw.lan> (raw)
In-Reply-To: <8416995.PXoT3vbUMm@vostro.rjw.lan>
On Friday, May 03, 2013 02:05:37 PM Rafael J. Wysocki wrote:
> On Thursday, May 02, 2013 05:20:12 PM Toshi Kani wrote:
> > On Thu, 2013-05-02 at 14:31 +0200, Rafael J. Wysocki wrote:
> > > From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> > >
> > > Split the ACPI processor driver into two parts, one that is
> > > non-modular, resides in the ACPI core and handles the enumeration
> > > and hotplug of processors and one that implements the rest of the
> > > existing processor driver functionality.
> > >
> > > The non-modular part uses an ACPI scan handler object to enumerate
> > > processors on the basis of information provided by the ACPI namespace
> > > and to hook up with the common ACPI hotplug infrastructure. It also
> > > populates the ACPI handle of each processor device having a
> > > corresponding object in the ACPI namespace, which allows the driver
> > > proper to bind to those devices, and makes the driver bind to them
> > > if it is readily available (i.e. loaded) when the scan handler's
> > > .attach() routine is running.
> > >
> > > There are a few reasons to make this change.
> > >
> > > First, switching the ACPI processor driver to using the common ACPI
> > > hotplug infrastructure reduces code duplication and size considerably,
> > > even though a new file is created along with a header comment etc.
> > >
> > > Second, since the common hotplug code attempts to offline devices
> > > before starting the (non-reversible) removal procedure, it will abort
> > > (and possibly roll back) hot-remove operations involving processors
> > > if cpu_down() returns an error code for one of them instead of
> > > continuing them blindly (if /sys/firmware/acpi/hotplug/force_remove
> > > is unset). That is a more desirable behavior than what the current
> > > code does.
> > >
> > > Finally, the separation of the scan/hotplug part from the driver
> > > proper makes it possible to simplify the driver's .remove() routine,
> > > because it doesn't need to worry about the possible cleanup related
> > > to processor removal any more (the scan/hotplug part is responsible
> > > for that now) and can handle device removal and driver removal
> > > symmetricaly (i.e. as appropriate).
> > >
> > > Some user-visible changes in sysfs are made (for example, the
> > > 'sysdev' link from the ACPI device node to the processor device's
> > > directory is gone and a 'physical_node' link is present instead,
> > > a 'firmware_node' link is present in the processor device's
> > > directory, the processor driver is now visible under
> > > /sys/bus/cpu/drivers/ and bound to the processor device), but
> > > that shouldn't affect the functionality that users care about
> > > (frequency scaling, C-states and thermal management).
> >
> > This looks very nice. I have one question below.
> >
> > > Tested on my venerable Toshiba Portege R500.
> > >
> > > Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> > > ---
> > > drivers/acpi/Makefile | 1
> > > drivers/acpi/acpi_processor.c | 473 +++++++++++++++++++++++
> > > drivers/acpi/glue.c | 6
> > > drivers/acpi/internal.h | 3
> > > drivers/acpi/processor_driver.c | 803 +++-------------------------------------
> > > drivers/acpi/scan.c | 1
> > > drivers/base/cpu.c | 11
> > > include/acpi/processor.h | 5
> > > 8 files changed, 574 insertions(+), 729 deletions(-)
> >
> > :
> >
> > > Index: linux-pm/drivers/base/cpu.c
> > > ===================================================================
> > > --- linux-pm.orig/drivers/base/cpu.c
> > > +++ linux-pm/drivers/base/cpu.c
> > > @@ -13,11 +13,21 @@
> > > #include <linux/gfp.h>
> > > #include <linux/slab.h>
> > > #include <linux/percpu.h>
> > > +#include <linux/acpi.h>
> > >
> > > #include "base.h"
> > >
> > > static DEFINE_PER_CPU(struct device *, cpu_sys_devices);
> > >
> > > +static int cpu_subsys_match(struct device *dev, struct device_driver *drv)
> > > +{
> > > + /* ACPI style match is the only one that may succeed. */
> > > + if (acpi_driver_match_device(dev, drv))
> >
> > Can you explain why this change is needed?
>
> This is the mechanism by which the driver core determines which driver to use
> with a processor device passed to device_attach().
>
> Basically, it walks the list of drivers whose bus type is cpu_subsys and
> calls cpu_subsys->match(), which points to cpu_subsys_match(), for the device
> and each of the drivers. The result of that tell is whether or not to use
> the given driver with the device.
>
> Now, acpi_driver_match_device() returns 'true' if (a) the device has an ACPI
> handle and (b) at least one of the IDs of the struct acpi_device associated
> with that handle is in the driver's .acpi_match_table table. Since the ACPI
> processor's .acpi_match_table contains the same set of IDs as the table
> of device IDs of processor_handler, this guarantees that the ACPI processor
> driver will be used for the devices prepared by acpi_processor_add().
>
> What it boils down to is that acpi_processor_start() is going to be called
> for every device whose ACPI handle is populated by acpi_processor_add().
The reason why it really is needed is because the ACPI processor driver is
modular and it may or may not be present when acpi_processor_add() is running,
but acpi_processor_start() should be called for the device once the driver has
been loaded.
Thanks,
Rafael
--
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.
next prev parent reply other threads:[~2013-05-03 12:12 UTC|newest]
Thread overview: 73+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-04-29 12:23 [PATCH 0/3 RFC] Driver core / ACPI: Add offline/online for graceful hot-removal of devices Rafael J. Wysocki
2013-04-29 12:26 ` [PATCH 1/3 RFC] Driver core: Add offline/online device operations Rafael J. Wysocki
2013-04-29 23:10 ` Greg Kroah-Hartman
2013-04-30 11:59 ` Rafael J. Wysocki
2013-04-30 15:32 ` Greg Kroah-Hartman
2013-04-30 20:05 ` Rafael J. Wysocki
2013-04-30 23:38 ` Toshi Kani
2013-05-02 0:58 ` Rafael J. Wysocki
2013-05-02 23:29 ` Toshi Kani
2013-05-03 11:48 ` Rafael J. Wysocki
2013-04-29 12:28 ` [PATCH 2/3 RFC] Driver core: Use generic offline/online for CPU offline/online Rafael J. Wysocki
2013-04-29 23:11 ` Greg Kroah-Hartman
2013-04-30 12:01 ` Rafael J. Wysocki
2013-04-30 15:27 ` Greg Kroah-Hartman
2013-04-30 20:06 ` Rafael J. Wysocki
2013-04-30 23:42 ` Toshi Kani
2013-05-01 14:49 ` Rafael J. Wysocki
2013-05-01 20:07 ` Toshi Kani
2013-05-02 0:26 ` Rafael J. Wysocki
2013-04-29 12:29 ` [PATCH 3/3 RFC] ACPI / hotplug: Use device offline/online for graceful hot-removal Rafael J. Wysocki
2013-04-30 23:49 ` Toshi Kani
2013-05-01 15:05 ` Rafael J. Wysocki
2013-05-01 20:20 ` Toshi Kani
2013-05-02 0:53 ` Rafael J. Wysocki
2013-05-02 12:26 ` [PATCH 0/4] Driver core / ACPI: Add offline/online for graceful hot-removal of devices Rafael J. Wysocki
2013-05-02 12:27 ` [PATCH 1/4] Driver core: Add offline/online device operations Rafael J. Wysocki
2013-05-02 13:57 ` Greg Kroah-Hartman
2013-05-02 23:11 ` Toshi Kani
2013-05-02 23:36 ` Rafael J. Wysocki
2013-05-02 23:23 ` Toshi Kani
2013-05-02 12:28 ` [PATCH 2/4] Driver core: Use generic offline/online for CPU offline/online Rafael J. Wysocki
2013-05-02 13:57 ` Greg Kroah-Hartman
2013-05-02 12:29 ` [PATCH 3/4] ACPI / hotplug: Use device offline/online for graceful hot-removal Rafael J. Wysocki
2013-05-02 12:31 ` [PATCH 4/4] ACPI / processor: Use common hotplug infrastructure Rafael J. Wysocki
2013-05-02 13:59 ` Greg Kroah-Hartman
2013-05-02 23:20 ` Toshi Kani
2013-05-03 12:05 ` Rafael J. Wysocki
2013-05-03 12:21 ` Rafael J. Wysocki [this message]
2013-05-03 18:27 ` Toshi Kani
2013-05-03 19:31 ` Rafael J. Wysocki
2013-05-03 19:34 ` Toshi Kani
2013-05-04 1:01 ` [PATCH 0/3 RFC] Driver core: Add offline/online callbacks for memory_subsys Rafael J. Wysocki
2013-05-04 1:03 ` [PATCH 1/3 RFC] ACPI / memhotplug: Bind removable memory blocks to ACPI device nodes Rafael J. Wysocki
2013-05-04 1:04 ` [PATCH 2/3 RFC] Driver core: Introduce types of device "online" Rafael J. Wysocki
2013-05-04 1:06 ` [PATCH 3/3 RFC] Driver core: Introduce offline/online callbacks for memory blocks Rafael J. Wysocki
2013-05-04 11:11 ` [PATCH 0/2 v2, RFC] Driver core: Add offline/online callbacks for memory_subsys Rafael J. Wysocki
2013-05-04 11:12 ` [PATCH 1/2 v2, RFC] ACPI / memhotplug: Bind removable memory blocks to ACPI device nodes Rafael J. Wysocki
2013-05-21 6:50 ` Tang Chen
2013-05-04 11:21 ` [PATCH 2/2 v2, RFC] Driver core: Introduce offline/online callbacks for memory blocks Rafael J. Wysocki
2013-05-06 16:28 ` Vasilis Liaskovitis
2013-05-07 0:59 ` Rafael J. Wysocki
2013-05-07 10:59 ` Vasilis Liaskovitis
2013-05-07 12:11 ` Rafael J. Wysocki
2013-05-07 21:03 ` Toshi Kani
2013-05-07 22:10 ` Rafael J. Wysocki
2013-05-07 22:45 ` Toshi Kani
2013-05-07 23:17 ` Rafael J. Wysocki
2013-05-07 23:59 ` Toshi Kani
2013-05-08 0:24 ` Rafael J. Wysocki
2013-05-08 0:37 ` Toshi Kani
2013-05-08 11:53 ` Rafael J. Wysocki
2013-05-08 14:38 ` Toshi Kani
2013-05-06 17:20 ` Greg Kroah-Hartman
2013-05-06 19:46 ` Rafael J. Wysocki
2013-05-21 6:37 ` Tang Chen
2013-05-21 11:15 ` Rafael J. Wysocki
2013-05-22 4:45 ` Tang Chen
2013-05-22 10:42 ` Rafael J. Wysocki
2013-05-22 22:06 ` [PATCH] Driver core / memory: Simplify __memory_block_change_state() Rafael J. Wysocki
2013-05-22 22:14 ` Greg Kroah-Hartman
2013-05-22 23:29 ` Rafael J. Wysocki
2013-05-23 4:37 ` Tang Chen
2013-05-06 10:48 ` [PATCH 0/2 v2, RFC] Driver core: Add offline/online callbacks for memory_subsys Rafael J. Wysocki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3338257.RT4RYiAzz9@vostro.rjw.lan \
--to=rjw@sisk.pl \
--cc=gregkh@linuxfoundation.org \
--cc=isimatu.yasuaki@jp.fujitsu.com \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=toshi.kani@hp.com \
--cc=vasilis.liaskovitis@profitbricks.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®