From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1030415AbcHBRGJ (ORCPT ); Tue, 2 Aug 2016 13:06:09 -0400 Received: from mail-wm0-f68.google.com ([74.125.82.68]:33804 "EHLO mail-wm0-f68.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S935659AbcHBRFx (ORCPT ); Tue, 2 Aug 2016 13:05:53 -0400 Subject: Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro To: Alan Stern , Baole Ni References: Cc: rjw@rjwysocki.net, viresh.kumar@linaro.org, jarkko.sakkinen@linux.intel.com, jgunthorpe@obsidianresearch.com, hpa@zytor.com, x86@kernel.org, linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, peter@korsgaard.com, lee.jones@linaro.org From: Jiri Slaby Message-ID: <335df7ab-6663-b14a-de33-7a485489c20e@suse.cz> Date: Tue, 2 Aug 2016 19:05:48 +0200 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.2 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 08/02/2016, 03:57 PM, Alan Stern wrote: >> --- a/drivers/cpufreq/powernow-k7.c >> +++ b/drivers/cpufreq/powernow-k7.c >> @@ -683,7 +683,7 @@ static void __exit powernow_exit(void) >> cpufreq_unregister_driver(&powernow_driver); >> } >> >> -module_param(acpi_force, int, 0444); >> +module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH); > > This is an excellent example. To me, 0444 is _much_ more readable and > understandable than S_IRUSR | S_IRGRP | S_IROTH. If anything, that should be S_IRUGO. However, I personally prefer numbers over macros too. thanks, -- js suse labs