From: Joe Perches <joe@perches.com>
To: Dan Carpenter <dan.carpenter@oracle.com>,
Julia Lawall <julia.lawall@inria.fr>
Cc: Rebecca Mckeever <remckee0@gmail.com>,
outreachy@lists.linux.dev,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 1/2] staging: rtl8192u: replace ternary statement with if and assignment
Date: Thu, 07 Apr 2022 23:14:51 -0700 [thread overview]
Message-ID: <34d0ad73f44ff4990f6bee49105ac49bb55352a5.camel@perches.com> (raw)
In-Reply-To: <20220408055732.GO3293@kadam>
On Fri, 2022-04-08 at 08:57 +0300, Dan Carpenter wrote:
> On Fri, Apr 08, 2022 at 06:15:14AM +0200, Julia Lawall wrote:
> > On Thu, 7 Apr 2022, Rebecca Mckeever wrote:
> >
> > > Replace ternary statement with an if statement followed by an assignment
> > > to increase readability and make error handling more obvious.
> > > Found with minmax coccinelle script.
[]
> > > diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c b/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c
[]
> > > @@ -470,7 +470,9 @@ int ieee80211_wx_get_encode(struct ieee80211_device *ieee,
> > > return 0;
> > > }
> > > len = crypt->ops->get_key(keybuf, SCM_KEY_LEN, NULL, crypt->priv);
> > > - erq->length = (len >= 0 ? len : 0);
> > > + if (len < 0)
> > > + len = 0;
> > > + erq->length = len;
> >
> > Maybe you could use max here?
>
> Initially Rebecca did use max() but I NAKed it. It's really not less
> readable. Better to handle the error explicitly. Keep the error path
> indented two tabs. Separate from the success path.
A comment would be useful as it's not obvious it's an 'error' path.
One has to read all 3 get_key functions to determine that.
next prev parent reply other threads:[~2022-04-08 6:15 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-04-08 1:12 [PATCH v2 0/2] staging: rtl8192u: cleanup of ternary and if else statements Rebecca Mckeever
2022-04-08 1:12 ` [PATCH v2 1/2] staging: rtl8192u: replace ternary statement with if and assignment Rebecca Mckeever
2022-04-08 4:15 ` Julia Lawall
2022-04-08 5:09 ` Greg Kroah-Hartman
2022-04-08 5:57 ` Dan Carpenter
2022-04-08 6:14 ` Joe Perches [this message]
2022-04-08 6:31 ` Dan Carpenter
2022-04-08 7:19 ` Joe Perches
2022-04-08 8:35 ` Dan Carpenter
2022-04-08 8:50 ` Julia Lawall
2022-04-08 1:12 ` [PATCH v2 2/2] staging: rtl8192u: use min_t/max_t macros instead of if else Rebecca Mckeever
2022-04-08 6:39 ` [PATCH v2 0/2] staging: rtl8192u: cleanup of ternary and if else statements Dan Carpenter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=34d0ad73f44ff4990f6bee49105ac49bb55352a5.camel@perches.com \
--to=joe@perches.com \
--cc=dan.carpenter@oracle.com \
--cc=gregkh@linuxfoundation.org \
--cc=julia.lawall@inria.fr \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=outreachy@lists.linux.dev \
--cc=remckee0@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®