mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Yinghai Lu <yinghai@kernel.org>
Cc: Bjorn Helgaas <bhelgaas@google.com>,
	David Miller <davem@davemloft.net>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Wei Yang <weiyang@linux.vnet.ibm.com>, TJ <linux@iam.tj>,
	Yijing Wang <wangyijing@huawei.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Len Brown <lenb@kernel.org>,
	ACPI Devel Maling List <linux-acpi@vger.kernel.org>
Subject: Re: [PATCH v4 13/52] PCI, acpiphp: Add missing realloc list checking after resource allocation
Date: Tue, 25 Aug 2015 02:37:13 +0200	[thread overview]
Message-ID: <3540278.fBlMDMjYYH@vostro.rjw.lan> (raw)
In-Reply-To: <CAE9FiQWW_zzZGoq-rrbe+R==-xwRHMkTAtFRGGkN-GK-F6NWsg@mail.gmail.com>

On Monday, August 24, 2015 03:14:26 PM Yinghai Lu wrote:
> On Mon, Aug 24, 2015 at 3:09 PM, Rafael J. Wysocki <rjw@rjwysocki.net> wrote:
> > On Thursday, August 20, 2015 11:20:28 PM Yinghai Lu wrote:
> >> We check the realloc list, as list must be empty after allocation.
> >>
> >> Add missing one acpiphp driver.
> >>
> >> Signed-off-by: Yinghai Lu <yinghai@kernel.org>
> >> Cc: "Rafael J. Wysocki" <rjw@rjwysocki.net>
> >> Cc: Len Brown <lenb@kernel.org>
> >> Cc: linux-acpi@vger.kernel.org
> >> ---
> >>  drivers/pci/hotplug/acpiphp_glue.c | 1 +
> >>  1 file changed, 1 insertion(+)
> >>
> >> diff --git a/drivers/pci/hotplug/acpiphp_glue.c b/drivers/pci/hotplug/acpiphp_glue.c
> >> index ff53856..1c7c1d7 100644
> >> --- a/drivers/pci/hotplug/acpiphp_glue.c
> >> +++ b/drivers/pci/hotplug/acpiphp_glue.c
> >> @@ -507,6 +507,7 @@ static void enable_slot(struct acpiphp_slot *slot)
> >>               }
> >>       }
> >>       __pci_bus_assign_resources(bus, &add_list, NULL);
> >> +     BUG_ON(!list_empty(&add_list));
> >
> > Is crashing the kernel the best we can do here?
> >
> > What about bailing out with a WARN_ON() instead?  Surely, the kernel can work
> > without the new device?
> 
> That should not happen.
> If that list is not empty, we could have broken the assign logic for
> optional or additional
> resource allocation.
> 
> We have other two BUG_ON checking in drivers/pci/setup-bus.c.
> 
> Do we need to change them all to WARN_ON()?
> 
> or you prefer this version instead:

I like this patch better, but the question really is how bad things can get
if we continue.  And if they can get critically bad, whether or not we still
are able to catch that critical error later on.

> ---
> 
> Subject: [PATCH] PCI: Separate realloc list checking after allocation
> 
> We check the realloc list, as list must be empty after allocation.
> 
> Separate the realloc list checking to another function.
> 
> Add checking that is missed in acpiphp driver.
> 
> -v2: change to WARN_ON addording to Rafael.
> 
> Signed-off-by: Yinghai Lu <yinghai@kernel.org>
> Cc: "Rafael J. Wysocki" <rjw@rjwysocki.net>
> Cc: Len Brown <lenb@kernel.org>
> Cc: linux-acpi@vger.kernel.org
> ---
>  drivers/pci/hotplug/acpiphp_glue.c |    1 +
>  drivers/pci/pci.h                  |    1 +
>  drivers/pci/setup-bus.c            |   12 +++++++++---
>  3 files changed, 11 insertions(+), 3 deletions(-)
> 
> Index: linux-2.6/drivers/pci/hotplug/acpiphp_glue.c
> ===================================================================
> --- linux-2.6.orig/drivers/pci/hotplug/acpiphp_glue.c
> +++ linux-2.6/drivers/pci/hotplug/acpiphp_glue.c
> @@ -507,6 +507,7 @@ static void enable_slot(struct acpiphp_s
>          }
>      }
>      __pci_bus_assign_resources(bus, &add_list, NULL);
> +    pci_bus_check_realloc(&add_list);
> 
>      acpiphp_sanitize_bus(bus);
>      pcie_bus_configure_settings(bus);
> Index: linux-2.6/drivers/pci/pci.h
> ===================================================================
> --- linux-2.6.orig/drivers/pci/pci.h
> +++ linux-2.6/drivers/pci/pci.h
> @@ -237,6 +237,7 @@ void __pci_bus_size_bridges(struct pci_b
>  void __pci_bus_assign_resources(const struct pci_bus *bus,
>                  struct list_head *realloc_head,
>                  struct list_head *fail_head);
> +void pci_bus_check_realloc(struct list_head *realloc_head);
>  bool pci_bus_clip_resource(struct pci_dev *dev, int idx);
> 
>  void pci_reassigndev_resource_alignment(struct pci_dev *dev);
> Index: linux-2.6/drivers/pci/setup-bus.c
> ===================================================================
> --- linux-2.6.orig/drivers/pci/setup-bus.c
> +++ linux-2.6/drivers/pci/setup-bus.c
> @@ -349,6 +349,12 @@ out:
>      }
>  }
> 
> +void pci_bus_check_realloc(struct list_head *realloc_head)
> +{
> +    if (WARN_ON(!list_empty(realloc_head)))
> +        free_list(realloc_head);
> +}
> +
>  /**
>   * assign_requested_resources_sorted() - satisfy resource requests
>   *
> @@ -1860,7 +1866,7 @@ again:
>      /* Depth last, allocate resources and update the hardware. */
>      __pci_bus_assign_resources(bus, add_list, &fail_head);
>      if (add_list)
> -        BUG_ON(!list_empty(add_list));
> +        pci_bus_check_realloc(add_list);
>      tried_times++;
> 
>      /* any device complain? */
> @@ -1935,7 +1941,7 @@ void pci_assign_unassigned_bridge_resour
>  again:
>      __pci_bus_size_bridges(parent, &add_list);
>      __pci_bridge_assign_resources(bridge, &add_list, &fail_head);
> -    BUG_ON(!list_empty(&add_list));
> +    pci_bus_check_realloc(&add_list);
>      tried_times++;
> 
>      if (list_empty(&fail_head))
> @@ -1994,6 +2000,6 @@ void pci_assign_unassigned_bus_resources
>                               &add_list);
>      up_read(&pci_bus_sem);
>      __pci_bus_assign_resources(bus, &add_list, NULL);
> -    BUG_ON(!list_empty(&add_list));
> +    pci_bus_check_realloc(&add_list);
>  }
>  EXPORT_SYMBOL_GPL(pci_assign_unassigned_bus_resources);


  reply	other threads:[~2015-08-25  0:09 UTC|newest]

Thread overview: 63+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-08-21  6:20 [PATCH v4 00/52] PCI: Resource allocation cleanup for v4.3 Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 01/52] PCI: Cleanup res_to_dev_res() printout Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 02/52] PCI: Reuse res_to_dev_res() in reassign_resources_sorted() Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 03/52] PCI: Use correct align for optional only resources during sorting Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 04/52] PCI: Optimize bus min_align/size calculation during sizing Yinghai Lu
2015-09-14 20:21   ` Bjorn Helgaas
2015-09-14 21:37     ` Yinghai Lu
2015-09-15 14:57       ` Bjorn Helgaas
2015-09-16 19:33         ` Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 05/52] PCI: Optimize bus align/size calculation for optional " Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 06/52] PCI: Don't add too much optional size for hotplug bridge MMIO Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 07/52] PCI: Reorder resources list for required/optional resources Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 08/52] PCI: Remove duplicated code for resource sorting Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 09/52] PCI: Rename pdev_sort_resources() to pdev_assign_resources_prepare() Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 10/52] PCI: Treat ROM resource as optional during realloc Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 11/52] PCI: Add debug printout during releasing partial assigned resources Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 12/52] PCI: Simplify res reference using in __assign_resources_sorted() Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 13/52] PCI, acpiphp: Add missing realloc list checking after resource allocation Yinghai Lu
2015-08-24 22:09   ` Rafael J. Wysocki
2015-08-24 22:14     ` Yinghai Lu
2015-08-25  0:37       ` Rafael J. Wysocki [this message]
2015-08-25  0:14         ` Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 14/52] PCI: Add __add_to_list() Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 15/52] PCI: Cache window alignment value during bus sizing Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 16/52] PCI: Check if resource is allocated before trying to assign one Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 17/52] PCI: Separate out save_resources()/restore_resources() Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 18/52] PCI: Move comment to pci_need_to_release() Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 19/52] PCI: Separate required+optional assigning to another function Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 20/52] PCI: Skip required+optional if there is no optional Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 21/52] PCI: Move saved required resource list out of required+optional assigning Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 22/52] PCI: Add alt_size ressource allocation support Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 23/52] PCI: Add support for more than two alt_size under same bridge Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 24/52] PCI: Better support for two alt_size Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 25/52] PCI: Fix size calculation with old_size on rescan path Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 26/52] PCI: Don't add too much optional size for hotplug bridge io Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 27/52] PCI: Move ISA io port align out of calculate_iosize() Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 28/52] PCI: Don't add too much io port for hotplug bridge with old size Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 29/52] PCI: Unify calculate_size() for io port and MMIO Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 30/52] PCI: Allow bridge optional only io port resource required size to be 0 Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 31/52] PCI: Unify skip_ioresource_align() Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 32/52] PCI: Kill macro checking for bus io port sizing Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 33/52] resources: Split out __allocate_resource() Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 34/52] resources: Make allocate_resource() return best fit resource Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 35/52] PCI: Check pref compatible bit for mem64 resource of PCIe device Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 36/52] PCI: Only treat non-pref mmio64 as pref if all bridges have MEM_64 Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 37/52] PCI: Add has_mem64 for struct host_bridge Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 38/52] PCI: Only treat non-pref mmio64 as pref if host bridge has mmio64 Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 39/52] PCI: Restore pref MMIO allocation logic for host bridge without mmio64 Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 40/52] sparc/PCI: Add mem64 resource parsing for root bus Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 41/52] sparc/PCI: Add IORESOURCE_MEM_64 for 64-bit resource in OF parsing Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 42/52] powerpc/PCI: " Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 43/52] OF/PCI: Add IORESOURCE_MEM_64 for 64-bit resource Yinghai Lu
2015-08-21 18:18   ` Rob Herring
2015-08-21 18:24     ` Yinghai Lu
2015-08-21  6:20 ` [PATCH v4 44/52] PCI: Treat optional as required in first try for bridge rescan Yinghai Lu
2015-08-21  6:21 ` [PATCH v4 45/52] PCI: Get new realloc size for bridge for last try Yinghai Lu
2015-08-21  6:21 ` [PATCH v4 46/52] PCI: Don't release sibling bridge resources during hotplug Yinghai Lu
2015-08-21  6:21 ` [PATCH v4 47/52] PCI: Don't release fixed resource for realloc Yinghai Lu
2015-08-21  6:21 ` [PATCH v4 48/52] PCI: Claim fixed resource during remove/rescan path Yinghai Lu
2015-08-21  6:21 ` [PATCH v4 49/52] PCI: Set resource to FIXED for LSI devices Yinghai Lu
2015-08-21  6:21 ` [PATCH v4 50/52] PCI, x86: Add pci=assign_pref_bars to reallocate pref BARs Yinghai Lu
2015-08-21  6:21 ` [PATCH v4 51/52] PCI: Introduce resource_disabled() Yinghai Lu
2015-08-21  6:21 ` [PATCH v4 52/52] PCI: Don't set flags to 0 when assign resource fail Yinghai Lu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3540278.fBlMDMjYYH@vostro.rjw.lan \
    --to=rjw@rjwysocki.net \
    --cc=akpm@linux-foundation.org \
    --cc=benh@kernel.crashing.org \
    --cc=bhelgaas@google.com \
    --cc=davem@davemloft.net \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=linux@iam.tj \
    --cc=wangyijing@huawei.com \
    --cc=weiyang@linux.vnet.ibm.com \
    --cc=yinghai@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®