From: Dikshita Agarwal <quic_dikshita@quicinc.com>
To: Dhruva Gole <d-gole@ti.com>
Cc: "Rafael J. Wysocki" <rafael@kernel.org>,
Pavel Machek <pavel@ucw.cz>, "Len Brown" <len.brown@intel.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Stanimir Varbanov <stanimir.k.varbanov@gmail.com>,
Vikash Garodia <quic_vgarodia@quicinc.com>,
Bjorn Andersson <andersson@kernel.org>,
"Konrad Dybcio" <konrad.dybcio@linaro.org>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Ulf Hansson <ulf.hansson@linaro.org>,
Bryan O'Donoghue <bryan.odonoghue@linaro.org>,
<linux-pm@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<linux-media@vger.kernel.org>, <linux-arm-msm@vger.kernel.org>
Subject: Re: [PATCH v2 1/2] PM: domains: add device managed version of dev_pm_domain_attach|detach_list()
Date: Thu, 8 Aug 2024 16:25:48 +0530 [thread overview]
Message-ID: <36de7f9c-701f-6650-468b-bf07453e2e21@quicinc.com> (raw)
In-Reply-To: <20240808104130.3lehlvkcprag2md6@lcpd911>
On 8/8/2024 4:11 PM, Dhruva Gole wrote:
> On Aug 07, 2024 at 12:45:46 +0530, Dikshita Agarwal wrote:
>> Add the devres-enabled version of dev_pm_domain_attach|detach_list.
>> If client drivers use devm_pm_domain_attach_list() to attach the
>> PM domains, devm_pm_domain_detach_list() will be invoked implicitly
>> during remove phase.
>>
>> Signed-off-by: Dikshita Agarwal <quic_dikshita@quicinc.com>
>> ---
>> drivers/base/power/common.c | 44 ++++++++++++++++++++++++++++++++++++++++++++
>> include/linux/pm_domain.h | 13 +++++++++++++
>> 2 files changed, 57 insertions(+)
>>
>> diff --git a/drivers/base/power/common.c b/drivers/base/power/common.c
>> index 327d168..729d6c2 100644
>> --- a/drivers/base/power/common.c
>> +++ b/drivers/base/power/common.c
>> @@ -277,6 +277,50 @@ int dev_pm_domain_attach_list(struct device *dev,
>> EXPORT_SYMBOL_GPL(dev_pm_domain_attach_list);
>>
>> /**
>> + * devm_pm_domain_detach_list - devres-enabled version of dev_pm_domain_detach_list.
>> + * @_list: The list of PM domains to detach.
>> + *
>> + * This function reverse the actions from devm_pm_domain_attach_list().
>> + * it will be invoked during the remove phase from drivers implicitly if driver
>> + * uses devm_pm_domain_attach_list() to attach the PM domains.
>> + */
>> +void devm_pm_domain_detach_list(void *_list)
>> +{
>> + struct dev_pm_domain_list *list = _list;
>> +
>> + dev_pm_domain_detach_list(list);
>> +}
>> +EXPORT_SYMBOL_GPL(devm_pm_domain_detach_list);
>> +
>> +/**
>> + * devm_pm_domain_attach_list - devres-enabled version of dev_pm_domain_attach_list
>> + * @dev: The device used to lookup the PM domains for.
>> + * @data: The data used for attaching to the PM domains.
>> + * @list: An out-parameter with an allocated list of attached PM domains.
>> + *
>> + * NOTE: this will also handle calling devm_pm_domain_detach_list() for
>> + * you during remove phase.
>> + *
>> + * Returns the number of attached PM domains or a negative error code in case of
>> + * a failure.
>> + */
>> +int devm_pm_domain_attach_list(struct device *dev,
>> + const struct dev_pm_domain_attach_data *data,
>> + struct dev_pm_domain_list **list)
>> +{
>> + int ret, num_pds = 0;
>
> Do we require this =0? In the very next line you're initing this anyway.
>
That's correct, will fix this. Thanks.
>> +
>> + num_pds = dev_pm_domain_attach_list(dev, data, list);
>> +
>> + ret = devm_add_action_or_reset(dev, devm_pm_domain_detach_list, *list);
>> + if (ret)
>> + return ret;
>> +
>> + return num_pds;
>> +}
>> +EXPORT_SYMBOL_GPL(devm_pm_domain_attach_list);
>> +
>> +/**
>> * dev_pm_domain_detach - Detach a device from its PM domain.
>> * @dev: Device to detach.
>> * @power_off: Used to indicate whether we should power off the device.
>> diff --git a/include/linux/pm_domain.h b/include/linux/pm_domain.h
>> index 772d328..efd517017 100644
>> --- a/include/linux/pm_domain.h
>> +++ b/include/linux/pm_domain.h
>> @@ -450,8 +450,12 @@ struct device *dev_pm_domain_attach_by_name(struct device *dev,
>> int dev_pm_domain_attach_list(struct device *dev,
>> const struct dev_pm_domain_attach_data *data,
>> struct dev_pm_domain_list **list);
>> +int devm_pm_domain_attach_list(struct device *dev,
>> + const struct dev_pm_domain_attach_data *data,
>> + struct dev_pm_domain_list **list);
>> void dev_pm_domain_detach(struct device *dev, bool power_off);
>> void dev_pm_domain_detach_list(struct dev_pm_domain_list *list);
>> +void devm_pm_domain_detach_list(void *list);
>
> Why not just call it dev_pm_domain_list *list? Why make it void? I am a
> bit confused.
>
This comment is not clear to me, could you pls elaborate?
This is just a stub API like others in this file for !CONFIG_PM case.
Thanks,
Dikshita
>
next prev parent reply other threads:[~2024-08-08 10:56 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-07 7:15 [PATCH v2 0/2] " Dikshita Agarwal
2024-08-07 7:15 ` [PATCH v2 1/2] PM: domains: " Dikshita Agarwal
2024-08-08 10:41 ` Dhruva Gole
2024-08-08 10:55 ` Dikshita Agarwal [this message]
2024-08-08 10:59 ` Dikshita Agarwal
2024-08-09 4:19 ` Dhruva Gole
2024-08-09 9:27 ` Dikshita Agarwal
2024-08-09 9:49 ` Dhruva Gole
2024-08-13 10:52 ` Ulf Hansson
2024-08-13 12:23 ` Dikshita Agarwal
2024-08-07 7:15 ` [PATCH v2 2/2] media: venus: use device managed APIs for power domains Dikshita Agarwal
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=36de7f9c-701f-6650-468b-bf07453e2e21@quicinc.com \
--to=quic_dikshita@quicinc.com \
--cc=andersson@kernel.org \
--cc=bryan.odonoghue@linaro.org \
--cc=d-gole@ti.com \
--cc=gregkh@linuxfoundation.org \
--cc=konrad.dybcio@linaro.org \
--cc=len.brown@intel.com \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=mchehab@kernel.org \
--cc=pavel@ucw.cz \
--cc=quic_vgarodia@quicinc.com \
--cc=rafael@kernel.org \
--cc=stanimir.k.varbanov@gmail.com \
--cc=ulf.hansson@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®