From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1037162AbdDUKeI (ORCPT ); Fri, 21 Apr 2017 06:34:08 -0400 Received: from smtprelay2.synopsys.com ([198.182.60.111]:55819 "EHLO smtprelay.synopsys.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1036454AbdDUKeH (ORCPT ); Fri, 21 Apr 2017 06:34:07 -0400 Subject: Re: [alsa-devel] [PATCH] ASoC: dwc: disallow building designware_pcm as a module To: Takashi Iwai , Mark Brown References: <20170418105954.23368-1-lkundrak@v3.sk> <20170418151834.c7e5fivmgn73sbwd@sirena.org.uk> <1492532010.28092.12.camel@v3.sk> <20170418171519.csiftftd434psyn5@sirena.org.uk> <2e39b000-bf25-6447-b53b-047401041f4e@synopsys.com> <1492618461.28092.18.camel@v3.sk> <03a3fbbb-7221-f4ee-5b1b-8fff518ea82c@synopsys.com> <20170420194646.qcpu7w3acjyfmeu5@sirena.org.uk> CC: Jose Abreu , Lubomir Rintel , , , Arnd Bergmann From: Jose Abreu Message-ID: <376c5933-9321-5399-74c7-6fd4943fab3d@synopsys.com> Date: Fri, 21 Apr 2017 11:34:00 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset="windows-1252" Content-Transfer-Encoding: 7bit X-Originating-IP: [10.107.19.99] Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi, On 20-04-2017 21:24, Takashi Iwai wrote: > So, I think Lubomir's change is right. But the patch subject and > description should be rephrased. > > One thing I don't like is the rename of the file. But in this > particular case, it's unavoidable unless we rename the module name. > Maybe rename to "dwc-i2s.c" and "dwc-pcm.c" (as the folder is called "dwc") and let the module still be called "designware-i2s"? > BTW, we should drop the superfluous EXPORT_SYMBOL*(), too. > > > Lubomir, could you please remove the EXPORT_SYMBOL, change the commit message and resend? Best regards, Jose Miguel Abreu