From: Florian Fainelli <f.fainelli@gmail.com>
To: Tristram.Ha@microchip.com, Andrew Lunn <andrew@lunn.ch>,
Pavel Machek <pavel@ucw.cz>,
Ruediger Schmitt <ruediger.schmitt@philips.com>
Cc: muvarov@gmail.com, nathan.leigh.conrad@gmail.com,
vivien.didelot@savoirfairelinux.com,
UNGLinuxDriver@microchip.com, netdev@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v1 RFC 0/7] Modify KSZ9477 DSA driver in preparation to add other KSZ switch drivers
Date: Mon, 9 Oct 2017 12:58:49 -0700 [thread overview]
Message-ID: <37fdf098-1002-2932-0b31-c28db8ede833@gmail.com> (raw)
In-Reply-To: <1507321985-15097-1-git-send-email-Tristram.Ha@microchip.com>
On 10/06/2017 01:32 PM, Tristram.Ha@microchip.com wrote:
> From: Tristram Ha <Tristram.Ha@microchip.com>
>
> This series of patches is to modify the original KSZ9477 DSA driver so
> that other KSZ switch drivers can be added and use the common code.
>
> There are several steps to accomplish this achievement. First is to
> rename some function names with a prefix to indicate chip specific
> function. Second is to move common code into header that can be shared.
> Last is to modify tag_ksz.c so that it can handle many tail tag formats
> used by different KSZ switch drivers.
>
> ksz_common.c will contain the common code used by all KSZ switch drivers.
> ksz9477.c will contain KSZ9477 code from the original ksz_common.c.
> ksz9477_spi.c is renamed from ksz_spi.c.
> ksz9477_reg.h is renamed from ksz_9477_reg.h.
> ksz_common.h is added to provide common code access to KSZ switch
> drivers.
> ksz_spi.h is added to provide common SPI access functions to KSZ SPI
> drivers.
Most of this looks fine, and it is probably time to move away from the
RFC state and do a formal patch submission with the Reviewed-by and
Acked-by tags you just collected.
Can you also make sure you prefix your patches with: net: dsa: to be
consistent with other submissions done to that subsystem, e.g:
net: dsa: microchip: Replace license with GPL
Thank you!
>
> v1
> - Each patch in the set is self-contained
> - Use ksz9477 prefix to indicate KSZ9477 specific code
> - Simplify MIB counter reading code
> - Switch driver code is not accessed from tag_ksz.c
>
> Tristram Ha (7):
> Replace license with GPL.
> Clean up code according to patch check suggestions.
> Rename some functions with ksz9477 prefix to separate chip specific
> code from common code.
> Rename ksz_spi.c to ksz9477_spi.c and update Kconfig in preparation to
> add more KSZ switch drivers.
> Break KSZ9477 DSA driver into two files in preparation to add more KSZ
> switch drivers. Add common functions in ksz_common.h so that other
> KSZ switch drivers can access code in ksz_common.c. Add ksz_spi.h
> for common functions used by KSZ switch SPI drivers.
> Add MIB counter reading support. Rename ksz_9477_reg.h to
> ksz9477_reg.h for consistency as the product name is always KSZ####.
> Header file ksz_priv.h no longer contains any chip specific data.
> Modify tag_ksz.c so that tail tag code can be used by other KSZ switch
> drivers.
>
> drivers/net/dsa/microchip/Kconfig | 14 +-
> drivers/net/dsa/microchip/Makefile | 4 +-
> drivers/net/dsa/microchip/ksz9477.c | 1376 ++++++++++++++++++++
> .../microchip/{ksz_9477_reg.h => ksz9477_reg.h} | 23 +-
> drivers/net/dsa/microchip/ksz9477_spi.c | 188 +++
> drivers/net/dsa/microchip/ksz_common.c | 1210 ++++-------------
> drivers/net/dsa/microchip/ksz_common.h | 234 ++++
> drivers/net/dsa/microchip/ksz_priv.h | 258 ++--
> drivers/net/dsa/microchip/ksz_spi.c | 216 ---
> drivers/net/dsa/microchip/ksz_spi.h | 82 ++
> include/net/dsa.h | 2 +-
> net/dsa/Kconfig | 4 +
> net/dsa/dsa.c | 4 +-
> net/dsa/dsa_priv.h | 2 +-
> net/dsa/tag_ksz.c | 107 +-
> 15 files changed, 2331 insertions(+), 1393 deletions(-)
> create mode 100644 drivers/net/dsa/microchip/ksz9477.c
> rename drivers/net/dsa/microchip/{ksz_9477_reg.h => ksz9477_reg.h} (98%)
> create mode 100644 drivers/net/dsa/microchip/ksz9477_spi.c
> create mode 100644 drivers/net/dsa/microchip/ksz_common.h
> delete mode 100644 drivers/net/dsa/microchip/ksz_spi.c
> create mode 100644 drivers/net/dsa/microchip/ksz_spi.h
>
--
Florian
prev parent reply other threads:[~2017-10-09 19:58 UTC|newest]
Thread overview: 33+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-06 20:32 Tristram.Ha
2017-10-06 20:32 ` [PATCH v1 RFC 1/7] Replace license with GPL Tristram.Ha
2017-10-09 9:18 ` David Laight
2017-10-09 18:40 ` Tristram.Ha
2017-10-09 19:40 ` Florian Fainelli
2017-10-14 19:41 ` Andrew Lunn
2017-10-09 19:54 ` Pavel Machek
2017-10-09 19:58 ` Woojung.Huh
2017-10-06 20:33 ` [PATCH v1 RFC 2/7] Clean up code according to patch check suggestions Tristram.Ha
2017-10-09 19:54 ` Pavel Machek
2017-10-09 19:54 ` Florian Fainelli
2017-10-14 19:42 ` Andrew Lunn
2017-10-06 20:33 ` [PATCH v1 RFC 3/7] Rename some functions with ksz9477 prefix Tristram.Ha
2017-10-09 19:54 ` Pavel Machek
2017-10-09 19:56 ` Florian Fainelli
2017-10-14 19:44 ` Andrew Lunn
2017-10-06 20:33 ` [PATCH v1 RFC 4/7] Rename ksz_spi.c to ksz9477_spi.c Tristram.Ha
2017-10-09 19:54 ` Pavel Machek
2017-10-09 19:56 ` Florian Fainelli
2017-10-14 19:45 ` Andrew Lunn
2017-10-06 20:33 ` [PATCH v1 RFC 5/7] Break KSZ9477 DSA driver into two files Tristram.Ha
2017-10-09 19:54 ` Pavel Machek
2017-10-09 20:01 ` Florian Fainelli
2017-10-14 19:52 ` Andrew Lunn
2017-10-06 20:33 ` [PATCH v1 RFC 6/7] Add MIB counter reading support Tristram.Ha
2017-10-09 19:54 ` Pavel Machek
2017-10-09 20:07 ` Florian Fainelli
2017-10-14 20:07 ` Andrew Lunn
2017-10-06 20:33 ` [PATCH v1 RFC 7/7] Modify tag_ksz.c so that tail tag code can be used by other KSZ switch drivers Tristram.Ha
2017-10-11 20:45 ` Pavel Machek
2017-10-18 18:02 ` Tristram.Ha
2017-10-14 20:15 ` Andrew Lunn
2017-10-09 19:58 ` Florian Fainelli [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=37fdf098-1002-2932-0b31-c28db8ede833@gmail.com \
--to=f.fainelli@gmail.com \
--cc=Tristram.Ha@microchip.com \
--cc=UNGLinuxDriver@microchip.com \
--cc=andrew@lunn.ch \
--cc=linux-kernel@vger.kernel.org \
--cc=muvarov@gmail.com \
--cc=nathan.leigh.conrad@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=pavel@ucw.cz \
--cc=ruediger.schmitt@philips.com \
--cc=vivien.didelot@savoirfairelinux.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®