From: Eugen Hristev <eugen.hristev@collabora.com>
To: "Jason-JH.Lin" <jason-jh.lin@mediatek.com>,
Chun-Kuang Hu <chunkuang.hu@kernel.org>,
AngeloGioacchino Del Regno
<angelogioacchino.delregno@collabora.com>
Cc: Matthias Brugger <matthias.bgg@gmail.com>,
Jason-ch Chen <jason-ch.chen@mediatek.com>,
Johnson Wang <johnson.wang@mediatek.com>,
Singo Chang <singo.chang@mediatek.com>,
Nancy Lin <nancy.lin@mediatek.com>,
Shawn Sung <shawn.sung@mediatek.com>,
dri-devel@lists.freedesktop.org,
linux-mediatek@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org,
Project_Global_Chrome_Upstream_Group@mediatek.com
Subject: Re: [PATCH v8 2/8] drm/mediatevk: Add crtc path enum for all_drm_priv array
Date: Thu, 3 Aug 2023 16:18:12 +0300 [thread overview]
Message-ID: <38720b56-df8e-d25a-0e6f-ca6e1fb3df26@collabora.com> (raw)
In-Reply-To: <20230802144802.751-3-jason-jh.lin@mediatek.com>
On 8/2/23 17:47, Jason-JH.Lin wrote:
> Add mtk_drm_crtc_path enum for eatch display path.
Typo: each
>
> Instead of using array index of all_drm_priv in mtk_drm_kms_init(),
> mtk_drm_crtc_path enum can make more readable.
can make *code* more readable ?
>
> Signed-off-by: Jason-JH.Lin <jason-jh.lin@mediatek.com>
> ---
> drivers/gpu/drm/mediatek/mtk_drm_drv.c | 6 +++---
> drivers/gpu/drm/mediatek/mtk_drm_drv.h | 8 +++++++-
> 2 files changed, 10 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpu/drm/mediatek/mtk_drm_drv.c b/drivers/gpu/drm/mediatek/mtk_drm_drv.c
> index 249c9fd6347e..89a38561ba27 100644
> --- a/drivers/gpu/drm/mediatek/mtk_drm_drv.c
> +++ b/drivers/gpu/drm/mediatek/mtk_drm_drv.c
> @@ -465,21 +465,21 @@ static int mtk_drm_kms_init(struct drm_device *drm)
> for (j = 0; j < private->data->mmsys_dev_num; j++) {
> priv_n = private->all_drm_private[j];
>
> - if (i == 0 && priv_n->data->main_len) {
> + if (i == CRTC_MAIN && priv_n->data->main_len) {
> ret = mtk_drm_crtc_create(drm, priv_n->data->main_path,
> priv_n->data->main_len, j);
> if (ret)
> goto err_component_unbind;
>
> continue;
> - } else if (i == 1 && priv_n->data->ext_len) {
> + } else if (i == CRTC_EXT && priv_n->data->ext_len) {
> ret = mtk_drm_crtc_create(drm, priv_n->data->ext_path,
> priv_n->data->ext_len, j);
> if (ret)
> goto err_component_unbind;
>
> continue;
> - } else if (i == 2 && priv_n->data->third_len) {
> + } else if (i == CRTC_THIRD && priv_n->data->third_len) {
> ret = mtk_drm_crtc_create(drm, priv_n->data->third_path,
> priv_n->data->third_len, j);
> if (ret)
> diff --git a/drivers/gpu/drm/mediatek/mtk_drm_drv.h b/drivers/gpu/drm/mediatek/mtk_drm_drv.h
> index eb2fd45941f0..f4de8bb27685 100644
> --- a/drivers/gpu/drm/mediatek/mtk_drm_drv.h
> +++ b/drivers/gpu/drm/mediatek/mtk_drm_drv.h
> @@ -9,11 +9,17 @@
> #include <linux/io.h>
> #include "mtk_drm_ddp_comp.h"
>
> -#define MAX_CRTC 3
> #define MAX_CONNECTOR 2
> #define DDP_COMPONENT_DRM_OVL_ADAPTOR (DDP_COMPONENT_ID_MAX + 1)
> #define DDP_COMPONENT_DRM_ID_MAX (DDP_COMPONENT_DRM_OVL_ADAPTOR + 1)
>
> +enum mtk_drm_crtc_path {
> + CRTC_MAIN,
> + CRTC_EXT,
> + CRTC_THIRD,
> + MAX_CRTC,
> +};
> +
> struct device;
> struct device_node;
> struct drm_crtc;
next parent reply other threads:[~2023-08-03 13:18 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20230802144802.751-1-jason-jh.lin@mediatek.com>
[not found] ` <20230802144802.751-3-jason-jh.lin@mediatek.com>
2023-08-03 13:18 ` Eugen Hristev [this message]
2023-08-05 7:27 ` Jason-JH Lin (林睿祥)
[not found] ` <20230802144802.751-4-jason-jh.lin@mediatek.com>
2023-08-03 13:22 ` [PATCH v8 3/8] drm/mediatek: Fix using wrong drm private data to bind mediatek-drm Eugen Hristev
2023-08-05 8:05 ` Jason-JH Lin (林睿祥)
[not found] ` <20230802144802.751-5-jason-jh.lin@mediatek.com>
2023-08-03 13:27 ` [PATCH v8 4/8] drm/mediatek: Add encoder_index function to mtk_ddp_comp_funcs Eugen Hristev
2023-08-05 7:40 ` Jason-JH Lin (林睿祥)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=38720b56-df8e-d25a-0e6f-ca6e1fb3df26@collabora.com \
--to=eugen.hristev@collabora.com \
--cc=Project_Global_Chrome_Upstream_Group@mediatek.com \
--cc=angelogioacchino.delregno@collabora.com \
--cc=chunkuang.hu@kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=jason-ch.chen@mediatek.com \
--cc=jason-jh.lin@mediatek.com \
--cc=johnson.wang@mediatek.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=matthias.bgg@gmail.com \
--cc=nancy.lin@mediatek.com \
--cc=shawn.sung@mediatek.com \
--cc=singo.chang@mediatek.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®