From: Valentin Schneider <valentin.schneider@arm.com>
To: Vincent Guittot <vincent.guittot@linaro.org>,
linux-kernel@vger.kernel.org, mingo@redhat.com,
peterz@infradead.org
Cc: pauld@redhat.com, srikar@linux.vnet.ibm.com,
quentin.perret@arm.com, dietmar.eggemann@arm.com,
Morten.Rasmussen@arm.com, hdanton@sina.com
Subject: Re: [PATCH v3 02/10] sched/fair: rename sum_nr_running to sum_h_nr_running
Date: Tue, 1 Oct 2019 18:11:42 +0100 [thread overview]
Message-ID: <389469a6-d295-2faa-7605-539720eba7a1@arm.com> (raw)
In-Reply-To: <1568878421-12301-3-git-send-email-vincent.guittot@linaro.org>
On 19/09/2019 08:33, Vincent Guittot wrote:
> Rename sum_nr_running to sum_h_nr_running because it effectively tracks
> cfs->h_nr_running so we can use sum_nr_running to track rq->nr_running
> when needed.
>
> There is no functional changes.
>
> Signed-off-by: Vincent Guittot <vincent.guittot@linaro.org>
Reviewed-by: Valentin Schneider <valentin.schneider@arm.com>
next prev parent reply other threads:[~2019-10-01 17:11 UTC|newest]
Thread overview: 57+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-09-19 7:33 [PATCH v3 0/8] sched/fair: rework the CFS load balance Vincent Guittot
2019-09-19 7:33 ` [PATCH v3 01/10] sched/fair: clean up asym packing Vincent Guittot
2019-09-27 23:57 ` Rik van Riel
2019-09-19 7:33 ` [PATCH v3 02/10] sched/fair: rename sum_nr_running to sum_h_nr_running Vincent Guittot
2019-09-27 23:59 ` Rik van Riel
2019-10-01 17:11 ` Valentin Schneider [this message]
2019-09-19 7:33 ` [PATCH v3 03/10] sched/fair: remove meaningless imbalance calculation Vincent Guittot
2019-09-28 0:05 ` Rik van Riel
2019-10-01 17:12 ` Valentin Schneider
2019-10-02 6:28 ` Vincent Guittot
2019-09-19 7:33 ` [PATCH v3 04/10] sched/fair: rework load_balance Vincent Guittot
2019-09-30 1:12 ` Rik van Riel
2019-09-30 7:44 ` Vincent Guittot
2019-09-30 16:24 ` Dietmar Eggemann
2019-10-01 8:14 ` Vincent Guittot
2019-10-01 16:52 ` Dietmar Eggemann
2019-10-02 6:44 ` Vincent Guittot
2019-10-02 9:21 ` Dietmar Eggemann
2019-10-08 13:02 ` Peter Zijlstra
2019-10-02 8:23 ` Vincent Guittot
2019-10-02 9:24 ` Dietmar Eggemann
2019-10-01 8:15 ` Dietmar Eggemann
2019-10-01 9:14 ` Vincent Guittot
2019-10-01 16:57 ` Dietmar Eggemann
2019-10-01 17:47 ` Valentin Schneider
2019-10-02 8:30 ` Vincent Guittot
2019-10-02 10:47 ` Valentin Schneider
2019-10-08 14:16 ` Peter Zijlstra
2019-10-08 14:34 ` Valentin Schneider
2019-10-08 15:30 ` Vincent Guittot
2019-10-08 15:48 ` Valentin Schneider
2019-10-08 17:39 ` Peter Zijlstra
2019-10-08 18:45 ` Vincent Guittot
2019-10-08 16:33 ` Peter Zijlstra
2019-10-08 16:39 ` Valentin Schneider
2019-10-08 17:36 ` Valentin Schneider
2019-10-08 17:55 ` Peter Zijlstra
2019-10-08 18:47 ` Vincent Guittot
2019-10-16 7:21 ` Parth Shah
2019-10-16 11:56 ` Vincent Guittot
2019-10-18 5:34 ` Parth Shah
2019-09-19 7:33 ` [PATCH v3 05/10] sched/fair: use rq->nr_running when balancing load Vincent Guittot
2019-09-19 7:33 ` [PATCH v3 06/10] sched/fair: use load instead of runnable load in load_balance Vincent Guittot
2019-09-19 7:33 ` [PATCH v3 07/10] sched/fair: evenly spread tasks when not overloaded Vincent Guittot
2019-09-19 7:33 ` [PATCH v3 08/10] sched/fair: use utilization to select misfit task Vincent Guittot
2019-10-01 17:12 ` Valentin Schneider
2019-09-19 7:33 ` [PATCH v3 09/10] sched/fair: use load instead of runnable load in wakeup path Vincent Guittot
2019-10-07 15:14 ` Rik van Riel
2019-10-07 15:27 ` Vincent Guittot
2019-10-07 18:06 ` Rik van Riel
2019-09-19 7:33 ` [PATCH v3 10/10] sched/fair: optimize find_idlest_group Vincent Guittot
2019-10-08 14:32 ` [PATCH v3 0/8] sched/fair: rework the CFS load balance Phil Auld
2019-10-08 15:53 ` Vincent Guittot
2019-10-09 19:33 ` Phil Auld
2019-10-10 8:20 ` Vincent Guittot
2019-10-16 7:21 ` Parth Shah
2019-10-16 11:51 ` Vincent Guittot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=389469a6-d295-2faa-7605-539720eba7a1@arm.com \
--to=valentin.schneider@arm.com \
--cc=Morten.Rasmussen@arm.com \
--cc=dietmar.eggemann@arm.com \
--cc=hdanton@sina.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=pauld@redhat.com \
--cc=peterz@infradead.org \
--cc=quentin.perret@arm.com \
--cc=srikar@linux.vnet.ibm.com \
--cc=vincent.guittot@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®