mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Jeffery <andrew@codeconstruct.com.au>
To: Kevin Tung <kevin.tung.openbmc@gmail.com>,
	Rob Herring <robh@kernel.org>,
	 Krzysztof Kozlowski	 <krzk+dt@kernel.org>,
	Conor Dooley <conor+dt@kernel.org>,
	Joel Stanley	 <joel@jms.id.au>
Cc: devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	 linux-aspeed@lists.ozlabs.org, linux-kernel@vger.kernel.org,
	Amithash Prasasd	 <amithash@meta.com>,
	Kevin Tung <Kevin.Tung@quantatw.com>,
	Ken Chen	 <Ken.Chen@quantatw.com>,
	Leo Yang <Leo-Yang@quantatw.com>,
	Jackson Liu	 <Jackson.Liu@quantatw.com>,
	Daniel Hsu <Daniel-Hsu@quantatw.com>
Subject: Re: [PATCH v5 3/8] ARM: dts: aspeed: yosemite5: Add new SGPIO line names and rename signal
Date: Wed, 04 Mar 2026 13:10:59 +1030	[thread overview]
Message-ID: <391b9b912492c07fd1fd7a737b7f49382d361fe2.camel@codeconstruct.com.au> (raw)
In-Reply-To: <20260223-yv5_revise_dts-v5-3-fc913e902488@gmail.com>

On Mon, 2026-02-23 at 19:17 +0800, Kevin Tung wrote:
> Add new SGPIO line names for user space monitoring and event logging.
> 
> Also rename PADDLE_BD_IOEXP_INT to ALERT_IRQ_PMBUS_PWR2_N to match
> hardware naming. The original PADDLE_BD_IOEXP_INT is unused, so this
> change does not affect current system functionality.

Why are these two problems being solved in the one patch?

https://docs.kernel.org/process/submitting-patches.html#split-changes

Essentially, your use of "Also" is a bit of a red flag here.

However, on the specifics, why was the PADDLE_BD_IOEXP_INT hardware
naming wrong to begin with? What changed?

Broadly, it feels a lot like you're revising platform designs, then
trying to make the one devicetree fit the current design, and are not
explicitly communicating that this is what you're doing.

If that _is_ what you're doing, then we can come up with much better
schemes to handle it that aren't a constant stream of compatibility
breaks.

I need you to engage with this concern.

From inspection, I only find patches 1, 4 and 7 of this series to be
something I'd consider applying without further discussion.

Andrew

  reply	other threads:[~2026-03-04  2:41 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-02-23 11:17 [PATCH v5 0/8] Revise Meta Yosemite5 devicetree Kevin Tung
2026-02-23 11:17 ` [PATCH v5 1/8] ARM: dts: aspeed: yosemite5: Increase i2c4/i2c12 bus speed to 400 kHz Kevin Tung
2026-02-23 11:17 ` [PATCH v5 2/8] ARM: dts: aspeed: yosemite5: Remove ambiguous power monitor DTS nodes Kevin Tung
2026-03-04  2:41   ` Andrew Jeffery
2026-03-09 18:41     ` Kevin Tung
2026-03-26  6:07       ` Andrew Jeffery
2026-03-30  3:15         ` Kevin Tung
2026-02-23 11:17 ` [PATCH v5 3/8] ARM: dts: aspeed: yosemite5: Add new SGPIO line names and rename signal Kevin Tung
2026-03-04  2:40   ` Andrew Jeffery [this message]
2026-03-09 18:34     ` Kevin Tung
2026-03-26  6:10       ` Andrew Jeffery
2026-02-23 11:17 ` [PATCH v5 4/8] ARM: dts: aspeed: yosemite5: Add IPMB node for OCP debug card Kevin Tung
2026-02-23 11:17 ` [PATCH v5 5/8] ARM: dts: aspeed: yosemite5: Correct power monitor shunt resistor Kevin Tung
2026-02-23 11:17 ` [PATCH v5 6/8] ARM: dts: aspeed: yosemite5: Add power distribution board IO expanders Kevin Tung
2026-02-23 11:17 ` [PATCH v5 7/8] ARM: dts: aspeed: yosemite5: Add debug card bypass GPIO Kevin Tung
2026-02-23 11:17 ` [PATCH v5 8/8] ARM: dts: aspeed: yosemite5: Fix host0-ready and add POST end GPIO Kevin Tung

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=391b9b912492c07fd1fd7a737b7f49382d361fe2.camel@codeconstruct.com.au \
    --to=andrew@codeconstruct.com.au \
    --cc=Daniel-Hsu@quantatw.com \
    --cc=Jackson.Liu@quantatw.com \
    --cc=Ken.Chen@quantatw.com \
    --cc=Kevin.Tung@quantatw.com \
    --cc=Leo-Yang@quantatw.com \
    --cc=amithash@meta.com \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=joel@jms.id.au \
    --cc=kevin.tung.openbmc@gmail.com \
    --cc=krzk+dt@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-aspeed@lists.ozlabs.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robh@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®