From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Stephen Boyd <swboyd@chromium.org>
Cc: Tri Vo <trong@android.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Viresh Kumar <viresh.kumar@linaro.org>,
Hridya Valsaraju <hridya@google.com>,
Sandeep Patil <sspatil@google.com>,
Kalesh Singh <kaleshsingh@google.com>,
Ravi Chandra Sadineni <ravisadineni@chromium.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Linux PM <linux-pm@vger.kernel.org>,
"Cc: Android Kernel" <kernel-team@android.com>,
kbuild test robot <lkp@intel.com>
Subject: Re: [PATCH v5] PM / wakeup: show wakeup sources stats in sysfs
Date: Wed, 31 Jul 2019 13:58:36 +0200 [thread overview]
Message-ID: <3963324.N1Qi0Ay72S@kreacher> (raw)
In-Reply-To: <CAJZ5v0hj-GpiYN7nwPJvKJag71MG6zEFbJ6BNwzDidD+7fNFWw@mail.gmail.com>
On Wednesday, July 31, 2019 10:34:11 AM CEST Rafael J. Wysocki wrote:
> On Wed, Jul 31, 2019 at 1:41 AM Stephen Boyd <swboyd@chromium.org> wrote:
> >
> > Quoting Rafael J. Wysocki (2019-07-30 16:05:55)
> > > On Wed, Jul 31, 2019 at 12:26 AM Stephen Boyd <swboyd@chromium.org> wrote:
> > > >
> > > > Quoting Rafael J. Wysocki (2019-07-30 15:17:55)
> > > > > On Tuesday, July 30, 2019 8:48:09 PM CEST Stephen Boyd wrote:
> > > > > >
> > > > > > Using the same prefix for the class and the device name is quite common.
> > > > > > For example, see the input, regulator, tty, tpm, remoteproc, hwmon,
> > > > > > extcon classes. I'd prefer it was left as /sys/class/wakeup/wakeupN. The
> > > > > > class name could be changed to wakeup_source perhaps (i.e.
> > > > > > /sys/class/wakeup_source/wakeupN)?
> > > > >
> > > > > Alternatively /sys/class/wakeup/wsN
> > > > >
> > > >
> > > > Or /sys/class/wakeup/eventN? It's your bikeshed to paint.
> > >
> > > So actually the underlying problem here is that device_wakeup_enable()
> > > tries to register a wakeup source and then attach it to the device to
> > > avoid calling possibly sleeping functions under a spinlock.
> >
> > Agreed, that is one problem.
> >
> > >
> > > However, it should be possible to call wakeup_source_create(name)
> > > first, then attach the wakeup source to the device (after checking for
> > > presence), and then invoke wakeup_source_add() (after dropping the
> > > lock). If the wakeup source virtual device registration is done in
> > > wakeup_source_add(), that should avoid the problem altogether without
> > > having to introduce extra complexity.
> >
> > While reordering the code to do what you describe will fix this specific
> > duplicate name problem, it won't fix the general problem with reusing
> > device names from one bus on a different bus/class.
>
> Fair enough.
>
> > We can run into the same problem when two buses name their devices the
> > same name and then we attempt to attach a wakeup source to those two
> > devices. Or we can have a problem where a virtual wakeup is made with
> > the same name, and again we'll try to make a duplicate named device.
> > Using something like 'event' or 'wakeup' or 'ws' as the prefix avoids this
> > problem and keeps things clean.
>
> Or suffix, like "<devname-wakeup>.
>
> But if prefixes are used by an existing convention, I would prefer
> "ws-" as it is concise enough and should not be confusing.
>
> > We should probably avoid letting the same virtual wakeup source be made
> > with the same name anyway, because userspace will be confused about what
> > virtual wakeup it is otherwise. I concede that using the name of the
> > wakeup source catches this problem without adding extra code.
> >
> > Either way, I'd like to see what you outline implemented so that we
> > don't need to do more work than is necessary when userspace writes to
> > the file.
>
> Since we agree here, let's make this change first. I can cut a patch
> for that in a reasonable time frame I think if no one else beats me to
> that.
So maybe something like the patch below (untested).
---
drivers/base/power/wakeup.c | 82 +++++++++++++++++---------------------------
1 file changed, 33 insertions(+), 49 deletions(-)
Index: linux-pm/drivers/base/power/wakeup.c
===================================================================
--- linux-pm.orig/drivers/base/power/wakeup.c
+++ linux-pm/drivers/base/power/wakeup.c
@@ -228,27 +228,6 @@ void wakeup_source_unregister(struct wak
EXPORT_SYMBOL_GPL(wakeup_source_unregister);
/**
- * device_wakeup_attach - Attach a wakeup source object to a device object.
- * @dev: Device to handle.
- * @ws: Wakeup source object to attach to @dev.
- *
- * This causes @dev to be treated as a wakeup device.
- */
-static int device_wakeup_attach(struct device *dev, struct wakeup_source *ws)
-{
- spin_lock_irq(&dev->power.lock);
- if (dev->power.wakeup) {
- spin_unlock_irq(&dev->power.lock);
- return -EEXIST;
- }
- dev->power.wakeup = ws;
- if (dev->power.wakeirq)
- device_wakeup_attach_irq(dev, dev->power.wakeirq);
- spin_unlock_irq(&dev->power.lock);
- return 0;
-}
-
-/**
* device_wakeup_enable - Enable given device to be a wakeup source.
* @dev: Device to handle.
*
@@ -265,15 +244,29 @@ int device_wakeup_enable(struct device *
if (pm_suspend_target_state != PM_SUSPEND_ON)
dev_dbg(dev, "Suspicious %s() during system transition!\n", __func__);
+ spin_lock_irq(&dev->power.lock);
+
+ if (dev->power.wakeup) {
+ spin_unlock_irq(&dev->power.lock);
+ return -EEXIST;
+ }
+ dev->power.wakeup = ERR_PTR(-EBUSY);
+
+ spin_unlock_irq(&dev->power.lock);
+
ws = wakeup_source_register(dev_name(dev));
if (!ws)
return -ENOMEM;
- ret = device_wakeup_attach(dev, ws);
- if (ret)
- wakeup_source_unregister(ws);
+ spin_lock_irq(&dev->power.lock);
- return ret;
+ dev->power.wakeup = ws;
+ if (dev->power.wakeirq)
+ device_wakeup_attach_irq(dev, dev->power.wakeirq);
+
+ spin_unlock_irq(&dev->power.lock);
+
+ return 0;
}
EXPORT_SYMBOL_GPL(device_wakeup_enable);
@@ -294,7 +287,7 @@ void device_wakeup_attach_irq(struct dev
struct wakeup_source *ws;
ws = dev->power.wakeup;
- if (!ws)
+ if (IS_ERR_OR_NULL(ws))
return;
if (ws->wakeirq)
@@ -316,7 +309,7 @@ void device_wakeup_detach_irq(struct dev
struct wakeup_source *ws;
ws = dev->power.wakeup;
- if (ws)
+ if (!IS_ERR_OR_NULL(ws))
ws->wakeirq = NULL;
}
@@ -353,23 +346,6 @@ void device_wakeup_disarm_wake_irqs(void
}
/**
- * device_wakeup_detach - Detach a device's wakeup source object from it.
- * @dev: Device to detach the wakeup source object from.
- *
- * After it returns, @dev will not be treated as a wakeup device any more.
- */
-static struct wakeup_source *device_wakeup_detach(struct device *dev)
-{
- struct wakeup_source *ws;
-
- spin_lock_irq(&dev->power.lock);
- ws = dev->power.wakeup;
- dev->power.wakeup = NULL;
- spin_unlock_irq(&dev->power.lock);
- return ws;
-}
-
-/**
* device_wakeup_disable - Do not regard a device as a wakeup source any more.
* @dev: Device to handle.
*
@@ -383,8 +359,16 @@ int device_wakeup_disable(struct device
if (!dev || !dev->power.can_wakeup)
return -EINVAL;
- ws = device_wakeup_detach(dev);
- wakeup_source_unregister(ws);
+ spin_lock_irq(&dev->power.lock);
+
+ ws = dev->power.wakeup;
+ dev->power.wakeup = NULL;
+
+ spin_unlock_irq(&dev->power.lock);
+
+ if (!IS_ERR(ws))
+ wakeup_source_unregister(ws);
+
return 0;
}
EXPORT_SYMBOL_GPL(device_wakeup_disable);
@@ -558,7 +542,7 @@ void __pm_stay_awake(struct wakeup_sourc
{
unsigned long flags;
- if (!ws)
+ if (IS_ERR_OR_NULL(ws))
return;
spin_lock_irqsave(&ws->lock, flags);
@@ -675,7 +659,7 @@ void __pm_relax(struct wakeup_source *ws
{
unsigned long flags;
- if (!ws)
+ if (IS_ERR_OR_NULL(ws))
return;
spin_lock_irqsave(&ws->lock, flags);
@@ -746,7 +730,7 @@ void pm_wakeup_ws_event(struct wakeup_so
unsigned long flags;
unsigned long expires;
- if (!ws)
+ if (IS_ERR_OR_NULL(ws))
return;
spin_lock_irqsave(&ws->lock, flags);
next prev parent reply other threads:[~2019-07-31 11:58 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-07-30 2:43 Tri Vo
2019-07-30 5:46 ` Rafael J. Wysocki
2019-07-30 18:39 ` Tri Vo
2019-07-30 18:48 ` Stephen Boyd
2019-07-30 18:51 ` Greg Kroah-Hartman
2019-07-30 22:17 ` Rafael J. Wysocki
2019-07-30 22:26 ` Stephen Boyd
2019-07-30 23:05 ` Rafael J. Wysocki
2019-07-30 23:31 ` Tri Vo
2019-07-30 23:41 ` Stephen Boyd
2019-07-31 8:34 ` Rafael J. Wysocki
2019-07-31 11:58 ` Rafael J. Wysocki [this message]
2019-07-31 17:13 ` Stephen Boyd
2019-07-31 17:17 ` Greg Kroah-Hartman
2019-07-31 21:19 ` Rafael J. Wysocki
2019-07-31 21:23 ` Tri Vo
2019-07-30 18:49 ` Greg Kroah-Hartman
2019-07-30 6:46 ` Greg KH
2019-07-30 19:20 ` Tri Vo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3963324.N1Qi0Ay72S@kreacher \
--to=rjw@rjwysocki.net \
--cc=gregkh@linuxfoundation.org \
--cc=hridya@google.com \
--cc=kaleshsingh@google.com \
--cc=kernel-team@android.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=lkp@intel.com \
--cc=ravisadineni@chromium.org \
--cc=sspatil@google.com \
--cc=swboyd@chromium.org \
--cc=trong@android.com \
--cc=viresh.kumar@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®