From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752185AbdJPMk2 (ORCPT ); Mon, 16 Oct 2017 08:40:28 -0400 Received: from bastet.se.axis.com ([195.60.68.11]:59359 "EHLO bastet.se.axis.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751410AbdJPMk1 (ORCPT ); Mon, 16 Oct 2017 08:40:27 -0400 Subject: Re: [PATCH 09/10] PCI: dwc: make cpu_addr_fixup take struct dw_pcie as argument To: Kishon Vijay Abraham I , Bjorn Helgaas , Jesper Nilsson , Jingoo Han , Joao Pinto CC: , , , References: <20171013160914.3220-1-niklas.cassel@axis.com> <20171013160914.3220-10-niklas.cassel@axis.com> From: Niklas Cassel Message-ID: <3970f7e1-c5bf-3c0c-98fb-fc0bf5b14212@axis.com> Date: Mon, 16 Oct 2017 14:40:24 +0200 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0 MIME-Version: 1.0 In-Reply-To: <20171013160914.3220-10-niklas.cassel@axis.com> Content-Type: text/plain; charset="utf-8" Content-Language: en-US Content-Transfer-Encoding: 7bit X-Originating-IP: [10.0.5.60] X-ClientProxiedBy: XBOX01.axis.com (10.0.5.15) To XBOX02.axis.com (10.0.5.16) X-TM-AS-GCONF: 00 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 10/13/2017 06:09 PM, Niklas Cassel wrote: (snip) Hello Kishon I just wanted to say that the function artpec6_pcie_calc_cpu_fixup_mask should work on dra7xx as well. (I had dra7xx in mind when I wrote it.) However, I did not want to change pci-dra7xx.c to also use this function, since your current code is quite simple. But if you think that it's a good idea, we could rename and move artpec6_pcie_calc_cpu_fixup_mask to pcie-designware.c, and migrate pci-dra7xx to utilize this function as well, as it is strictly more correct to use values from device tree, rather than having a hard coded define in the SoC driver. Regards, Niklas