Attached is a revised "hotplug update" patch, against 2.4.0-test10. It's looking close to submit-able now. General change description is the same as the first patch, which can be found at http://boudicca.tux.org/hypermail/linux-kernel/this-week/0785.html Changes since the first patch: * CONFIG_HOTPLUG and CONFIG_KMOD are now totally independent. It was an incestuous relationship anyway. * exec_usermodehelper and call_usermodehelper are now unconditionally present * new file Documentation/networking/netdevices.txt describes /sbin/network usage, and netdevice locking * usb supports ACTION=$verb again, for compatibility with existing implementation * don't use magic numbers for 'insert' value in code, use TRUE/FALSE * ditch the sbus slot number * use '/' separate in PCI environment variables, for consistency with USB * eliminate EXPORT_SYMBOL(hotplug_path), modules don't need it * constify netdev_event_name[] array Now, time to track down that elusive thing called sleep... :) -- Jeff Garzik | Dinner is ready when Building 1024 | the smoke alarm goes off. MandrakeSoft | -/usr/games/fortune