- New __PA() macro for physical address. - Rename pg0 to more descriptive boot_pgtables. Remove unused pg1. Add boot_pgtables_end instead of relying on empty_zero_page. - Don't hardcode pte entries in swapper_pg_dir. Let the linker do its job. This is in preparation to move empty_zero_page, swapper_pg_dir, and boot_pgtables to other data sections. -- Brian Gerst