Hi Andrew, attached is the first piece from my slab patch: remove kmem_ from all static function that are only used in slab.c. Except kmem_cache_slabmgmt, I've renamed it to alloc_slabmgmt(). Patch against 2.5.40, afaics -mm1 doesn't contain any changes in slab.c Please apply. -- Manfred