Linus, John Levon suggested I send this to you. It's a cleanup of the NMI handling to make it into a request/release mechanism (instead of hard-coding everything into traps.c). It renames "nmi.c" to "nmi_watchdog.c" (as it should be named) and moves the real NMI handling code from traps.c to nmi.c. It's been posted and reworked on lkml, and it seems to have finally met approval. The "cc-ed" people have reviewed the patch (or at least made helpful suggestions :-). Since a lot of things are hacking into this code (lkcd, kdb, oprofile, nmi watchdog, and now my IPMI watchdog pretimeout), it would be very nice to get their junk out of this code and allow them to bind in nicely, and allow binding from modules. (And this time it's a -p1 diff) Thanks, -Corey