So I've made a couple attempts at adding a Memory Binding facility to the kernel. Obviously, I've had no success as yet, so I'm stubbornly trying another approach! ;) This patch is just a small pre-patch to the real memory binding. It just adds get_zonelist() and get_node_zonelist() calls, to make some code a little more readable. This patch is super straight-forward. The real fun is in the next patch... [mcd@arrakis membind]$ diffstat 00-pre_membind.patch gfp.h | 2 +- mmzone.h | 8 ++++++++ 2 files changed, 9 insertions(+), 1 deletion(-) -Matt