From: 刘稳 <18502523564@163.com>
To: "Joe Perches" <joe@perches.com>
Cc: sre@kernel.org, linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re:Re: [PATCH] power: supply: 88pm860x_battery array_soc first number is in mV
Date: Fri, 27 Oct 2017 10:48:00 +0800 (CST) [thread overview]
Message-ID: <3a3b3c7c.4645.15f5bbaa714.Coremail.18502523564@163.com> (raw)
In-Reply-To: <1508996478.10651.28.camel@perches.com>
At 2017-10-26 12:41:18, "Joe Perches" <joe@perches.com> wrote:
>On Thu, 2017-10-26 at 13:21 +0800, winton.liu wrote:
>> Fix wrong comments of array_soc description.
>> First number is mV not mAh.
>[]
>> diff --git a/drivers/power/supply/88pm860x_battery.c b/drivers/power/supply/88pm860x_battery.c
>[]
>> @@ -123,7 +123,7 @@ struct ccnt {
>>
>> /*
>> * State of Charge.
>> - * The first number is mAh(=3.6C), and the second number is percent point.
>> + * The first number is mV, and the second number is percent point.
>> */
>> static int array_soc[][2] = {
>> {4170, 100}, {4154, 99}, {4136, 98}, {4122, 97}, {4107, 96},
>
>OK, but why not change the declaration to a struct
>and make it obvious?
>
>Also, the array or struct should be const.
>
Yes, using a struct makes it more readable.
>Perhaps:
>---
> drivers/power/supply/88pm860x_battery.c | 13 ++++++++-----
> 1 file changed, 8 insertions(+), 5 deletions(-)
>
>diff --git a/drivers/power/supply/88pm860x_battery.c b/drivers/power/supply/88pm860x_battery.c
>index 63c57dc82ac1..973c5f7b07ba 100644
>--- a/drivers/power/supply/88pm860x_battery.c
>+++ b/drivers/power/supply/88pm860x_battery.c
>@@ -123,9 +123,12 @@ struct ccnt {
>
> /*
> * State of Charge.
>- * The first number is mAh(=3.6C), and the second number is percent point.
>+ * The first number is mV(=3.6C), and the second number is percent point3..
'(=3.6C)' is not needed. 1mAh = 1mA *3600s = 3.6C. As first number is mV, 3.6C is not needed.
> */
>-static int array_soc[][2] = {
>+static const struct {
>+ u16 mv;
>+ u8 percent;
>+} array_soc[] = {
> {4170, 100}, {4154, 99}, {4136, 98}, {4122, 97}, {4107, 96},
> {4102, 95}, {4088, 94}, {4081, 93}, {4070, 92}, {4060, 91},
> {4053, 90}, {4044, 89}, {4035, 88}, {4028, 87}, {4019, 86},
>@@ -388,14 +391,14 @@ static int calc_soc(struct pm860x_battery_info *info, int state, int *soc)
> return ret;
>
> count = ARRAY_SIZE(array_soc);
>- if (ocv < array_soc[count - 1][0]) {
>+ if (ocv < array_soc[count - 1].mv) {
> *soc = 0;
> return 0;
> }
>
> for (i = 0; i < count; i++) {
>- if (ocv >= array_soc[i][0]) {
>- *soc = array_soc[i][1];
>+ if (ocv >= array_soc[i].mv) {
>+ *soc = array_soc[i].percent;
> break;
> }
> }
>
prev parent reply other threads:[~2017-10-27 3:04 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-26 5:21 winton.liu
2017-10-26 5:41 ` Joe Perches
2017-10-27 2:48 ` 刘稳 [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3a3b3c7c.4645.15f5bbaa714.Coremail.18502523564@163.com \
--to=18502523564@163.com \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=sre@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®