From: Joe Perches <joe@perches.com>
To: Julia Lawall <julia.lawall@inria.fr>,
Shreeya Patel <shreeya.patel23498@gmail.com>
Cc: Larry.Finger@lwfinger.net, gregkh@linuxfoundation.org,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org,
outreachy-kernel@googlegroups.com, sbrivio@redhat.com,
daniel.baluta@gmail.com, nramas@linux.microsoft.com,
hverkuil@xs4all.nl
Subject: Re: [Outreachy kernel] [PATCH v2] Staging: rtl8188eu: rtw_mlme: Add space around operators
Date: Tue, 10 Mar 2020 09:57:20 -0700 [thread overview]
Message-ID: <3b19da8cb94aeb1e77452348dc528dd3b8a52a2a.camel@perches.com> (raw)
In-Reply-To: <alpine.DEB.2.21.2003101554530.26409@hadrien>
On Tue, 2020-03-10 at 15:57 +0100, Julia Lawall wrote:
> On Tue, 10 Mar 2020, Shreeya Patel wrote:
>
> > Add space around operators for improving the code
> > readability.
> >
> > Reported by checkpatch.pl
> >
> > Signed-off-by: Shreeya Patel <shreeya.patel23498@gmail.com>
> > ---
> >
> > rtw_mlme_old.o - Previously produced object file before making any
> > changes to the source code.
> > rtw_mlme.o - Object file produced after compiling the changes done in source
> > file.
> >
> > Following is the output of diff between the previously produced object
> > file and the object file produced after compiling the changes.
> >
> > shreeya@Shreeya-Patel:~git/kernels/staging/drivers/staging/rtl8188eu/core$ diff rtw_mlme_old.o rtw_mlme.o
> > shreeya@Shreeya-Patel:~git/kernels/staging/drivers/staging/rtl8188eu/core$
> >
> > Following output shows that there was no other change in the source
> > code except for whitespace.
> >
> > shreeya@Shreeya-Patel:~git/kernels/staging$ git diff -w drivers/staging/rtl8188eu/core/
> > shreeya@Shreeya-Patel:~git/kernels/staging$
>
> If this information is importamt, it should be above the line. On the
> other hand, it is much too detailed, making it hard to figure out what is
> being said. It would be better to just say diff of the .o files before
> and after the changes shows no difference. Likewise git diff -w shows no
> difference. That way one can quickly see what tests you did, without
> being distracted by the machine name, the directory name, etc.
Exactly right.
Keep at it Shreeya. Almost done.
[It's also nice to trim your replies Julia]
prev parent reply other threads:[~2020-03-10 16:59 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-03-10 14:47 Shreeya Patel
2020-03-10 14:57 ` Julia Lawall
2020-03-10 16:57 ` Joe Perches [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3b19da8cb94aeb1e77452348dc528dd3b8a52a2a.camel@perches.com \
--to=joe@perches.com \
--cc=Larry.Finger@lwfinger.net \
--cc=daniel.baluta@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=hverkuil@xs4all.nl \
--cc=julia.lawall@inria.fr \
--cc=linux-kernel@vger.kernel.org \
--cc=nramas@linux.microsoft.com \
--cc=outreachy-kernel@googlegroups.com \
--cc=sbrivio@redhat.com \
--cc=shreeya.patel23498@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®