From: Chanwoo Choi <cwchoi00@gmail.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Chanwoo Choi <cw00.choi@samsung.com>,
Chanwoo Choi <chanwoo@kernel.org>
Subject: Re: [GIT PULL] extcon next for 6.4
Date: Tue, 25 Apr 2023 21:58:47 +0900 [thread overview]
Message-ID: <3b49bdb2-642e-214b-7334-911721f62ce6@gmail.com> (raw)
In-Reply-To: <1d2b9fd2-4a59-cb3b-2fd3-9f6635f3bbf8@gmail.com>
Dear Greg,
Gently ping for v6.4.
Best Regards,
Chanwoo Choi
On 23. 4. 17. 00:28, Chanwoo Choi wrote:
> Dear Greg,
>
> This is extcon-next pull request for v6.4. I add detailed description of
> this pull request on below. Please pull extcon with following updates.
>
> Best Regards,
> Chanwoo Choi
>
>
> The following changes since commit 09a9639e56c01c7a00d6c0ca63f4c7c41abe075d:
>
> Linux 6.3-rc6 (2023-04-09 11:15:57 -0700)
>
> are available in the Git repository at:
>
> git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git tags/extcon-next-for-6.4
>
> for you to fetch changes up to 4e30418def07f8359c7927d5815788043afbb482:
>
> extcon: Drop unneeded assignments (2023-04-17 00:14:12 +0900)
>
> ----------------------------------------------------------------
> Update extcon next for v6.4
>
> Detailed description for this pull request:
> 1. Clean-up extcon core without any behavior changes
> - Add extcon_alloc_cables/muex/groups to improve the readability
> of extcon_dev_register.
>
> - Fix kernel doc of property and property capability fields to aovid warnings
> and add missing description of struct extcon_dev.
>
> - Use DECLARE_BITMAP macro and sysfs_emit instead of sprintf
>
> - Use device_match_of_node helper instead of accessing the .of_node
>
> - Use ida_alloc/free to get the unique id for extcon device
>
> 2. Update extcon-usbc-tusb320.c to support usb_role_switch and accessory detection
> - Add usb_role_switch support on extcon-usbsc-tusb320.
>
> - Add additional accessory detection for audio/debug accessory
> and then pass the deteced accessory information to typec subsystem
> on extcon-usbsc-tusb320.c.
>
> - Add the support of unregistration of typec port on both error handling
> and driver removal step on
>
> 3. Update extcon provider drivers (apx288/qcom-spmi-misc/palmas)
> - Replace put_device with acpi_dev_put on extcon-axp288.c
>
> - Use platform_get_irq_byname_optional for getting irq of
> usb_id and usb_vbus on extcon-qcom-spmi-misc.c.
>
> - Remove unused of_gpio.h on extcon-palmas.c.
>
> 4. Fix the devicetree binding document
> - Rename misc node name to 'usb-dect@900' on pm8941-misc.yam
>
> - Fix usb-id and usb_vbus defintion on pm8941-misc.yaml
> ----------------------------------------------------------------
>
> Alvin Šipraga (3):
> extcon: usbc-tusb320: Unregister typec port on driver removal
> extcon: usbc-tusb320: add accessory detection support
> extcon: usbc-tusb320: add usb_role_switch support
>
> Andy Shevchenko (13):
> extcon: axp288: Replace open coded acpi_dev_put()
> extcon: palmas: Remove unused of_gpio.h
> extcon: Fix kernel doc of property fields to avoid warnings
> extcon: Fix kernel doc of property capability fields to avoid warnings
> extcon: Use DECLARE_BITMAP() to declare bit arrays
> extcon: Use sysfs_emit() to instead of sprintf()
> extcon: Amend kernel documentation of struct extcon_dev
> extcon: Use device_match_of_node() helper
> extcon: Use dev_of_node(dev) instead of dev->of_node
> extcon: Remove dup device name in the message and unneeded error check
> extcon: Use unique number for the extcon device ID
> extcon: Use sizeof(*pointer) instead of sizeof(type)
> extcon: Drop unneeded assignments
>
> Arnd Bergmann (1):
> extcon: usbc-tusb320: add USB_ROLE_SWITCH dependency
>
> Bryan O'Donoghue (2):
> dt-bindings: pm8941-misc: Fix usb_id and usb_vbus definitions
> extcon: qcom-spmi: Switch to platform_get_irq_byname_optional
>
> Bumwoo Lee (4):
> extcon: Remove redundant null checking for class
> extcon: Add extcon_alloc_cables to simplify extcon register function
> extcon: Add extcon_alloc_muex to simplify extcon register function
> extcon: Add extcon_alloc_groups to simplify extcon register function
>
> Luca Weiss (1):
> dt-bindings: pm8941-misc: rename misc node name
>
> .../bindings/extcon/qcom,pm8941-misc.yaml | 14 +-
> drivers/extcon/Kconfig | 1 +
> drivers/extcon/extcon-axp288.c | 2 +-
> drivers/extcon/extcon-palmas.c | 1 -
> drivers/extcon/extcon-qcom-spmi-misc.c | 4 +-
> drivers/extcon/extcon-usbc-tusb320.c | 153 +++++++--
> drivers/extcon/extcon.c | 368 ++++++++++++---------
> drivers/extcon/extcon.h | 8 +-
> 8 files changed, 354 insertions(+), 197 deletions(-)
--
Best Regards,
Samsung Electronics
Chanwoo Choi
next prev parent reply other threads:[~2023-04-25 12:58 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-04-16 15:28 Chanwoo Choi
2023-04-25 12:58 ` Chanwoo Choi [this message]
2023-04-25 13:22 ` Greg Kroah-Hartman
2023-04-25 18:49 ` Chanwoo Choi
2023-04-27 14:22 ` Greg Kroah-Hartman
2023-04-28 6:12 ` Greg Kroah-Hartman
2023-04-30 0:29 ` Chanwoo Choi
2023-04-30 8:00 ` Greg Kroah-Hartman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3b49bdb2-642e-214b-7334-911721f62ce6@gmail.com \
--to=cwchoi00@gmail.com \
--cc=chanwoo@kernel.org \
--cc=cw00.choi@samsung.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®