From: Pavel Skripkin <paskripkin@gmail.com>
To: Stefan Schmidt <stefan@datenfreihafen.org>,
alex.aring@gmail.com, davem@davemloft.net, kuba@kernel.org,
linux-wpan@vger.kernel.org, netdev@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH -next] ieee802154: atusb: move to new USB API
Date: Sat, 8 Jan 2022 16:11:30 +0300 [thread overview]
Message-ID: <3b9356e7-2eb9-8a86-cfb8-8667c1996b54@gmail.com> (raw)
In-Reply-To: <2439d9ab-133f-0338-24f9-a9a5cd2065a3@datenfreihafen.org>
Hi Stefan,
On 1/7/22 16:46, Stefan Schmidt wrote:
>
> Hello.
>
> On 05.01.22 15:49, Pavel Skripkin wrote:
>> @@ -176,9 +105,13 @@ static int atusb_read_subreg(struct atusb *lp,
>> unsigned int addr, unsigned int mask,
>> unsigned int shift)
>> {
>> - int rc;
>> + int rc, ret;
>> +
>> + ret = usb_control_msg_recv(lp->usb_dev, 0, ATUSB_REG_READ, ATUSB_REQ_FROM_DEV,
>
> You are changing the meaning of the rc variable away from a return code.
> Its the register value now. I would prefer if we change the name to
> something like reg to reflect this new meaning.
>
Ack. Will fix in v2.
>> + 0, addr, &rc, 1, 1000, GFP_KERNEL);
>> + if (ret < 0)
>> + return ret;
>>
>> - rc = atusb_read_reg(lp, addr);
>> rc = (rc & mask) >> shift;
>>
>> return rc;
>
> The change above and the bug fix I reported the other day is all that is
> missing for this to be applied. You want to send a v2 with this changes
> or do you prefer me doing them here locally and apply?
>
I am going to send v2 soon. Thank you for review!
With regards,
Pavel Skripkin
next prev parent reply other threads:[~2022-01-08 13:11 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-01-05 14:49 Pavel Skripkin
2022-01-05 20:27 ` Stefan Schmidt
2022-01-05 20:58 ` Pavel Skripkin
2022-01-07 13:43 ` Stefan Schmidt
2022-01-07 13:46 ` Stefan Schmidt
2022-01-08 13:11 ` Pavel Skripkin [this message]
2022-01-08 13:18 ` [PATCH -next v2] " Pavel Skripkin
2022-01-10 8:57 ` Stefan Schmidt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3b9356e7-2eb9-8a86-cfb8-8667c1996b54@gmail.com \
--to=paskripkin@gmail.com \
--cc=alex.aring@gmail.com \
--cc=davem@davemloft.net \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-wpan@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=stefan@datenfreihafen.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome