From: "Gustavo A. R. Silva" <gustavo@embeddedor.com>
To: Sergey Matyukevich <sergey.matyukevich.os@quantenna.com>
Cc: Igor Mitsyanko <imitsyanko@quantenna.com>,
Avinash Patil <avinashp@quantenna.com>,
Sergey Matyukevich <smatyukevich@quantenna.com>,
Kalle Valo <kvalo@codeaurora.org>,
"David S. Miller" <davem@davemloft.net>,
"linux-wireless@vger.kernel.org" <linux-wireless@vger.kernel.org>,
"netdev@vger.kernel.org" <netdev@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH][next] qtnfmac: replace qtnf_cmd_acl_data_size() with struct_size()
Date: Thu, 4 Apr 2019 11:33:56 -0500 [thread overview]
Message-ID: <3baa19c1-a213-3dcf-2f03-23b058ec419a@embeddedor.com> (raw)
In-Reply-To: <e56579c6-da6e-4cb2-90b1-89e7774debf9@embeddedor.com>
On 4/4/19 11:01 AM, Gustavo A. R. Silva wrote:
>
>
> On 4/4/19 8:32 AM, Sergey Matyukevich wrote:
>>> One of the more common cases of allocation size calculations is finding
>>> the size of a structure that has a zero-sized array at the end, along
>>> with memory for some number of elements for that array. For example:
>>>
>>> struct foo {
>>> int stuff;
>>> struct boo entry[];
>>> };
>>>
>>> size = sizeof(struct foo) + count * sizeof(struct boo);
>>> instance = kzalloc(size, GFP_KERNEL)
>>>
>>> Instead of leaving these open-coded and prone to type mistakes, we can
>>> now use the new struct_size() helper:
>>>
>>> size = struct_size(instance, entry, count);
>>>
>>> or
>>>
>>> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL)
>>>
>>> Based on the above, replace qtnf_cmd_acl_data_size() with the
>>> new struct_size() helper.
>>>
>>> This code was detected with the help of Coccinelle.
>>>
>>> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
>>> ---
>>> drivers/net/wireless/quantenna/qtnfmac/commands.c | 15 ++++-----------
>>> 1 file changed, 4 insertions(+), 11 deletions(-)
>>
>> Hi Gustavo,
>>
>
> Hey Sergey,
>
>> Thanks for the patch! By the way, it does not apply cleanly, so it needs
>> to be rebased on top of the up-to-date wireless-drivers-next tree. Let
>> me know if you would prefer me to care about rebase. Then I will
>> add this patch to the upcoming series of qtnfmac fixes.
>>
>
> Don't worry. I'll do it and send this again.
>
Hmm... I just applied it cleanly on top of wireless-drivers-next/master:
973a99be7943 (HEAD) qtnfmac: replace qtnf_cmd_acl_data_size() with struct_size()
38bb0baea310 (wireless-drivers-next/master) rtlwifi: move spin_lock_bh to spin_lock in tasklet
60209d482b97 rtlwifi: fix potential NULL pointer dereference
765976285a8c rtlwifi: fix a potential NULL pointer dereference
Do you see any issues with this?
Thanks
--
Gustavo
next prev parent reply other threads:[~2019-04-04 16:36 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-04-03 17:02 Gustavo A. R. Silva
2019-04-04 13:32 ` Sergey Matyukevich
2019-04-04 16:01 ` Gustavo A. R. Silva
2019-04-04 16:33 ` Gustavo A. R. Silva [this message]
2019-04-04 16:40 ` Kalle Valo
2019-04-04 16:45 ` Gustavo A. R. Silva
2019-04-04 16:38 ` Kalle Valo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3baa19c1-a213-3dcf-2f03-23b058ec419a@embeddedor.com \
--to=gustavo@embeddedor.com \
--cc=avinashp@quantenna.com \
--cc=davem@davemloft.net \
--cc=imitsyanko@quantenna.com \
--cc=kvalo@codeaurora.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-wireless@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=sergey.matyukevich.os@quantenna.com \
--cc=smatyukevich@quantenna.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®