mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jani Nikula <jani.nikula@linux.intel.com>
To: Liao Yuanhong <liaoyuanhong@vivo.com>,
	Joonas Lahtinen <joonas.lahtinen@linux.intel.com>,
	Rodrigo Vivi <rodrigo.vivi@intel.com>,
	Tvrtko Ursulin <tursulin@ursulin.net>,
	David Airlie <airlied@gmail.com>, Simona Vetter <simona@ffwll.ch>,
	Liao Yuanhong <liaoyuanhong@vivo.com>,
	Nitin Gote <nitin.r.gote@intel.com>,
	Krzysztof Niemiec <krzysztof.niemiec@intel.com>,
	"open list:DRM DRIVERS" <dri-devel@lists.freedesktop.org>,
	open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/4] drm/i915/gem: Remove goto label that are only used once
Date: Tue, 05 Aug 2025 10:52:09 +0300	[thread overview]
Message-ID: <3c436b32da8d76df7eace4dbbde79e808058ad8b@intel.com> (raw)
In-Reply-To: <20250805074645.625911-2-liaoyuanhong@vivo.com>

On Tue, 05 Aug 2025, Liao Yuanhong <liaoyuanhong@vivo.com> wrote:
> Remove unnecessary goto labels to improve code readability. 

Please don't. It's fine as it is.

> Signed-off-by: Liao Yuanhong <liaoyuanhong@vivo.com>
> ---
>  drivers/gpu/drm/i915/gem/i915_gem_region.c | 10 ++++------
>  1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/gem/i915_gem_region.c b/drivers/gpu/drm/i915/gem/i915_gem_region.c
> index 636768d0f57e..539d1716d454 100644
> --- a/drivers/gpu/drm/i915/gem/i915_gem_region.c
> +++ b/drivers/gpu/drm/i915/gem/i915_gem_region.c
> @@ -92,15 +92,13 @@ __i915_gem_object_create_region(struct intel_memory_region *mem,
>  		flags |= I915_BO_ALLOC_PM_EARLY;
>  
>  	err = mem->ops->init_object(mem, obj, offset, size, page_size, flags);
> -	if (err)
> -		goto err_object_free;
> +	if (err) {
> +		i915_gem_object_free(obj);
> +		return ERR_PTR(err);
> +	}
>  
>  	trace_i915_gem_object_create(obj);
>  	return obj;
> -
> -err_object_free:
> -	i915_gem_object_free(obj);
> -	return ERR_PTR(err);
>  }
>  
>  struct drm_i915_gem_object *

-- 
Jani Nikula, Intel

  reply	other threads:[~2025-08-05  7:52 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-08-05  7:46 [PATCH 0/4] drm: " Liao Yuanhong
2025-08-05  7:46 ` [PATCH 1/4] drm/i915/gem: " Liao Yuanhong
2025-08-05  7:52   ` Jani Nikula [this message]
2025-08-05  7:46 ` [PATCH 2/4] drm/imagination: " Liao Yuanhong
2025-08-05  7:46 ` [PATCH 3/4] drm/imx: " Liao Yuanhong
2025-08-06  7:32   ` Laurentiu Palcu
2025-08-05  7:46 ` [PATCH 4/4] drm/panel: " Liao Yuanhong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3c436b32da8d76df7eace4dbbde79e808058ad8b@intel.com \
    --to=jani.nikula@linux.intel.com \
    --cc=airlied@gmail.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=joonas.lahtinen@linux.intel.com \
    --cc=krzysztof.niemiec@intel.com \
    --cc=liaoyuanhong@vivo.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nitin.r.gote@intel.com \
    --cc=rodrigo.vivi@intel.com \
    --cc=simona@ffwll.ch \
    --cc=tursulin@ursulin.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®