From: Olivier Langlois <olivier@trillion01.com>
To: Pavel Begunkov <asml.silence@gmail.com>,
Randy Dunlap <rdunlap@infradead.org>,
Jens Axboe <axboe@kernel.dk>,
io-uring@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2] io_uring: reduce latency by reissueing the operation
Date: Sun, 20 Jun 2021 16:54:38 -0400 [thread overview]
Message-ID: <3c6e168b40ebf4e8fd2aa9c9cf1785cdd8b5e6c1.camel@trillion01.com> (raw)
In-Reply-To: <7ad30cb0-3322-6c40-2a1b-27308aa757d8@gmail.com>
On Sun, 2021-06-20 at 21:08 +0100, Pavel Begunkov wrote:
> On 6/20/21 9:01 PM, Randy Dunlap wrote:
> > On 6/20/21 12:28 PM, Olivier Langlois wrote:
> > > On Sun, 2021-06-20 at 12:07 -0700, Randy Dunlap wrote:
> > > > On 6/20/21 12:05 PM, Olivier Langlois wrote:
> > > > > - return false;
> > > > > + return ret?IO_ARM_POLL_READY:IO_ARM_POLL_ERR;
> > > >
> > > > Hi,
> > > > Please make that return expression more readable.
> > > >
> > > >
> > > How exactly?
> > >
> > > by adding spaces?
> > > Changing the define names??
> >
> > Adding spaces would be sufficient IMO (like Pavel suggested also).
>
> Agree. That should be in the code style somewhere
>
Sure no problem.
This hasn't been reported by checkpatch.pl but I have just discovered
codespell... Maybe this addon reports more issues than vanilla
checkpatch
next prev parent reply other threads:[~2021-06-20 20:54 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-06-20 19:05 Olivier Langlois
2021-06-20 19:07 ` Randy Dunlap
2021-06-20 19:28 ` Olivier Langlois
2021-06-20 20:01 ` Randy Dunlap
2021-06-20 20:08 ` Pavel Begunkov
2021-06-20 20:54 ` Olivier Langlois [this message]
2021-06-20 22:17 ` Randy Dunlap
2021-06-21 16:03 ` Jens Axboe
2021-06-20 19:56 ` Pavel Begunkov
2021-06-20 20:03 ` Pavel Begunkov
2021-06-20 20:56 ` Olivier Langlois
2021-06-20 21:05 ` Olivier Langlois
2021-06-20 21:09 ` Pavel Begunkov
2021-06-20 21:11 ` Pavel Begunkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3c6e168b40ebf4e8fd2aa9c9cf1785cdd8b5e6c1.camel@trillion01.com \
--to=olivier@trillion01.com \
--cc=asml.silence@gmail.com \
--cc=axboe@kernel.dk \
--cc=io-uring@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rdunlap@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®