mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Samuel Iglesias Gonsálvez" <siglesias@igalia.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: <devel@driverdev.osuosl.org>, <linux-kernel@vger.kernel.org>,
	Manohar Vanga <manohar.vanga@cern.ch>,
	Dan Carpenter <dan.carpenter@oracle.com>
Subject: Re: [PATCH v4 1/3] Staging: IndustryPack bus for the Linux Kernel
Date: Thu, 10 May 2012 17:34:54 +0100	[thread overview]
Message-ID: <3c71a30f539ee297f781beede0a411f3@igalia.com> (raw)
In-Reply-To: <20120510153728.GA18574@kroah.com>

On 2012-05-10 16:37, Greg Kroah-Hartman wrote:
(snip)
>
>> > > +static void ipack_device_release(struct device *dev)
>> > > +{
>> > > +}
>> >
>> > Weee.  As per the in-kernel documentation, I get to publically 
>> mock
>> you
>> > for doing something as foolish as thinking you are smarter than 
>> the
>> > kernel by just creating an empty function for the release 
>> callback.
>> >
>> > Did you think this really is the solution for when the kernel is
>> > complaining to you about the fact that you need a callback 
>> function
>> > here?  Surely I didn't just put that logic in the core for no good
>> > reason now, right?
>> >
>> > Please fix this up NOW.
>>
>> OK, I will fix it. However reading my code, I don't see the need to
>> kfree anything here, like in other drivers, for example.
>
> Then your code is designed wrong.  You must free the memory here.  
> The
> problem is that your "core" is not doing the allocation, but are 
> relying
> on the driver to do it instead.  Don't do that, the driver should not
> have to do any of this at all.  Look at other busses for examples.
>

OK.

>> Is it OK to have a pr_info notifying the release of the device or 
>> should
>> I think again about it?
>
> You should never have a pr_info() call anywhere, what would a user do
> with such a message?  That seems pretty pointless, right?
>
> Also, please always use dev_*() calls instead of pr_*() calls, as you
> should always have access to a struct device in your code.
>

OK

>> > > +++ b/drivers/staging/ipack/ipack.h
>> > > @@ -0,0 +1,183 @@
>> > > +/*
>> > > + * Industry-pack bus.
>> > > + *
>> > > + * (C) 2011 Samuel Iglesias Gonsalvez <siglesia@cern.ch>, CERN
>> > > + * (C) 2012 Samuel Iglesias Gonsalvez <siglesias@igalia.com>,
>> Igalia
>> > > + *
>> > > + * This program is free software; you can redistribute it 
>> and/or
>> modify it
>> > > + * under the terms of the GNU General Public License as 
>> published
>> by the Free
>> > > + * Software Foundation; either version 2 of the License, or (at
>> your option)
>> > > + * any later version.
>> >
>> > Again, "any later version", are you sure?  Be very sure about this
>> > please.
>> >
>> > > +struct ipack_device {
>> > > +   char board_name[IPACK_BOARD_NAME_SIZE];
>> >
>> > Why not use dev->name?
>>
>> May I be wrong, do you refer rename it to "name"?
>
> rename what?  Why do you need a board name for a device?  Shouldn't 
> that
> just be the "name" for the device?  And as such, just use the field 
> you
> already have.
>

In struct device there is the field "init_name". There is a "name" 
field in the corresponding struct kobject inside of dev. This is the 
reason of my misunderstanding.

I will change it.

>> > > +   char bus_name[IPACK_BOARD_NAME_SIZE];
>
> And, why do you need a bus name?  Shouldn't that be implied based on
> what bus the device is attached to?
>

This is the name of the bus device. The problem here is that the 
ipoctal mezzanine needs to save the IRQ vector in his memory space in a 
different address depending of the carrier board it is plugged to.

It is described in IP-OCTAL's datasheet. So this bus_name variable 
gives the way to do it.

Best regards,

Sam

  reply	other threads:[~2012-05-10 16:35 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-05-09 13:27 Samuel Iglesias Gonsalvez
2012-05-09 13:27 ` [PATCH v4 2/3] Staging: ipack: added support for the TEWS TPCI-200 carrier board Samuel Iglesias Gonsalvez
2012-05-09 21:15   ` Greg Kroah-Hartman
2012-05-09 13:27 ` [PATCH v4 3/3] Staging: ipack: add support for IP-OCTAL mezzanine board Samuel Iglesias Gonsalvez
2012-05-09 21:13 ` [PATCH v4 1/3] Staging: IndustryPack bus for the Linux Kernel Greg Kroah-Hartman
2012-05-10 14:23   ` Samuel Iglesias Gonsálvez
2012-05-10 15:37     ` Greg Kroah-Hartman
2012-05-10 16:34       ` Samuel Iglesias Gonsálvez [this message]
2012-05-10 16:42         ` Greg Kroah-Hartman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3c71a30f539ee297f781beede0a411f3@igalia.com \
    --to=siglesias@igalia.com \
    --cc=dan.carpenter@oracle.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=manohar.vanga@cern.ch \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®