mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Philipp Stanner <pstanner@redhat.com>
To: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>
Cc: dri-devel@lists.freedesktop.org,
	Fabio Estevam <festevam@gmail.com>,
	 "Rafael J. Wysocki" <rafael@kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Sascha Hauer <s.hauer@pengutronix.de>,
	linux-kernel@vger.kernel.org, Maxime Ripard <mripard@kernel.org>,
	 Mark Brown <broonie@kernel.org>,
	NXP Linux Team <linux-imx@nxp.com>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	Laurentiu Palcu <laurentiu.palcu@oss.nxp.com>,
	David Gow <davidgow@google.com>, Shawn Guo <shawnguo@kernel.org>,
	Pengutronix Kernel Team <kernel@pengutronix.de>,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 1/2] platform_device: add devres function region-reqs
Date: Mon, 08 Jan 2024 09:25:22 +0100	[thread overview]
Message-ID: <3d0e251f0d58f1f8266074973644160d831fa462.camel@redhat.com> (raw)
In-Reply-To: <5k75ed3czl6rqzkykl7xc4dbyih2frunoor4ypfqxx7yzfs2vd@6ieg4dewtgxf>

Hi

On Fri, 2024-01-05 at 20:11 +0100, Uwe Kleine-König wrote:
> On Fri, Jan 05, 2024 at 06:22:18PM +0100, Philipp Stanner wrote:
> > Some drivers want to use (request) a region exclusively but
> > nevertheless
> > create several mappings within that region.
> > 
> > Currently, there is no managed devres function to request a region
> > without mapping it.
> > 
> > Add the function devm_platform_get_resource()
> > 
> > Signed-off-by: Philipp Stanner <pstanner@redhat.com>
> > ---
> >  drivers/base/platform.c         | 37
> > +++++++++++++++++++++++++++++++++
> >  include/linux/platform_device.h |  2 ++
> >  2 files changed, 39 insertions(+)
> > 
> > diff --git a/drivers/base/platform.c b/drivers/base/platform.c
> > index 10c577963418..243b9ec54d04 100644
> > --- a/drivers/base/platform.c
> > +++ b/drivers/base/platform.c
> > @@ -82,6 +82,43 @@ struct resource *platform_get_mem_or_io(struct
> > platform_device *dev,
> >  }
> >  EXPORT_SYMBOL_GPL(platform_get_mem_or_io);
> >  
> > +/**
> > + * devm_platform_get_and_resource - get and request a resource
> 
> This function name is wrong.
> 
> > + *
> > + * @pdev: the platform device to get the resource from
> > + * @type: resource type (either IORESOURCE_MEM or IORESOURCE_IO)
> > + * @num: resource index
> > + * @name: name to be associated with the request
> > + *
> > + * Return: a pointer to the resource on success, an ERR_PTR on
> > failure.
> > + *
> > + * Gets a resource and requests it. Use this instead of
> > + * devm_platform_ioremap_resource() only if you have to create
> > several single
> > + * mappings with devm_ioremap().
> > + */
> > +struct resource *devm_platform_get_resource(struct platform_device
> > *pdev,
> > +               unsigned int type, unsigned int num, const char
> > *name)
> > +{
> > +       struct resource *res;
> > +
> > +       res = platform_get_resource(pdev, type, num);
> > +       if (!res)
> > +               return ERR_PTR(-EINVAL);
> 
> From devm_platform_get_resource I'd expect that it only does
> platform_get_resource() + register a cleanup function to undo it.
> 
> > +       if (type & IORESOURCE_MEM)
> > +               res = devm_request_mem_region(&pdev->dev, res-
> > >start, res->end, name);
> > +       else if (type & IORESOURCE_IO)
> > +               res = devm_request_region(&pdev->dev, res->start,
> > res->end, name);
> > +       else
> > +               return ERR_PTR(-EINVAL);
> 
> So this part is surprising. IMHO your function's name should include
> "request".

Yes, that sounds very correct to me. I'll address that in v2


Thx for the feedback,

P.

> 
> > +       if (!res)
> > +               return ERR_PTR(-EBUSY);
> > +
> > +       return res;
> > +}
> > +EXPORT_SYMBOL_GPL(devm_platform_get_resource);
> > +
> >  #ifdef CONFIG_HAS_IOMEM
> >  /**
> >   * devm_platform_get_and_ioremap_resource - call
> > devm_ioremap_resource() for a
> 
> Best regards
> Uwe
> 


  reply	other threads:[~2024-01-08  8:25 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-01-05 17:22 [PATCH 0/2] platform_device: add new devres function Philipp Stanner
2024-01-05 17:22 ` [PATCH 1/2] platform_device: add devres function region-reqs Philipp Stanner
2024-01-05 19:11   ` Uwe Kleine-König
2024-01-08  8:25     ` Philipp Stanner [this message]
2024-01-08  7:46   ` kernel test robot
2024-01-05 17:22 ` [PATCH 2/2] drm/dcss: request memory region Philipp Stanner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3d0e251f0d58f1f8266074973644160d831fa462.camel@redhat.com \
    --to=pstanner@redhat.com \
    --cc=broonie@kernel.org \
    --cc=davidgow@google.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=festevam@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=kernel@pengutronix.de \
    --cc=laurentiu.palcu@oss.nxp.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-imx@nxp.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mripard@kernel.org \
    --cc=rafael@kernel.org \
    --cc=s.hauer@pengutronix.de \
    --cc=shawnguo@kernel.org \
    --cc=tzimmermann@suse.de \
    --cc=u.kleine-koenig@pengutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®