From: Tomi Valkeinen <tomi.valkeinen@ti.com>
To: Lee Jones <lee.jones@linaro.org>
Cc: linux-kernel@vger.kernel.org, "David Airlie" <airlied@linux.ie>,
"Daniel Vetter" <daniel@ffwll.ch>,
"Sumit Semwal" <sumit.semwal@linaro.org>,
"Christian König" <christian.koenig@amd.com>,
"Rob Clark" <rob.clark@linaro.org>,
dri-devel@lists.freedesktop.org, linux-media@vger.kernel.org,
linaro-mm-sig@lists.linaro.org
Subject: Re: [PATCH 08/19] drm/omapdrm/omap_gem: Fix misnamed and missing parameter descriptions
Date: Tue, 10 Nov 2020 14:01:44 +0200 [thread overview]
Message-ID: <3d5dc164-d26a-5999-1e7f-9cabfdd84c36@ti.com> (raw)
In-Reply-To: <20201106214949.2042120-9-lee.jones@linaro.org>
On 06/11/2020 23:49, Lee Jones wrote:
> Fixes the following W=1 kernel build warning(s):
>
> drivers/gpu/drm/omapdrm/omap_gem.c:593: warning: Function parameter or member 'file' not described in 'omap_gem_dumb_create'
> drivers/gpu/drm/omapdrm/omap_gem.c:593: warning: Excess function parameter 'drm_file' description in 'omap_gem_dumb_create'
> drivers/gpu/drm/omapdrm/omap_gem.c:619: warning: Function parameter or member 'offset' not described in 'omap_gem_dumb_map_offset'
>
> Cc: Tomi Valkeinen <tomi.valkeinen@ti.com>
> Cc: David Airlie <airlied@linux.ie>
> Cc: Daniel Vetter <daniel@ffwll.ch>
> Cc: Sumit Semwal <sumit.semwal@linaro.org>
> Cc: "Christian König" <christian.koenig@amd.com>
> Cc: Rob Clark <rob.clark@linaro.org>
> Cc: dri-devel@lists.freedesktop.org
> Cc: linux-media@vger.kernel.org
> Cc: linaro-mm-sig@lists.linaro.org
> Signed-off-by: Lee Jones <lee.jones@linaro.org>
> ---
> drivers/gpu/drm/omapdrm/omap_gem.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
Thanks! I'll pick this one and the next to drm-misc-next.
Tomi
--
Texas Instruments Finland Oy, Porkkalankatu 22, 00180 Helsinki.
Y-tunnus/Business ID: 0615521-4. Kotipaikka/Domicile: Helsinki
next prev parent reply other threads:[~2020-11-10 12:01 UTC|newest]
Thread overview: 57+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-11-06 21:49 [PATCH 00/19] [Set 2] Rid W=1 warnings from GPU Lee Jones
2020-11-06 21:49 ` [PATCH 01/19] drm/ttm/ttm_range_manager: Demote non-conformant kernel-doc header Lee Jones
2020-11-07 12:12 ` Christian König
2020-11-06 21:49 ` [PATCH 02/19] drm/r128/ati_pcigart: Source file headers are not good candidates for kernel-doc Lee Jones
2020-11-06 22:22 ` Sam Ravnborg
2020-11-06 21:49 ` [PATCH 03/19] drm/selftests/test-drm_dp_mst_helper: Move 'sideband_msg_req_encode_decode' onto the heap Lee Jones
2020-11-06 21:49 ` [PATCH 04/19] drm/mga/mga_dma: Demote kernel-doc abusers to standard comment blocks Lee Jones
2020-11-06 22:23 ` Sam Ravnborg
2020-11-06 21:49 ` [PATCH 05/19] drm/mga/mga_state: Remove unused variable 'buf_priv' Lee Jones
2020-11-06 22:23 ` Sam Ravnborg
2020-11-06 21:49 ` [PATCH 06/19] drm/radeon/atom: Move prototype into shared location Lee Jones
2020-11-10 21:54 ` Alex Deucher
2020-11-06 21:49 ` [PATCH 07/19] drm/radeon/radeon_kms: Include header containing our own prototypes Lee Jones
2020-11-10 21:55 ` Alex Deucher
2020-11-06 21:49 ` [PATCH 08/19] drm/omapdrm/omap_gem: Fix misnamed and missing parameter descriptions Lee Jones
2020-11-10 12:01 ` Tomi Valkeinen [this message]
2020-11-06 21:49 ` [PATCH 09/19] drm/omapdrm/omap_dmm_tiler: Demote abusive use of kernel-doc format Lee Jones
2020-11-06 21:49 ` [PATCH 10/19] drm/radeon/radeon: Move prototype into shared header Lee Jones
2020-11-07 14:26 ` Sam Ravnborg
2020-11-07 15:14 ` Lee Jones
2020-11-09 11:06 ` Lee Jones
2020-11-09 15:25 ` Sam Ravnborg
2020-11-09 16:10 ` Lee Jones
2020-11-06 21:49 ` [PATCH 11/19] drm/radeon/radeon_drv: Source file headers are not good candidates for kernel-doc Lee Jones
2020-11-10 21:56 ` Alex Deucher
2020-11-06 21:49 ` [PATCH 12/19] drm/amd/display/dc/basics/fixpt31_32: Move variables to where they're used Lee Jones
2020-11-09 19:58 ` Alex Deucher
2020-11-06 21:49 ` [PATCH 13/19] drm/radeon/radeon_drv: Move prototypes to a shared headerfile Lee Jones
2020-11-10 21:58 ` Alex Deucher
2020-11-06 21:49 ` [PATCH 14/19] drm/amd/amdgpu/amdgpu_device: Provide documentation for 'reg_addr' params Lee Jones
2020-11-09 19:54 ` Alex Deucher
2020-11-06 21:49 ` [PATCH 15/19] drm/radeon: Move prototypes to shared header Lee Jones
2020-11-10 21:59 ` Alex Deucher
2020-11-06 21:49 ` [PATCH 16/19] drm/amd/amdgpu/amdgpu_kms: Remove 'struct drm_amdgpu_info_device dev_info' from the stack Lee Jones
2020-11-09 20:05 ` Alex Deucher
2020-11-06 21:49 ` [PATCH 17/19] drm/radeon/radeon_kms: Fix misnaming of 'radeon_info_ioctl's dev param Lee Jones
2020-11-07 14:29 ` Sam Ravnborg
2020-11-07 15:13 ` Lee Jones
2020-11-09 19:50 ` Alex Deucher
2020-11-09 19:55 ` Sam Ravnborg
2020-11-09 20:06 ` Alex Deucher
2020-11-09 20:10 ` Lee Jones
2020-11-09 20:52 ` Sam Ravnborg
2020-11-09 21:15 ` Lee Jones
2020-11-09 19:59 ` Lee Jones
2020-11-06 21:49 ` [PATCH 18/19] drm/radeon/atombios_crtc: Remove description of non-existent function param 'encoder' Lee Jones
2020-11-10 22:01 ` Alex Deucher
2020-11-06 21:49 ` [PATCH 19/19] drm/v3d/v3d_drv: Remove unused static variable 'v3d_v3d_pm_ops' Lee Jones
2020-11-06 22:26 ` [PATCH 00/19] [Set 2] Rid W=1 warnings from GPU Sam Ravnborg
2020-11-07 12:18 ` Christian König
2020-11-07 15:07 ` Lee Jones
2020-11-07 17:34 ` Sam Ravnborg
2020-11-07 18:41 ` Lee Jones
2020-11-07 19:29 ` Sam Ravnborg
2020-11-13 7:19 ` Lee Jones
2020-11-13 7:28 ` Alex Deucher
2020-11-13 7:36 ` Lee Jones
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3d5dc164-d26a-5999-1e7f-9cabfdd84c36@ti.com \
--to=tomi.valkeinen@ti.com \
--cc=airlied@linux.ie \
--cc=christian.koenig@amd.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=lee.jones@linaro.org \
--cc=linaro-mm-sig@lists.linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=rob.clark@linaro.org \
--cc=sumit.semwal@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®