From: Sinan Kaya <okaya@kernel.org>
To: Bjorn Helgaas <helgaas@kernel.org>
Cc: linux-pci@vger.kernel.org, linux-arm-msm@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
Bjorn Helgaas <bhelgaas@google.com>,
open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH V5 5/6] PCI: Deprecate pci_reset_bus() and pci_reset_slot() functions
Date: Wed, 18 Jul 2018 15:36:29 -0700 [thread overview]
Message-ID: <3d664a22-7362-07ec-584d-b38829a22ba2@kernel.org> (raw)
In-Reply-To: <20180718223027.GI128988@bhelgaas-glaptop.roam.corp.google.com>
On 7/18/2018 3:30 PM, Bjorn Helgaas wrote:
> On Mon, Jul 02, 2018 at 06:58:54PM -0400, Sinan Kaya wrote:
>> pci_reset_bus() and pci_reset_slot() functions are not being used by
>> any code. Remove them from the kernel in favor of pci_try_reset_bus()
>> and pci_try_reset_slot() functions.
>>
>> Signed-off-by: Sinan Kaya <okaya@codeaurora.org>
>> ---
>> drivers/pci/pci.c | 55 ++---------------------------------------------------
>> include/linux/pci.h | 2 --
>> 2 files changed, 2 insertions(+), 55 deletions(-)
>>
>> diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
>> index a31e6db..7e3f2e9 100644
>> --- a/drivers/pci/pci.c
>> +++ b/drivers/pci/pci.c
>> @@ -4784,9 +4784,9 @@ int pci_probe_reset_slot(struct pci_slot *slot)
>> EXPORT_SYMBOL_GPL(pci_probe_reset_slot);
>>
>> /**
>> - * pci_reset_slot - reset a PCI slot
>> + * __pci_try_reset_slot - Try to reset a PCI slot
>> * @slot: PCI slot to reset
>> - *
>> + *`
>
> Is this "*`" intentional or a typo? I can't find it in kernel-doc.rst
> (but it's full of ` and maybe I missed it).
Typo.
>
> I do see a few other occurrences in the code, although they look like
> typos to me:
>
> $ git grep "\*\`" | grep -v Documentation
> arch/mips/cavium-octeon/octeon-usb.c: *` 0x1 = Big endian
> arch/mips/cavium-octeon/octeon-usb.c: *` 0x1 = Big endian
> drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c:/*`
>
next prev parent reply other threads:[~2018-07-18 22:36 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <1530572336-20296-1-git-send-email-okaya@codeaurora.org>
2018-07-02 22:58 ` [PATCH V5 1/6] PCI: Handle error return from pci_reset_bridge_secondary_bus() Sinan Kaya
2018-07-02 22:58 ` [PATCH V5 2/6] IB/hfi1: Use pci_try_reset_bus() for initiating pci secondary bus reset Sinan Kaya
2018-07-02 22:58 ` [PATCH V5 3/6] PCI: Hide pci_reset_bridge_secondary_bus() from drivers Sinan Kaya
2018-07-02 22:58 ` [PATCH V5 4/6] PCI: Unify try slot and bus reset API Sinan Kaya
2018-07-02 22:58 ` [PATCH V5 5/6] PCI: Deprecate pci_reset_bus() and pci_reset_slot() functions Sinan Kaya
2018-07-18 22:30 ` Bjorn Helgaas
2018-07-18 22:36 ` Sinan Kaya [this message]
2018-07-18 23:29 ` Bjorn Helgaas
2018-07-02 22:58 ` [PATCH V5 6/6] PCI: Rename pci_try_reset_bus() to pci_reset_bus() Sinan Kaya
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3d664a22-7362-07ec-584d-b38829a22ba2@kernel.org \
--to=okaya@kernel.org \
--cc=bhelgaas@google.com \
--cc=helgaas@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome