mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Krish Sadhukhan <krish.sadhukhan@oracle.com>
To: Joerg Roedel <joro@8bytes.org>, Paolo Bonzini <pbonzini@redhat.com>
Cc: Sean Christopherson <sean.j.christopherson@intel.com>,
	Vitaly Kuznetsov <vkuznets@redhat.com>,
	Wanpeng Li <wanpengli@tencent.com>,
	Jim Mattson <jmattson@google.com>,
	kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
	Joerg Roedel <jroedel@suse.de>
Subject: Re: [PATCH 4/4] KVM: SVM: Rename svm_nested_virtualize_tpr() to nested_svm_virtualize_tpr()
Date: Thu, 25 Jun 2020 16:28:21 -0700	[thread overview]
Message-ID: <3d8aa359-a43c-a080-5d62-3bf1300e1ee1@oracle.com> (raw)
In-Reply-To: <20200625080325.28439-5-joro@8bytes.org>


On 6/25/20 1:03 AM, Joerg Roedel wrote:
> From: Joerg Roedel <jroedel@suse.de>
>
> Match the naming with other nested svm functions.
>
> No functional changes.
>
> Signed-off-by: Joerg Roedel <jroedel@suse.de>
> ---
>   arch/x86/kvm/svm/svm.c | 6 +++---
>   arch/x86/kvm/svm/svm.h | 2 +-
>   2 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/arch/x86/kvm/svm/svm.c b/arch/x86/kvm/svm/svm.c
> index e0b0321d95d4..b0d551bcf2a0 100644
> --- a/arch/x86/kvm/svm/svm.c
> +++ b/arch/x86/kvm/svm/svm.c
> @@ -3040,7 +3040,7 @@ static void update_cr8_intercept(struct kvm_vcpu *vcpu, int tpr, int irr)
>   {
>   	struct vcpu_svm *svm = to_svm(vcpu);
>   
> -	if (svm_nested_virtualize_tpr(vcpu))
> +	if (nested_svm_virtualize_tpr(vcpu))
>   		return;
>   
>   	clr_cr_intercept(svm, INTERCEPT_CR8_WRITE);
> @@ -3234,7 +3234,7 @@ static inline void sync_cr8_to_lapic(struct kvm_vcpu *vcpu)
>   {
>   	struct vcpu_svm *svm = to_svm(vcpu);
>   
> -	if (svm_nested_virtualize_tpr(vcpu))
> +	if (nested_svm_virtualize_tpr(vcpu))
>   		return;
>   
>   	if (!is_cr_intercept(svm, INTERCEPT_CR8_WRITE)) {
> @@ -3248,7 +3248,7 @@ static inline void sync_lapic_to_cr8(struct kvm_vcpu *vcpu)
>   	struct vcpu_svm *svm = to_svm(vcpu);
>   	u64 cr8;
>   
> -	if (svm_nested_virtualize_tpr(vcpu) ||
> +	if (nested_svm_virtualize_tpr(vcpu) ||
>   	    kvm_vcpu_apicv_active(vcpu))
>   		return;
>   
> diff --git a/arch/x86/kvm/svm/svm.h b/arch/x86/kvm/svm/svm.h
> index 003e89008331..8907efda0b0a 100644
> --- a/arch/x86/kvm/svm/svm.h
> +++ b/arch/x86/kvm/svm/svm.h
> @@ -365,7 +365,7 @@ void svm_set_gif(struct vcpu_svm *svm, bool value);
>   #define NESTED_EXIT_DONE	1	/* Exit caused nested vmexit  */
>   #define NESTED_EXIT_CONTINUE	2	/* Further checks needed      */
>   
> -static inline bool svm_nested_virtualize_tpr(struct kvm_vcpu *vcpu)
> +static inline bool nested_svm_virtualize_tpr(struct kvm_vcpu *vcpu)
>   {
>   	struct vcpu_svm *svm = to_svm(vcpu);
>   
Should the name be changed to svm_nested_virtualized_tpr ?  Because 
svm_nested_virtualize_tpr implies that the action of the function is to 
virtualize the TPR.

  reply	other threads:[~2020-06-25 23:30 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-25  8:03 [PATCH 0/4] KVM: SVM: Code move follow-up Joerg Roedel
2020-06-25  8:03 ` [PATCH 1/4] KVM: SVM: Rename struct nested_state to svm_nested_state Joerg Roedel
2020-06-25  8:03 ` [PATCH 2/4] KVM: SVM: Add vmcb_ prefix to mark_*() functions Joerg Roedel
2020-06-25  8:03 ` [PATCH 3/4] KVM: SVM: Add svm_ prefix to set/clr/is_intercept() Joerg Roedel
2020-06-25  8:03 ` [PATCH 4/4] KVM: SVM: Rename svm_nested_virtualize_tpr() to nested_svm_virtualize_tpr() Joerg Roedel
2020-06-25 23:28   ` Krish Sadhukhan [this message]
2020-06-25  9:34 ` [PATCH 0/4] KVM: SVM: Code move follow-up Vitaly Kuznetsov
2020-06-25 12:22   ` Paolo Bonzini
2020-06-25 23:29 ` Krish Sadhukhan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3d8aa359-a43c-a080-5d62-3bf1300e1ee1@oracle.com \
    --to=krish.sadhukhan@oracle.com \
    --cc=jmattson@google.com \
    --cc=joro@8bytes.org \
    --cc=jroedel@suse.de \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pbonzini@redhat.com \
    --cc=sean.j.christopherson@intel.com \
    --cc=vkuznets@redhat.com \
    --cc=wanpengli@tencent.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®