mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Thomas Weißschuh" <linux@weissschuh.net>
To: Mark Pearson <mpearson-lenovo@squebb.ca>
Cc: hdegoede@redhat.com, markgross@kernel.org,
	markpearson@lenovo.com, pobrn@protonmail.com,
	linux-kernel@vger.kernel.org,
	platform-driver-x86@vger.kernel.org
Subject: Re: [PATCH v4 2/4] platform/x86: think-lmi: use correct possible_values delimiters
Date: Mon, 20 Mar 2023 15:22:09 +0000	[thread overview]
Message-ID: <3df8ca69-e2a4-49d1-9c5c-8e6ff8bb0f96@t-8ch.de> (raw)
In-Reply-To: <20230320003221.561750-2-mpearson-lenovo@squebb.ca>

Hi Mark,

Thanks for the series!
For all of it:

Reviewed-by: Thomas Weißschuh <linux@weissschuh.net>

If you decide to reroll it, one more nitpick below.

On Sun, Mar 19, 2023 at 08:32:19PM -0400, Mark Pearson wrote:
> firmware-attributes class requires that possible values are delimited
> using ';' but the Lenovo firmware uses ',' instead.
> Parse string and replace where appropriate.
> 
> Suggested-by: Thomas Weißschuh <linux@weissschuh.net>
> Fixes: a40cd7ef22fb ("platform/x86: think-lmi: Add WMI interface support on Lenovo platforms")
> Signed-off-by: Mark Pearson <mpearson-lenovo@squebb.ca>
> ---
> Changes in v4
>  - Moved earlier in the series as recommended
>  - used strreplace function as recommended
> Changes in v3: 
>  - New patch added to the series. No v1 & v2.
> 
>  drivers/platform/x86/think-lmi.c | 9 ++++++++-
>  1 file changed, 8 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/platform/x86/think-lmi.c b/drivers/platform/x86/think-lmi.c
> index a765bf8c27d8..53f34b1adb8c 100644
> --- a/drivers/platform/x86/think-lmi.c
> +++ b/drivers/platform/x86/think-lmi.c
> @@ -954,7 +954,7 @@ static ssize_t type_show(struct kobject *kobj, struct kobj_attribute *attr,
>  
>  	if (setting->possible_values) {
>  		/* Figure out what setting type is as BIOS does not return this */
> -		if (strchr(setting->possible_values, ','))
> +		if (strchr(setting->possible_values, ';'))
>  			return sysfs_emit(buf, "enumeration\n");

If you make this patch the first on of the series it would
* make the hunk above unnecessary.
* make it easier to backport if somebody wants do do so.
* make the then second patch easier to read as it would not introduce
  "incorrect" code that needs a fix-up in the following commit.

>  	}
>  	/* Anything else is going to be a string */
> @@ -1413,6 +1413,13 @@ static int tlmi_analyze(void)
>  				pr_info("Error retrieving possible values for %d : %s\n",
>  						i, setting->display_name);
>  		}
> +		/*
> +		 * firmware-attributes requires that possible_values are separated by ';' but
> +		 * Lenovo FW uses ','. Replace appropriately.
> +		 */
> +		if (setting->possible_values)
> +			strreplace(setting->possible_values, ',', ';');
> +
>  		kobject_init(&setting->kobj, &tlmi_attr_setting_ktype);
>  		tlmi_priv.setting[i] = setting;
>  		kfree(item);
> -- 
> 2.39.2
> 

  reply	other threads:[~2023-03-20 15:30 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-03-20  0:32 [PATCH v4 1/4] platform/x86: think-lmi: add missing type attribute Mark Pearson
2023-03-20  0:32 ` [PATCH v4 2/4] platform/x86: think-lmi: use correct possible_values delimiters Mark Pearson
2023-03-20 15:22   ` Thomas Weißschuh [this message]
2023-03-22 14:22     ` Hans de Goede
2023-03-20  0:32 ` [PATCH v4 3/4] platform/x86: think-lmi: only display possible_values if available Mark Pearson
2023-03-20  0:32 ` [PATCH v4 4/4] platform/x86: think-lmi: Add possible_values for ThinkStation Mark Pearson
2023-03-20 13:56 ` [PATCH v4 1/4] platform/x86: think-lmi: add missing type attribute Hans de Goede
2023-03-20 13:57   ` Hans de Goede
2023-03-20 13:58     ` Mark Pearson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3df8ca69-e2a4-49d1-9c5c-8e6ff8bb0f96@t-8ch.de \
    --to=linux@weissschuh.net \
    --cc=hdegoede@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=markgross@kernel.org \
    --cc=markpearson@lenovo.com \
    --cc=mpearson-lenovo@squebb.ca \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=pobrn@protonmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®