mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "David Hildenbrand (Arm)" <david@kernel.org>
To: Yeoreum Yun <yeoreum.yun@arm.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Lorenzo Stoakes <ljs@kernel.org>, Zi Yan <ziy@nvidia.com>,
	Baolin Wang <baolin.wang@linux.alibaba.com>,
	"Liam R. Howlett" <liam@infradead.org>,
	Nico Pache <nico.pache@linux.dev>,
	Ryan Roberts <ryan.roberts@arm.com>, Dev Jain <dev.jain@arm.com>,
	Barry Song <baohua@kernel.org>, Lance Yang <lance.yang@linux.dev>,
	Usama Arif <usama.arif@linux.dev>,
	Vlastimil Babka <vbabka@kernel.org>,
	Mike Rapoport <rppt@kernel.org>,
	Suren Baghdasaryan <surenb@google.com>,
	Michal Hocko <mhocko@suse.com>, Shuah Khan <shuah@kernel.org>,
	Kevin Brodsky <kevin.brodsky@arm.com>,
	linux-mm@kvack.org, linux-kselftest@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v8 3/4] kselftest: mm: integrate huge page checks
Date: Thu, 1 Oct 2026 13:40:06 +0200	[thread overview]
Message-ID: <3e03425b-7962-4c69-93aa-96168fd7168e@kernel.org> (raw)
In-Reply-To: <aruMgm8UZ_t2V_wh@e129823.arm.com>

On 9/29/26 12:01, Yeoreum Yun wrote:
> On Tue, Sep 29, 2026 at 10:07:37AM +0200, David Hildenbrand (Arm) wrote:
>> On 9/24/26 21:11, Yeoreum Yun wrote:
>>> check_large_folios() only checks for large folios without distinguishing
>>> between anonymous and file-backed huge pages.
>>>
>>> To add huge page type checking, integrate the huge page checks into
>>> __check_huge():
>>>
>>>   1. If hpage_size == pmd_pagesize, check PAGE_IS_HUGE instead of using
>>>      check_large_folios(), since only the mapping type matters. This
>>>      identifies PMD-mapped huge pages.
>>>
>>>   2. Otherwise, use check_large_folios() to detect large folios. This
>>>      covers mTHP cases.
>>>
>>>   3. Check the folio flags according to the huge page type.
>>>
>>> Suggested-by: David Hildenbrand (Arm) <david@kernel.org>
>>> Suggested-by: Zi Yan <ziy@nvidia.com>
>>> Signed-off-by: Yeoreum Yun <yeoreum.yun@arm.com>
>>> ---
>>
>> Instead of merging both things (detecting mapping vs. detecting anon vs. file),
>> could we simply perform the anon vs. file change separately?
>>
>> Doing another pagemap walk that focuses on that should end up with something
>> that is easier to read.
> 
> Okay. I'll change like below in next-spin:
> 
> -------&<-------
> 
> @@ -411,57 +400,78 @@ static bool check_huge_type(uint64_t categories, enum check_huge_type type)
>         return false;
>  }
> 
> -static bool __check_pmd_huge(void *addr, size_t len, int nr_hpages,
> -                 uint64_t hpage_size, enum check_huge_type type)
> +static bool __check_huge(void *addr, size_t len, int nr_hpages,
> +               uint64_t hpage_size, enum check_huge_type type)
>  {
>  {
> -       int pagemap_fd;
> +       bool ret = false;
> +       int pagemap_fd, kpageflags_fd;
>         int nr_pmd_mappings = 0;
> +       uint64_t pmd_pagesize, scan_mapping_size;
>         uint64_t categories;
> +       unsigned long pfn;
> +       bool check_pmd_mapping, allow_nonpresent;
>         char *start = addr;
>         char *end = start + len;
> 
> +       pmd_pagesize = read_pmd_pagesize();
> +       if (!pmd_pagesize)
> +               ksft_exit_fail_msg("reading PMD pagesize failed\n");
> +
> +       check_pmd_mapping = hpage_size == pmd_pagesize;
> +       scan_mapping_size = (nr_hpages > 0) ? hpage_size : psize();
> +       /* Some mTHP tests check a partially populated PMD-sized range. */
> +       allow_nonpresent = (uint64_t)nr_hpages * hpage_size < len;
> +
>         pagemap_fd = open(PAGEMAP_PATH, O_RDONLY);
>         if (pagemap_fd < 0)
>                 ksft_exit_fail_perror("open pagemap");
> 
> -       for (; start < end; start += hpage_size) {
> +       kpageflags_fd = open(KPAGEFLAGS_PATH, O_RDONLY);
> +       if (kpageflags_fd < 0)
> +               ksft_exit_fail_perror("open kpageflags");
> +
> +       for (; start < end; start += scan_mapping_size) {
>                 categories = pagemap_scan_get_categories(pagemap_fd, start);
> -               if (!(categories & PAGE_IS_HUGE))
> +               pfn = pagemap_get_pfn(pagemap_fd, start);
> +               if (pfn == -1UL) {
> +                       if (!allow_nonpresent)
> +                               goto out;
>                         continue;
> -               if (check_huge_type(categories, type))
> +               }
> +               if (!check_huge_type(categories, type))
> +                       goto out;
> +       }
> +
> +       if (!check_pmd_mapping) {
> +               ret = check_large_folios(pagemap_fd, kpageflags_fd,
> +                               addr, len, nr_hpages, hpage_size);
> +               goto out;
> +       }
> +
> +       for (start = addr; start < end; start += scan_mapping_size) {
> +               categories = pagemap_scan_get_categories(pagemap_fd, start);
> +               if (categories & PAGE_IS_HUGE)
>                         nr_pmd_mappings++;
>         }
> -       close(pagemap_fd);
> 
> -       return nr_hpages == nr_pmd_mappings;
> +       if (nr_pmd_mappings != nr_hpages)
> +               goto out;
> +       ret = true;
> +
> +out:
> +       close(pagemap_fd);
> +       close(kpageflags_fd);
> +       return ret;
>  }
> 

I'd leave existing __check_huge() mostly alone, and instead have an additional
function that checks the type.

Essentially a __check_type() or sth that we run after the large folio / pmd check.

-- 
Cheers,

David

  reply	other threads:[~2026-10-01 11:40 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-24 19:11 [PATCH v8 0/4] kselftest: mm: fix some failure of split_huge_page_test Yeoreum Yun
2026-09-24 19:11 ` [PATCH v8 1/4] kselftest: mm: prevent random failure of huge page split for khugepaged Yeoreum Yun
2026-09-25 12:10   ` Sarthak Sharma
2026-09-25 14:25     ` Yeoreum Yun
2026-09-24 19:11 ` [PATCH v8 2/4] kselftest: mm: replace usage of /proc/self/smaps for __check_pmd_huge() Yeoreum Yun
2026-09-25 12:38   ` Sarthak Sharma
2026-09-25 14:23     ` Yeoreum Yun
2026-09-28 12:46       ` David Hildenbrand (Arm)
2026-09-29  6:36   ` Baolin Wang
2026-09-29 15:20   ` Zi Yan
2026-09-24 19:11 ` [PATCH v8 3/4] kselftest: mm: integrate huge page checks Yeoreum Yun
2026-09-25 12:54   ` Sarthak Sharma
2026-09-29  6:45   ` Baolin Wang
2026-09-29  8:07   ` David Hildenbrand (Arm)
2026-09-29 10:01     ` Yeoreum Yun
2026-10-01 11:40       ` David Hildenbrand (Arm) [this message]
2026-10-01 13:52         ` Yeoreum Yun
2026-10-01 19:59           ` David Hildenbrand (Arm)
2026-10-01 21:09             ` Yeoreum Yun
2026-09-24 19:11 ` [PATCH v8 4/4] kselftest: mm: remove check_huge_shmem() Yeoreum Yun
2026-09-25 12:56   ` Sarthak Sharma

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3e03425b-7962-4c69-93aa-96168fd7168e@kernel.org \
    --to=david@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=baohua@kernel.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=dev.jain@arm.com \
    --cc=kevin.brodsky@arm.com \
    --cc=lance.yang@linux.dev \
    --cc=liam@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=nico.pache@linux.dev \
    --cc=rppt@kernel.org \
    --cc=ryan.roberts@arm.com \
    --cc=shuah@kernel.org \
    --cc=surenb@google.com \
    --cc=usama.arif@linux.dev \
    --cc=vbabka@kernel.org \
    --cc=yeoreum.yun@arm.com \
    --cc=ziy@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®