Hi Andrew, as said (see 0/2) this patch doesn't change any code, just moves stuff from the "mach_resources.h" header to a "std_resources.c" subarch specific file, and introduces a "std_resources.h" header for the prototypes. Hope those names are okay. I first put this in the subarch "setup.c", noticed it seemed very out of place there, moved it to "legacy_resources.[ch]", found that name to be a bit long, renamed them to "legacy.[ch]", found that to be too generic a name, and settled on this one... Rene.