From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 5405EECAAD3 for ; Thu, 15 Sep 2022 02:44:51 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S230023AbiIOCos (ORCPT ); Wed, 14 Sep 2022 22:44:48 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:46046 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S229669AbiIOCoo (ORCPT ); Wed, 14 Sep 2022 22:44:44 -0400 Received: from out30-131.freemail.mail.aliyun.com (out30-131.freemail.mail.aliyun.com [115.124.30.131]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id A6951A1B0 for ; Wed, 14 Sep 2022 19:44:41 -0700 (PDT) X-Alimail-AntiSpam: AC=PASS;BC=-1|-1;BR=01201311R101e4;CH=green;DM=||false|;DS=||;FP=0|-1|-1|-1|0|-1|-1|-1;HT=ay29a033018045176;MF=xhao@linux.alibaba.com;NM=1;PH=DS;RN=7;SR=0;TI=SMTPD_---0VPqlKcb_1663209877; Received: from 30.240.97.215(mailfrom:xhao@linux.alibaba.com fp:SMTPD_---0VPqlKcb_1663209877) by smtp.aliyun-inc.com; Thu, 15 Sep 2022 10:44:38 +0800 Message-ID: <408fbc89-8711-0ea2-16e7-99b746e1f09e@linux.alibaba.com> Date: Thu, 15 Sep 2022 10:44:37 +0800 MIME-Version: 1.0 User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:102.0) Gecko/20100101 Thunderbird/102.2.1 Subject: Re: [PATCH] mm/hugetlbfs: use macro SZ_1K to replace 1024 To: Al Viro Cc: akpm@linux-foundation.org, linux-mm@kvack.org, linux-kernel@vger.kernel.org, mike.kravetz@oracle.com, songmuchun@bytedance.com, SeongJae Park References: <20220914115723.38271-1-xhao@linux.alibaba.com> From: haoxin In-Reply-To: Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 8bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org 在 2022/9/15 上午12:43, Al Viro 写道: > On Wed, Sep 14, 2022 at 07:57:23PM +0800, Xin Hao wrote: >> Using macro SZ_1K in hugetlbfs_show_options() has no any functional >> changes, just makes code more readable. > Why is it any more readable that way? The main purpose of this code is to convert size to 'K', and 'M'. I think using SZ_1k does look more appropriate than 1024, that's all. >> Signed-off-by: Xin Hao >> --- >> fs/hugetlbfs/inode.c | 6 +++--- >> 1 file changed, 3 insertions(+), 3 deletions(-) >> >> diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c >> index f7a5b5124d8a..9b9784ffe8de 100644 >> --- a/fs/hugetlbfs/inode.c >> +++ b/fs/hugetlbfs/inode.c >> @@ -1023,10 +1023,10 @@ static int hugetlbfs_show_options(struct seq_file *m, struct dentry *root) >> if (sbinfo->max_inodes != -1) >> seq_printf(m, ",nr_inodes=%lu", sbinfo->max_inodes); >> >> - hpage_size /= 1024; >> + hpage_size /= SZ_1K; >> mod = 'K'; >> - if (hpage_size >= 1024) { >> - hpage_size /= 1024; >> + if (hpage_size >= SZ_1K) { >> + hpage_size /= SZ_1K; >> mod = 'M'; >> } >> seq_printf(m, ",pagesize=%lu%c", hpage_size, mod); >> -- >> 2.31.0